Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Probleme mit Linux im Netzwerk

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Netzwerk
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
FormA
Gast





BeitragVerfasst am: 12. Feb 2002 23:58   Titel: Probleme mit Linux im Netzwerk

Habe folgendes Problem mit Linux :

Linux läd beim Start die korrekten Treiber für die Netzwerkkarte (NE2000 PCI), es kommen keine Fehlermeldungen, weder beim Start noch beim Shutdown. Aber bei meinem Hub geht das Lämpchen für die bestehende Verbindung nicht an. Ich bekomme auch keine Antwort auf ein Ping.
Ich hab parallel zu Linux auf dem gleichen Rechner Windows 2000 laufen und das Lämpchen geht jedes mal an -> es kann kein Hardware Fehler sein.

Habe Netzwerkkarte schon in einen anderen PCI Slot umgesteckt -> immer noch das gleiche Problem

Ich bin ein Linux Anfänger, habe deswegen schon etliche Bücher nach diesem Problemfall durchsuucht aber nirgens eine Problemlösung gefunden.
Kann mir hier jemand helfen ???
 

Stefan
Gast





BeitragVerfasst am: 13. Feb 2002 7:34   Titel: Re: Probleme mit Linux im Netzwerk

poste doch bitte mal die Ausgaben von

ifconfig
route -n

Vielleicht werden wir ja dann hier ein wenig schlauer.
Merkwuerdig finde ich allerdings dass mit den Laempchen. Bei mir
brennt das Laempchen sobald ich einen physikalischen Link aufgebaut
habe, und dazu brauche ich aber keine Software/Treiber.
Wir schauen einfach mal, vielleicht findet sich ja was.

Stefan
 

FormA
Gast





BeitragVerfasst am: 13. Feb 2002 13:16   Titel: Re: Probleme mit Linux im Netzwerk

So, hier mal die Angaben, ich kann ehrlich gesagt gar nix damit anfangen ... :(

----------
linux:~ # ifconfig
eth0 Protokoll:Ethernet Hardware Adresse 00:50:BF:00:54:C1
inet Adresse:192.168.6.15 Bcast:192.168.6.255 Maske:255.255.255.0
inet6 Adresse: fe80::250:bfff:fe00:54c1/10 Gültigkeitsbereich:Verbindu
ng
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:10 dropped:0 overruns:0 carrier:20
Kollisionen:170 Sendewarteschlangenlänge:100
RX bytes:0 (0.0 b) TX bytes:744 (744.0 b)
Interrupt:10 Basisadresse:0xe800

lo Protokoll:Lokale Schleife
inet Adresse:127.0.0.1 Maske:255.0.0.0
inet6 Adresse: ::1/128 Gültigkeitsbereich:Maschine
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:14 errors:0 dropped:0 overruns:0 frame:0
TX packets:14 errors:0 dropped:0 overruns:0 carrier:0
Kollisionen:0 Sendewarteschlangenlänge:0
RX bytes:732 (732.0 b) TX bytes:732 (732.0 b)
----------
----------
linux:~ # route -n
Kernel IP Routentabelle
Ziel Router Genmask Flags Metric Ref Use Iface
192.168.6.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
0.0.0.0 192.168.6.1 0.0.0.0 UG 0 0 0 eth0
----------


Das mit dem Hub Lämpchen hat mir schon mal jemand gesagt, aber anscheinend is meiner da wohl ein bisschen anders gebaut, ka :confused:
 

Stefan
Gast





BeitragVerfasst am: 13. Feb 2002 13:38   Titel: Re: Probleme mit Linux im Netzwerk

Und schon ein Stueckchen weiter:

> TX packets:0 errors:10 dropped:0 overruns:0 carrier:20
> Kollisionen:170 Sendewarteschlangenlänge:100
> RX bytes:0 (0.0 b) TX bytes:744 (744.0 b)

170 Kollisionen, und keine empfangenen Pakete.

Hmm, leider kenne ich mich in die Richtung nicht sooo gut aus,
aber haeufig ist es der Treiber was dran schuld ist (wenns nicht die Hardware
ist).

Gibt er in /var/log/messages was aus, Fehlermeldungen, waehrend du pingst?
Was bringt er beim booten wenn er den Treiber fuer die Netzwerkkarte laedt (kann man
im Nachhinein ueber Eingabe des Befehls dmesg auch noch rausbekommen),
und was ists fuer ne Netzwerkkarte (RTL oder SIS Chip oder ganz was anderes).


stefan
 

FormA
Gast





BeitragVerfasst am: 13. Feb 2002 23:48   Titel: Re: Probleme mit Linux im Netzwerk

Uiuiui das hört sich gar nicht gut an :(

Also wie oben schon erwähnt kommt weder beim Start noch beim Herunterfahren ne Fehlermeldung. Hardware Fehler is auch auszuschließen da es mit dem parallel laufenden Win 2000 prima funktioniert.

Die Netzwerkkarte heißt (laut win2k Geräte Manager) Realtec RTL8029(AS)-PCI-Ethernetadapter.

Konnte eigentlich keine Fehlermeldungen erkennen während ich gepingt hab ..... hmmmm ...
 

Stefan
Gast





BeitragVerfasst am: 14. Feb 2002 8:34   Titel: Re: Probleme mit Linux im Netzwerk

Hmm...

hat die Karte BNC & RJ45 Anschluss? Hast du
die Moeglichkeit mal den BNC Anschluss zu testen.

Ansonsten versuch mal die Realtek Diagnose Tools zu benutzen um alle Auto-Einstellungen
auf spezielle Einstellungen zu forcen.

Linktype : 100Mbit Halfduplex
Interfacetype: Twisted Pair
usw.


Hier gibts entsprechende Tools fuer linux:
http://www.scyld.com/diag/index.html


Stefan
 

Simon
Gast





BeitragVerfasst am: 15. Feb 2002 13:28   Titel: Re: Probleme mit Linux im Netzwerk

Hallo, habe mir gerade mal angesehen was hier los ist und festgestellt das ich 'fast' das gleiche Problem (ohne Lösung) habe...
(Ist auf Seite2 des Netzwerkforums)
Wie kann ich eigentlich
--
Linktype : 100Mbit Halfduplex
Interfacetype: Twisted Pair
usw.
--
solche einstellungen forcen? Bestimmt nur über die Software, oder? Da MeineKarte von 3Com ist (10/100mbit Fast Ethernet TP) werde ich wohl mal nach einem Tool Suchen, oder kann ich das irgendwie in configdateien speichern??
(So wirklich viel Ahnung habe ich halt auch nicht.
MFG Simon
 

bonzo



Anmeldungsdatum: 27.07.2001
Beiträge: 12
Wohnort: Garrel

BeitragVerfasst am: 15. Feb 2002 22:53   Titel: Re: Probleme mit Linux im Netzwerk

@simon
für die 3com karten der serie 3c9xxc gibt es ein tool bei 3com. wenn du den treiber für diese karte herunterlädst, musst du darauf achten, das du auch die disk2 mitnimmst. diese datei dann entpacken und dort gibt es dann ein tool namens 3c90xcfg. am besten fährst du den rechner mit einer win98 bootdisk hoch und dann die 3com disk rein. dann einfach 3c90xcfg eingeben und schon bist du in rom der netzwerkkarte um dort die einstellungen zu überprüfen.

@FormA
bei der realtek karte kenn ich leider nicht son tool, sorry!
_________________
----------------------
----------------------
MfG
Bonzo
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Netzwerk Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy