Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Nochmal wegen Router

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Netzwerk
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Borg
Gast





BeitragVerfasst am: 28. Apr 2002 16:47   Titel: Nochmal wegen Router

Ich habe unter Suse 8.0 die Möglichkeit, wenn ich auf Yastmodule und dann auf Netzwerk erweitert klicke auf Routing zu klicken.

Da muss man dann eine Standardgateway angeben. Dort habe ich die IP meiner Netzwerkarte angegeben, die mit dem DSL-Modem verbunden ist. In der Route-Datei wird dann folgendes eingetragen:

default 192.168.0.21 - -

Mein Netzwerk ist mit der anderen Netzwerkarte verbunden. Die hat die IP 192.168.0.20. Der Client hat die IP 192.168.0.22 und alle nutzen die Netzwerkmaske 255.255.255.0.

Was muss ich noch in die Route-Datei eintragen, um den Client ins Internet routen zu können?
Was muss noch aktiviert werden? Firewall?

Muss der Proxy (squid) beim routen deaktiviert werden? Oder muss ich den anlassen?

Ich hab bis jetzt alles konfiguriert, so wie in etlichen Dokumentationen beschrieben und verschiedene Wege ausprobiert. Nichts klappt wirklich.
Wenn ich vom Client aus die Netzwerkkarte mit dem DSL anpinge klappt alles super, nur eine Internet-IP (wenn ich z.B. die vom Internetprovider nehme) kann ich vom Client aus nicht erreichen.

So...was fehlt Euch noch an Infos? Hoffe Ihr könnt diemal was mit der Beschreibung anfangen.

Liebe Grüße...
 

cptchaos



Anmeldungsdatum: 06.06.2000
Beiträge: 129

BeitragVerfasst am: 28. Apr 2002 17:10   Titel: Re: Nochmal wegen Router

Moin moin,

So wie ich es verstanden habe, willst Du dein Heimrechner mit einem Router/Gateway über DSL gemeinsam ins Internet bringen.

Das hat mit Routing nichts zu tun, da Du für deine Hosts (Arbeitsplätze/Heimrechner) im privaten Netz keine offizielle IP bekommst. Du hast diesen eine interne locale IP verteilt, dein Gateway muß also stellvertretend für deine Hosts die Anfrage stellen und die Pakete intern wieder auflösen.
Was Du benötigst ist NAT (Network Adress Translation) auch unter Masquering bekannt, schaue dir doch einmal die private Firewall von SuSE an (ist bei 8.0 dabei), die sollte sowas können.

Den Squid kannst Du ruhig aktiviert lassen, dieses ist ein HTTP Proxy mit cache Funktion. Was dazu noch fehlen würde ist ein stellvertretender DNS Dienst, sonst klappt die Namensauflösung nicht. Deine Hosts müssten dann so konfiguriert werden das sie auch die internen Dienste nutzen. (DNS und HTTP Proxy Einstellung bei den Clients)
Dann würde zumindestens HTTP schon mal funktionieren.

Wenn der Rechner nur als Router/Gateway arbeiten soll bietet sich vieleicht eine andere Distri an :

http://fli4l.de

Das ist ein Disketten Router, für den es einen Windows Client zur konfiguration gibt. Eventuell ist dieser für dich besser geeignet.

MfG Marek
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

Borg
Gast





BeitragVerfasst am: 28. Apr 2002 20:43   Titel: Re: Nochmal wegen Router

Ich hab nochmal geguckt. Aber auf alle Fälle kommt man nicht drum herum eine Route zu setzen. Und da hab ich halt Probleme mit, weil ich nicht weiß, welche IP wohin.

Da wird immer was von IP der Providers geschrieben, aber ich bin doch bei t-online und bekomm immer ne neue IP von denen???

Es muss an der Route liegen, weil wenn ich vom Client aus ping www.irgendeinedomain.de eingebe bekomme ich zwar die IP von der gepingten Domain angezeigt, aber mein Ruf kommt nich zurück.

Vielleicht ist ja einer so lieb und schreibt mir mit den angegebenen IP´s mal so eine route-Datei *liebguck*
 

Sven
Gast





BeitragVerfasst am: 29. Apr 2002 12:42   Titel: Re: Nochmal wegen Router

Du brauchst in die /etc/route.conf überhaupt nichts reinschreiben, wenn Du DSL hast. Bei mir ist sie komplett leer und es funzt.
 

Torsten
Gast





BeitragVerfasst am: 29. Apr 2002 13:21   Titel: Re: Nochmal wegen Router

Mit der beschriebenen Konfiguration befinden sich alle deine Rechner im gleichen Netzsegment und Datenpakete im gleichen Netz werden nicht geroutet ... das ist kein Linux-, sondern ein Netzkonfigurationsproblem, das unter jedem BS auftreten kann. Ändere Deine IP-Adressen, vergib an die nach außen gerichtete NIC z.B. 192.168.1.1 und versuch dann zwischen zwei Netzsegmenten zu routen.

Schau mal hier nach, da steht genau, was man einrichten muß, um den Effekt zu erzielen, den Du erzielen willst

http://sdb.suse.de/de/sdb/html/hoe_adsl_manuell_pppoe.html

Da steht auch, daß man kein Default-Gateway eintragen darf. Deine Idee mit dem Hardwarerouter (andere Frage)ist nicht schlecht, mein Netz läuft auch über einen solchen, nur daß dahinter gleich der Linuxserver steht, der den Proxy, Sendmail, POP3, Fileserverdienste (Samba) und Routing für die Windowskisten meiner Familienmitglieder bietet. Zu Beginn wollte ich das auch so haben wie Du, aber zwei Rechner wollte ich nicht ständig am Laufen haben und Samba auf 'ner Firewall bzw. dem Gateway war mir zu heiß.

Übrigens, wenn der Proxy läuft, brauchst Du keinen Router mehr ... dann sollten doch alle über den Proxy surfen und keiner Deiner anderen Rechner muß mehr direkte Anfragen ins Internet schicken.

CU
 

arno kuenburg
Gast





BeitragVerfasst am: 30. Apr 2002 22:56   Titel: Re: Nochmal wegen Router

hi
ich kenn mich mit dsl nicht aus (hab kabel) aber ich glaub damit deine clients surfen können und so musst du
masquerading und ip forwarding einschalten

echo 1 > /proc/sys/net/ipv4/ip_forward
iptables -A POSTROUTING -t nat -s 192.168.0.0/24 -j MASQUERADE
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Netzwerk Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy