Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
LAMP (Apache 2.036 und PHP 4.21)

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Netzwerk
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Sebastian
Gast





BeitragVerfasst am: 17. Mai 2002 9:21   Titel: LAMP (Apache 2.036 und PHP 4.21)

Mahlzeit

Evtl. kann mir ja jemand von euch helfen. Ich versuche krampfhaft PHP4 zum aktuellen Apache 2.0.3.6 zu installieren, was aber leider fehlschlägt.

Der Apache geht wunderbar und wurde mittels --ennable-so auch koniguriert. Nun möchte ich PHP 4.21 installieren, nur schlägt das mit einem Fehler in apxs fehl.

Dazu übergeb ich unter anderem beim ./configure den Parameter --with-apxs2.

Der Pfad wird auch gefunden nur kommt nach ein paar Zeilen später dann die etwas nichtssagende Fehlermeldung das apxs nicht weiterarbeiten kann. Entweder ich hätte kein Perl installiert (ist aber) oder der Pfad würde nicht stimmen (muss es ja aber da apxs ja versucht was zu machen) oder das ich vergessen hätte Apache 2 mit --enable-so zu kompilieren was ja aber auch gemacht wurde. Der Fehler sieht genau so aus als wenn man apxs per Hand ohne Parameter starten würde, wo einem dann die Optionen angezeigt werden.

Ich wollt nur mal fragen ob Bugs bekannt sind oder evtl. ein fehlerhaftes Script oder ob jemand ein ähnliches Problem lösen könnte oder gar eine direkte Anleitung für Apache 2 und PHP4 im Netz schon irgendwo existiert ...


Bitte helft ...
 

moses
Gast





BeitragVerfasst am: 17. Mai 2002 12:45   Titel: Re: LAMP (Apache 2.036 und PHP 4.21)

Hi,

hast du auch pfad zu apxs angegeben. Etwa:
./configure --with-apxs2=/usr/local/apache/sbin/apxs ?
Wenn du nichts angibst, nimmt das Script standartwert. Und da liegt nichts.
Hast du mod_so in Apache einkompiliert?
Ansonsten momentan sieht düster mit modulen für Apache 2.0.x. Mit 1.3.24 funzt aber alles Prima.

CU
moses
 

Sebastian
Gast





BeitragVerfasst am: 17. Mai 2002 16:09   Titel: Re: LAMP (Apache 2.036 und PHP 4.21)

Jepp der Pfad zu apxs stimmt, er kanns ja auch aufrufen und wenn ich httpd -l eingebe ist http_core und mod_so mit drinn.

Keine Ahnung wo was nicht stimmt. Ich werd nacher nochmal die 2.0.35 versuchen dort war noch einiges anders als in 2.0.36 angeblich gings dort ... Aber toll iser schon der neue Apache Vor allem schnell ...
 

Sebastian
Gast





BeitragVerfasst am: 17. Mai 2002 22:57   Titel: Re: LAMP (Apache 2.036 und PHP 4.21)

Grrrr, is doch zu doof. Also erstmal: es funktioniert !!!!

Das Problem war ich hab beim Apache basteln --enable-layout=SuSE mit angegeben. Ich hab zwar ne SuSE 6.4 am laufen aber die Pfade in config.layout stimmen dennoch nicht ! Daher die Probleme.

Am besten einen eigenen neuen Abschnitt mit den gewünschten Pfade eintragen und es geht. Scheint aber nur über DSo zu funktionieren. Als inetd funktioniert Apache ab 2.0.x leider auch nicht mehr
 

Sebastian
Gast





BeitragVerfasst am: 17. Mai 2002 23:00   Titel: Re: LAMP (Apache 2.036 und PHP 4.21)

Achso, fast hät ichs vergessen. Ich bastel bis zum 27.Mai n kleines LAMP HowTo zu Apache 2.0.36 und PHP 4.2.1 und pack das auf meine Page (http://www.ihc-computerclub.de), wer mag kann das hier natürlich verwenden, bitte aber zumindest mit Angabe meiner Page )

Thx.
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Netzwerk Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy