Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
ping: sendmsg: Invalid argument

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Netzwerk
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
annette



Anmeldungsdatum: 12.05.2002
Beiträge: 16

BeitragVerfasst am: 22. Mai 2002 17:45   Titel: ping: sendmsg: Invalid argument

Hi!

Ich hab Suse Linux 7.3 Kernel 2.4 und wähle mich über T-DSL ins Internet ein. Der Linuxrechner dient als Router und ist vernetzt mit einem Windows-Rechner. Immer nach der ersten Einwahl ins Internet tritt sowohl vom Server als auch vom Client folgendes Problem beim Pinging auf:


#ping –c5 216.xx.xxx.xx
PING 216.xx.xxx.xx (2xx.xx.xxx.xx) from 192.168.99.1 : 56(84) bytes of data.
ping: sendmsg: Invalid argument
ping: sendmsg: Invalid argument
ping: sendmsg: Invalid argument

Beim nächsten Ping ist wieder alles okay. Kann mir jemand sagen woran das liegt? Bitte um Hilfe.


Gruß,
Annette
 
Benutzer-Profile anzeigen Private Nachricht senden

nano
Gast





BeitragVerfasst am: 22. Mai 2002 19:35   Titel: Re: ping: sendmsg: Invalid argument

Hi Annette,
stehen denn in den Log-Dateien (z.B. /var/log/messages)
irgendwelche Fehlermeldungen?
Funktioniert ping nur nicht nach außen, oder kannst du
z.B. auch deinen Server nicht von deinem
Client anpingen?

Gruß,
nano
 

annette



Anmeldungsdatum: 12.05.2002
Beiträge: 16

BeitragVerfasst am: 22. Mai 2002 20:11   Titel: Re: ping: sendmsg: Invalid argument

Hi Nano!

Es passiert nur nach außen, intern ist alles okay.
Was mich etwas stutzig macht, ist folgendes:

eth0 für T-DSL: 192.168.22.1
eth1 für internes Netzwerk: 192.168.3.1

Beim ersten Ping nach außen versucht er es aber über 192.168.99.1 <------ !!!!
Vor dem ersten Ping hat ppp0 192.168.99.1; nach dem ersten Ping die korrekte IP.

Irgendwo muß mir beim Konfigurieren ein Fehler unterlaufen sein. Aber wo?

Gruß,
Annette
 
Benutzer-Profile anzeigen Private Nachricht senden

nano
Gast





BeitragVerfasst am: 22. Mai 2002 21:09   Titel: Re: ping: sendmsg: Invalid argument

Hi Annette,
tritt das Problem nur bei ping auf?
Oder geht erst mal gar nix nach außen?

Gruß,
nano
 

annette



Anmeldungsdatum: 12.05.2002
Beiträge: 16

BeitragVerfasst am: 22. Mai 2002 22:24   Titel: Re: ping: sendmsg: Invalid argument

Hi Nano,

das Problem tritt generell beim Zugriff aufs Internet auf, da diese blöde IP (192.168.99.1) erst beim zweiten Zugriff aufs Internet durch die korrekte IP ersetzt wird.


/etc/ppp/peers/demand enthält übrigens folgenden Eintrag, wieso auch immer:

192.168.99.1:192.168.99.99

ipcp-accept-local
ipcp-accept-remote



Gruß,
Annette
 
Benutzer-Profile anzeigen Private Nachricht senden

Nick
Gast





BeitragVerfasst am: 23. Mai 2002 20:17   Titel: Re: ping: sendmsg: Invalid argument

Hallo da draussen...

ich habe hier eine aehnliche config, da tritt es auch auf:
suse 7.3, kernel 2.4.18 (den original, selbst kompiliert), allerdings gehe ich ueber isdn (t-online) ins internet.
die automatische einwahl nutzt du ja sicherlich auch, oder?
ansonsten habe ich insgesamt zwei netzwerkkarten und eine isdn-karte im rechner. funktioniert alles wunderbar.
nur diese komische meldung halt, hab mich schon fast damit abgefunden.

nick
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Netzwerk Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy