Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
DHCP läuft trotz Anleitung nicht

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Netzwerk
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
tweb_de



Anmeldungsdatum: 14.02.2002
Beiträge: 46
Wohnort: Berlin

BeitragVerfasst am: 08. Jun 2002 11:38   Titel: DHCP läuft trotz Anleitung nicht

Ich bin mal die Anleitung für den DHCP Server durchgegangen (http://www.pl-berichte.de/work/server/andere/dhcpd.html) und habe alles konfiguriert.
Er läuft, alle Paketfilter sind aus, aber trotzdem bezieht mein Win2K Rechner keine IP.
Muss also an der Route liegen.
Also Console: "route add 255.255.255.255 eth0"
Aber danach tut sich immer noch nix.
Was muss ich in die route.conf eintragen, damit es geht.
Oder noch andere Ideen ?
Danke schonmal.
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen

Descartes
Gast





BeitragVerfasst am: 08. Jun 2002 12:28   Titel: Re: DHCP läuft trotz Anleitung nicht

in der /etc/hosts schon die Broadcast 255.255.255.255 Adresse eingetragen ?

Wenn du ein LAN benutzt das eh nur im Segment 192.168.0.x Rechner hat ist es vollkommen ausreichend wenn du die Broadcast-Adresse mit 192.168.0.255 auf dein eigenes Subnetz einschränkst.
 

gewitter



Anmeldungsdatum: 09.04.2001
Beiträge: 1354

BeitragVerfasst am: 08. Jun 2002 19:53   Titel: Re: DHCP läuft trotz Anleitung nicht

reich mal die dhcpd.conf rein, vielleicht haperts daran. und was gibt "dhcpd -d" im logging als fehlermeldung heraus?
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

tweb
Gast





BeitragVerfasst am: 08. Jun 2002 20:17   Titel: Re: DHCP läuft trotz Anleitung nicht

Ich habe genau die Config aus der Anleitung - vermute aber, dass es bei mir mit dem Routing bzw der Host-Datei nicht hinhaut. Der Server läuft erstmal, in Log steht nur "Multiple interfaces match the same subnet: eth0 eth1".
Das wars.


default-lease-time 86400;
max-lease-time 2592000;

option domain-name "websternet.lan";
option domain-name-servers 192.168.0.1;
option broadcast-address 192.168.0.255;
option routers 192.168.0.1;
option subnet-mask 255.255.255.0;

subnet 192.168.0.0 netmask 255.255.255.0
{
range 192.168.0.30 192.168.0.49;
}

ddns-update-style ad-hoc;
 

Mirko
Gast





BeitragVerfasst am: 09. Jun 2002 9:38   Titel: Re: DHCP läuft trotz Anleitung nicht

Hallo!

Starte mal "dhcpd eth0"

Damit beschränkst Du Deinen dhcp-Server auf dieses Interface.


Bye
 

gewitter



Anmeldungsdatum: 09.04.2001
Beiträge: 1354

BeitragVerfasst am: 09. Jun 2002 18:43   Titel: Re: DHCP läuft trotz Anleitung nicht

mal den dienst stoppen. bevor du dhcpd -d eingibst. ausserdem bringt dieses route add 255.255.255.0 oder was auch immer nichts, den der dhclient ruft ja auf dieser adresse raus und kann daher auch von jedem anderen rechner antwort bekommen, es sei denn dhcpd läuft nicht richtig oder die klientnetzwerkkarte wird nicht richtig angesprochen.

Zuletzt bearbeitet von gewitter am 09. Jun 2002 18:43, insgesamt 1-mal bearbeitet
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Netzwerk Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy