Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Probleme mit Squid

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Netzwerk
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Taurus71
Gast





BeitragVerfasst am: 23. Aug 2002 14:42   Titel: Probleme mit Squid

Hallo alle zusammen,

ich habe da ein kleines Problem mit dem Squid.
Nach der Installation, Konfiguration und dem anschließendem Restart von Linux bekommt der Client-PC kein Verbindung ins INet.
Ich nutzt Suse Linux 8.0. In dem Rechner sindzwei Netzwerkkarten drin, die erste hat die IP 192.168.0.1/255.255.255.0 ist ist an einem Switch angeschlossen. Die zweite hat keine feste IP, da daran das DSL-Modem sitzt.
Auf dem Linux-Rechner, wo Squid läuft, habe ich keine Problem mit den Inet, nur auf den Clienten (Win2k und Win98SE), obowhl bei den Browsern dort alles richtig eingestellt ist (Proxyserver: 192.168.0.1:3128).
Squid bringt auch keine Fehlermeldung heraus, wenn er gestartet wird.

Kann mir jemand weiterhelfne ?

Danke im voraus

Taurus71

p.s. Hier die Squid.conf zum besseren Verständnis. Stammt nicht von mir, habe ich von irgendwo aus dem Inet, ich bin erst ein Linux-Newbie

# begin /etc/squid.conf

http_port 3128
# icp_port 3130

# Der Wert für cache_mem kann etwa 1/4 des
# Hauptspeichers (RAM) betragen. Bei 64MB-RAM wären dies 16MB
cache_mem 16 MB

cache_swap_low 90
cache_swap_high 95
maximum_object_size 4096 KB

# Die Parameter für cache_dir bemessen sich nach der Anzahl der
# Workstations und der zur Verfügung stehenden Festplatte.
# Minimum ist etwa 500 MB in 16 Verzeichnissen zu je 256 Einträgen
# Empfehlung: 1000 32 256 möglichst auf separater Festplatte
# cache_dir /var/cache/squid 500 16 256

cache_access_log /var/squid/logs/access.log
cache_log /var/squid/logs/cache.log
cache_store_log /var/squid/logs/store.log
emulate_httpd_log on
debug_options ALL,1
dns_nameservers 127.0.0.1
negative_ttl 5 minutes

acl all src 0.0.0.0/0.0.0.0
acl manager proto cache_object
acl localhost src 127.0.0.1/255.255.255.255
acl SSL_ports port 443 563
acl Safe_ports port 80 22 443 563 70 210 1025-65535
acl CONNECT method CONNECT

http_access allow manager localhost
#http_access deny !Safe_ports
#http_access deny CONNECT !SSL_ports

# never_direct allow all
http_access allow all
icp_access allow all
miss_access allow all

cache_effective_user squid
cache_effective_group nogroup

# end of /etc/squid.conf
 

Andreas Reck
Gast





BeitragVerfasst am: 25. Aug 2002 14:40   Titel: Re: Probleme mit Squid

Hast du gecheckt, ob das Netzwerk funktioniert, also ping von den Clients auf den Proxy? Als nächstes überprüfen, ob vielleicht ein Firewall (client oder proxy) das ganze behindert. Ansonsten sieht die config eigentlich ganz gut aus der access müsste eigentlich für jeden beliebigen Rechner möglich sein
http_access all
dukky
 

S.Pfeffer
Gast





BeitragVerfasst am: 28. Aug 2002 11:59   Titel: Re: Probleme mit Squid

Servus,

Dein LAN hat keine Rechte auf dem Proxy:

acl all src 0.0.0.0/0.0.0.0
acl manager proto cache_object
acl localhost src 127.0.0.1/255.255.255.255
acl SSL_ports port 443 563
acl Safe_ports port 80 22 443 563 70 210 1025-65535
acl CONNECT method CONNECT

http_access allow manager localhost
#http_access deny !Safe_ports
#http_access deny CONNECT !SSL_ports

setz mal noch ein : acl localnet src 192.168.0.0/255.255.255.0 und ändere die Zeile weiter unten in: http_access allow manager localhost localnet

Servus
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Netzwerk Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy