Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
fli4l -hat das schon jemand geschafft???

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Netzwerk
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
heinbloed
Gast





BeitragVerfasst am: 13. Okt 2002 14:17   Titel: fli4l -hat das schon jemand geschafft???

Hallo,
Ich wage es kaum zu glauben ,das das funktionieren kann.
Ich wollte einen DSL-router zusammenstellen.Ein 486 Motherboard hatte ich noch , 2 identische Netzwerkkarten und ein Floppy dazu und 16 MB RAM und los gehts
Der Base.txt bearbeitet wie folgt:
----------------schnipp--------------
##-----------------------------------------------------------------------------
## base.txt - fli4l configuration parameters 2.0.4
##
## You can edit/change this file with fliwiz V1.6 or any text editor.
##
## P L E A S E R E A D T H E D O C U M E N T A T I O N ,
## S E E R E A D M E . T X T
##
## B I T T E U N B E D I N G T D I E D O K U M E N T A T I O N
## L E S E N , S I E H E R E A D M E . T X T
##
## Creation: 26.06.2001 fm
## Last Update: $Id: base.txt,v 1.20.2.2 2002/02/22 09:00:14 fm Exp $
##
## Copyright (c) 2001-2002 Frank Meyer <frank@fli4l.de>
##
## This program is free software; you can redistribute it and/or modify
## it under the terms of the GNU General Public License as published by
## the Free Software Foundation; either version 2 of the License, or
## (at your option) any later version.
##-----------------------------------------------------------------------------

#------------------------------------------------------------------------------
# General settings:
#------------------------------------------------------------------------------
HOSTNAME='fli4l' # name of fli4l router
PASSWORD='koelner' # password for telnetd, ftpd and sshd
MOUNT_BOOT='rw' # mount boot device (floppy): ro, rw, no

RAMSIZE='2048' # size of ramdisk for unzipped opt.tgz
# the variables MOUNT_OPT, PART_OPT and UPDATE_MODE will be ignored if
# RAMSIZE is not empty. see docu
MOUNT_OPT='ro' # mount opt device: ro, rw
PART_OPT='hda2' # location of opt-files? ram1 or disk-partition
UPDATE_MODE='full' # add, cfg, full, none, see documentation

#------------------------------------------------------------------------------
# Ethernet card drivers:
# uncomment your ethernet card
#------------------------------------------------------------------------------
ETH_DRV_N='1' # number of ethernet drivers to load, usually 1
RealTek 8129/8139 (not 8019/8029!) (NEW)


ETH_DRV_1_OPTION='' # additional option, e.g. 'io=0x340' for ne

#------------------------------------------------------------------------------
# Ether networks used with IP protocol:
#------------------------------------------------------------------------------
IP_ETH_N='1' # number of ip ethernet networks, usually 1
IP_ETH_1_NAME='' # optional: other device name than ethX
IP_ETH_1_IPADDR='192.168.4.1' # IP address of your n'th ethernet card
IP_ETH_1_NETWORK='192.168.4.0' # network of your LAN
IP_ETH_1_NETMASK='255.255.255.0' # netmask of your LAN

#------------------------------------------------------------------------------
# Additional routes, optional
#------------------------------------------------------------------------------
IP_DEFAULT_GATEWAY='' # normally not used, read documentation!
IP_ROUTE_N='0' # number of additional routes
IP_ROUTE_1='192.168.7.0 255.255.255.0 192.168.6.99' # network netmask gateway

#------------------------------------------------------------------------------
# Masquerading:
#------------------------------------------------------------------------------
MASQ_NETWORK='192.168.4.0/24' # networks to masquerade (e.g. our LAN)
MASQ_MODULE_N='1' # load n masq modules (default: only ftp)
MASQ_MODULE_1='ftp' # ftp
MASQ_MODULE_2='h323' # h323 (netmeeting)
MASQ_MODULE_3='icq' # icq (use with caution!)
MASQ_MODULE_4='irc' # irc
MASQ_MODULE_5='raudio' # raudio
MASQ_MODULE_6='vdolive' # vdolive
MASQ_MODULE_7='quake' # quake
MASQ_MODULE_8='cuseeme' # cuseeme
MASQ_MODULE_9='mms' # MSN-Filetransfer
MASQ_MODULE_10='pptp' # pptp
MASQ_MODULE_11='ipsec' # ipsec
MASQ_MODULE_12='dplay' # dplay (direct play)
MASQ_MODULE_13='msn-0.02' # msn zone (use version 0.01 or 0.02)
MASQ_MODULE_14='udp_dloose' # pseudo mod: some internet games need it

MASQ_FTP_PORT_N='0' # using ftp masq-module on different ports
MASQ_FTP_PORT_1='21' # standard ftp port
MASQ_FTP_PORT_2='2021' # additional port

#------------------------------------------------------------------------------
# Optional package: PORTFW
#
# If you set OPT_PORTFW='yes', you can also edit opt/etc/portfw.sh
#------------------------------------------------------------------------------
OPT_PORTFW='no' # install port forwarding tools/modules
PORTFW_N='0' # how many portforwardings to set up
PORTFW_1='8080 192.168.4.15:80 tcp' # sample 1: forward ext. port 8080 to int.
# host 192.168.6.15 to port 80 (use tcp)
PORTFW_2='3000-3010 192.168.4.15 tcp' # sample 2: forward portrange to int. host
# 192.168.5.15 (use tcp)


#------------------------------------------------------------------------------
# Routing without masquerading
#------------------------------------------------------------------------------
ROUTE_NETWORK='' # optional: route from/to network, no masq

#------------------------------------------------------------------------------
# Routing: internal hosts to deny forwarding
#------------------------------------------------------------------------------
FORWARD_DENY_HOST_N='0' # number of denied hosts
FORWARD_DENY_HOST_1='192.168.6.5' # optional: 1st denied host
FORWARD_DENY_HOST_2='192.168.6.6' # optional: 2nd denied host

#------------------------------------------------------------------------------
# Routing: ports to reject/deny forwarding (from inside and outside!)
#------------------------------------------------------------------------------
FORWARD_DENY_PORT_N='1' # no. of ports to reject/deny forwarding
FORWARD_DENY_PORT_1='137:139 REJECT' # deny/reject forwarding of netbios
FORWARD_TRUSTED_NETS='' # but allow forwarding between LANs

#------------------------------------------------------------------------------
# Firewall: ports to reject/deny from outside (all served ports)
#
# here we leave two ports untouched:
#
# 53 dns
# 113 auth
#------------------------------------------------------------------------------
FIREWALL_DENY_PORT_N='6' # no. of ports to reject/deny
FIREWALL_DENY_PORT_1='0:52 REJECT' # privileged ports: reject or deny
FIREWALL_DENY_PORT_2='54:112 REJECT' # privileged ports: reject or deny
FIREWALL_DENY_PORT_3='114:1023 REJECT' # privileged ports: reject or deny
FIREWALL_DENY_PORT_4='5000:5001 REJECT' # imond/telmond ports: reject or deny
FIREWALL_DENY_PORT_5='8000 REJECT' # proxy access: reject or deny
FIREWALL_DENY_PORT_6='20012 REJECT' # vbox server access: reject or deny

FIREWALL_DENY_ICMP='yes' # deny icmp (ping): yes or no
FIREWALL_LOG='yes' # log access to rejected/denied ports

#------------------------------------------------------------------------------
# Domain configuration:
#------------------------------------------------------------------------------
START_DNS='yes' # start dns server: yes or no
DNS_FORWARDERS='212.122.128.10 212.122.129.10' # DNS servers of your provider, e.g. MSN
DNS_VERBOSE='no' # log queries in /usr/local/ens/ens.log
DOMAIN_NAME='lan.fli4l' # your domain name
DNS_FORBIDDEN_N='0' # number of forbidden domains
DNS_FORBIDDEN_1='foo.bar' # 1st forbidden domain
DNS_FORBIDDEN_2='bar.foo' # 2nd forbidden domain
HOSTS_N='4' # number of hosts in your domain
HOST_1='192.168.4.1 fli4l' # 1st host: ip and name
HOST_2='192.168.4.2 client2' # 2nd host: ip and name
HOST_3='192.168.4.3 client3' # 3rd host: ip and name
HOST_4='192.168.4.4 client4' # 4th host: ip and name

#------------------------------------------------------------------------------
# Special DNS configuration
#------------------------------------------------------------------------------
DNS_N='0' # number of special dns servers, normally 0
#DNS_1='firma.de 192.168.1.12' # 1st special dns server for firma.de
#DNS_2='lan.firma.de 192.168.2.12' # 2nd special dns server for lan.firma.de

#------------------------------------------------------------------------------
# imond configuration:
#------------------------------------------------------------------------------
START_IMOND='yes' # start imond: yes or no
IMOND_PORT='5000' # TCP-Port, see also FIREWALL_DENY_PORT_x!
IMOND_PASS='' # imond-password, may be empty
IMOND_ADMIN_PASS='' # imond-admin-password, may be empty
IMOND_LED='' # tty for led: com1 - com4 or empty
IMOND_BEEP='no' # beep if connection going up/down
IMOND_LOG='no' # log /var/log/imond.log: yes or no
IMOND_LOGDIR='/var/log' # log-directory, e.g. /var/log
IMOND_ENABLE='yes' # accept "enable/disable" commands
IMOND_DIAL='no' # accept "dial/hangup" commands
IMOND_ROUTE='no' # accept "route" command
IMOND_REBOOT='no' # accept "reboot" command

#------------------------------------------------------------------------------
# Generic circuit configuration:
#------------------------------------------------------------------------------
IP_DYN_ADDR='yes' # use dyn. ip addresses (most providers do)
DIALMODE='auto' # standard dialmode: auto, manual, or off

#------------------------------------------------------------------------------
# optional package: syslogd
#------------------------------------------------------------------------------
OPT_SYSLOGD='yes' # start syslogd: yes or no
SYSLOGD_DEST_N='1' # number of destinations
SYSLOGD_DEST_1='*.* /dev/console' # n'th prio & destination of syslog msgs
SYSLOGD_DEST_2='*.* @192.168.4.2' # example: loghost 192.168.4.2
SYSLOGD_DEST_3='kern.info /var/log/dial.log' # example: log infos

#------------------------------------------------------------------------------
# optional package: klogd
#------------------------------------------------------------------------------
OPT_KLOGD='yes' # start klogd: yes or no

#------------------------------------------------------------------------------
# optional package: y2k correction
#------------------------------------------------------------------------------
OPT_Y2K='no' # y2k correction: yes or no
Y2K_DAYS='' # correct hardware Y2K-Bug: add x days

#------------------------------------------------------------------------------
# Optional package: PNP
#------------------------------------------------------------------------------
OPT_PNP='no' # install isapnp tools: yes or no
--------------------schnapp----------------
Ich habe hier 2 neue Real-Tek Netzwerkarten
Den DSL.txt habe ich auch noch bearbeitet:
----------------------schnipp---------------
# Optional package: PPPoE
#------------------------------------------------------------------------------
OPT_PPPOE='yes' # use ppp over ethernet: yes or no
PPPOE_NAME='DSL' # circuit name, don't write spaces
PPPOE_USEPEERDNS='yes' # use dns server of your provider: yes or no
PPPOE_ETH='eth1' # eth card connected to ADSL modem, e.g. 2nd
PPPOE_USER='1und1/xxxxxxx' # username
PPPOE_PASS='mein Passwort' # password
PPPOE_DEBUG='yes' # enable pppd debugging, 'yes' or 'no'
PPPOE_HUP_TIMEOUT='600' # idle time after which to hangup
PPPOE_CHARGEINT='60' # value of charge interval (in seconds)
PPPOE_TIMES='Mo-Su:00-24:0.0:Y' # times/charges when LCR
----------------------------schnapp--------------
...und dann die diskette erstellt

Beim Hochfahren fällt nichts besonderes auf.....Die Netzwerkkarten hinten kontrolliert (die Diode) und da fällt mir folgendes auf:
Nur die Diode der Netzwerkkarte leuchtet mit dem das DSL-Modem verbunden ist.Wenn ich das Modem in die andere Karte anschliesse leuchtet diese ebenfalls.
Die Diode der Karte die mit meinem Rechner verbunden ist bleibt dunkel.
Um mir mein Linux nicht zu "versauen" -auch weil ich nicht genau weiß wie man dieses unter der SuSE 8.0 einrichtet habe ich meine alte Festplatte mit WIN ausgekramt und dieses nach Anleitung eingerichtet......
Der Router lässt sich nicht anpingen
Vielleicht kann mir hier jemand weiterhelfen......ich versuche mich schon daran seit fast einer Woche -Ohne Ergebniss und obwohl die Doko eigentlich relativ gut ist...
Am Router sind keinerlei Meldungen zu entnehmen die irgendwie auf was hindeuten,ausser das er läuft :
Willkommen......
Kennwort
fli4l#

Danke für die Zeit des Lesens...und auch für weitere Hinweise,
Hein*
 

Michael
Gast





BeitragVerfasst am: 13. Okt 2002 17:00   Titel: Re: fli4l -hat das schon jemand geschafft???

Hallo,
so was hat mich auch schon Stunden gekostet, bis ich endlich dahinterkam:
Entweder ist das Kabel zwischen den beiden Rechnern defekt, oder es ist das falsche Kabel. Fuer PC zu PC Direktverbindung brauchst Du ein sog. Crossover-Patchkabel.
 

Jochen
Gast





BeitragVerfasst am: 13. Okt 2002 17:33   Titel: Re: fli4l -hat das schon jemand geschafft???

Hi,

ich bin ebenfalls gerade in der Lernphase zu fli4l, allerdings mit ISDN. "ETHER_DRV_N=1" sollte laut Doku bei 2 gleichartigen Netzwerkkarten korrekt sein, als Treiber verwendest Du wahrscheinlich 8139too, oder? Genau an der Stelle ist die base.txt oben leider zerrupft. Wenn Du Dich am Router anmelden kannst: Hast Du "dmesg" als Kommando zur Verfügung? Damit kannst Du die Treiber-Messages in Ruhe durchsehen, ob der Treiber auch beide Netzwerkkarten befeuert oder nur eine sieht.

Wenn er beide sieht und ein "ifconfig -a" sowohl eth0 als auch eth1 zeigt, wird der Fehler sehr wahrscheinlich am Kabel liegen, wie Michael auch schon sagte.

Jochen
 

heinbloed
Gast





BeitragVerfasst am: 13. Okt 2002 18:05   Titel: Re: fli4l -hat das schon jemand geschafft???

@ Michael
Thx das wird es wohl auch sein.....
Ich bin hingegengen und habe folgendermassen verkabelt:
Rechner vom DSL-Modem getrennt.Dieses Kabel in eth0 vom Router gesteckt
Router mit DSL-Modem verbunden.
ein Ping auf www.web.de wurde vom Router direkt ausgeführt - mit Erfolg
ein Ping auf meinem Rechner (192.168.4.2) klappte nicht......
Das war mir irgendwie nicht bewusst ,das man das Kabel zwar vom Rechner --->Dsl-Modem nutzen kann,wohl nicht aber Rechner---->Router.....
Aber,woran erkennt man ,ob es sich um das richtige handelt????
Gruß Hein

@ Jochen,
Ich kann überhaupt nicht mit dem Router über meinem Rechner kommunizieren....
weder mit ping (192.168.4.1 -IP des Routers)noch mit "Gewalt" (www.web.de)
Nun gibt es 2 Möglichkeiten:
Entweder ich bin zu doof ,meiner SuSE 8.0 beizubringen das ich nen Router habe,oder aber es liegt am Kabel.
Gruß Hein *
@ all,
Danke für die Hinweise und schönen Sonntag noch
Hein*
 

heinbloed
Gast





BeitragVerfasst am: 13. Okt 2002 18:09   Titel: Re: fli4l -hat das schon jemand geschafft???

@ Jochen
ifconfig -a ergab folgendes:
eth0
eth1
lo
pp0

rechts daneben viel Text...was aber nicht auf Fehler hinweist -Mir aber wohl klar wird , das es am Kabel liegt

Thx,
Hein*
 

Michael
Gast





BeitragVerfasst am: 13. Okt 2002 19:52   Titel: Re: fli4l -hat das schon jemand geschafft???

>Das war mir irgendwie nicht bewusst ,das man das Kabel zwar vom Rechner --->Dsl-Modem nutzen kann,wohl nicht aber Rechner---->Router..... Aber,woran erkennt man ,ob es sich um das richtige handelt????<

Gute Frage, vermutlich erkennt man es an dem Aufdruck, wenn man weiss worauf man zu achten hat. Ich habe mir einfach fuer wenige EUR eines im Laden geholt. Die LED's an den NIC's muessen auf jeden Fall leuchten, sonst geht nichts, auch wenn alles andere korrekt konfiguriert ist.
 

Jochen
Gast





BeitragVerfasst am: 14. Okt 2002 6:51   Titel: Re: fli4l -hat das schon jemand geschafft???

>Aber,woran erkennt man ,ob es sich um das richtige handelt????

Nach meiner Erfahrung sind Cross-Over-Kabel meist farblich kodiert, um sie nicht mit 08/15-Patchkabeln zu verwechseln. Ob meine Erfahrung (grüne RJ45-Stecker) jedoch allgemeingültig ist, wage ich zu bezweifeln...

Jochen
 

arno
Gast





BeitragVerfasst am: 14. Okt 2002 9:44   Titel: Re: fli4l -hat das schon jemand geschafft???

@jochen
leider nicht
hatte schon massig probs mit verdammten kabeln die weder beschriftet waren noch farblich anders
hab mir angewöhnt dir kabeln am stecker direkt zu vergleichen
mfg
 

heinbloed
Gast





BeitragVerfasst am: 14. Okt 2002 17:22   Titel: Re: fli4l -hat das schon jemand geschafft???


Es lag am Kabel
Problem hat sich somit erledigt
Gruß Hein*
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Netzwerk Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy