Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Probleme beim mounten von NFS-Verzeichnissen unter SuSE 8.1

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Netzwerk
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Wolfgang
Gast





BeitragVerfasst am: 15. Okt 2002 17:56   Titel: Probleme beim mounten von NFS-Verzeichnissen unter SuSE 8.1

Hallo,

ich versuche auf einem Rechner (SuSE 8.1) Verzeichnisse via NFS zu exportieren. Grundsätzlich weiß ich wie das geht, da ich das schon mit andren Distris oft genug gemacht habe.

Mein Problem liegt wohl in der Auflösung der Rechnernamen. Ich habe einen Rechner mit SuSE 7.2 im Netzwerk laufen, der als Gateway und gleichzeitig als DNS/DHCP-Server dient. Dieser Rechner läuft mit dieser Konfiguration schon eine lange Zeit und auch keine Probleme. Er hat vorher andere Linux Versionen einwandfrei 'bedient'.

Wenn ich mit 'nslookup' versuche, die Rechnernamen aufzulösen klappt alles problemlos. Versuche ich nun mit 'mount -t nfs 192.168.0.2:/server/daten /mnt/imports' das Verzeichnis des Rechnes auf einem Client zu mounten, wird dieser Zugriff verweigert und ich bekomme folgende Meldung:

"mount: 192.168.0.2:/server/daten failed, reason given by server: Permission denied"

Interessanter ist jedoch der Eintrag in der Datei '/var/log/messages' auf dem Server. Die lautet:

"192.168.0.2 rpc.mountd: refused mount request from 192.168.0.3 (tuxi.athome.de.0.168.192.in-addr.arpa) for /server/daten (/server/daten): no DNS forward lookup"

Besonders der letzte Eintrag 'no DNS forward lookup' macht mir zu schaffen. Ich habe schon mehrmals die Konfiguration des DNS/DHCP-Servers kontrolliert bzw. geändert, aber leider ohne Erfolg. Es scheint auch nicht so, das bei SuSE 8.1 irgendetwas so anders ist, oder?

Weiß jemand vieleicht Rat?

Vielen Dank für eure Postings im voraus. Grüße

Wolfgang Tippelt

P.S.: Wenn irgendwas nicht genau beschrieben ist, einfach nachfragen.
 

ChrisPr
Gast





BeitragVerfasst am: 16. Okt 2002 13:56   Titel: Re: Probleme beim mounten von NFS-Verzeichnissen unter SuSE 8.1

Hi ..

was sagt nslookup auf dem server ?!?! auf ip und hostname des clients ?!?!
bzw was sagt deine exports ?!?!

grüsse

ChrisPr
 

Wolfgang
Gast





BeitragVerfasst am: 18. Okt 2002 22:55   Titel: Re: Probleme beim mounten von NFS-Verzeichnissen unter SuSE 8.1

Auf allen Rechnern werden die IP und Hostnamen korrekt ermittelt. In meiner exports-Datei steht: "/srv/data 192.168.0.*(rw,no_root_squash,sync)".

Egal was ich auch eintrage, das Ergebnis ist immer das selbe.
 

nessie
Gast





BeitragVerfasst am: 19. Okt 2002 11:41   Titel: Re: Probleme beim mounten von NFS-Verzeichnissen unter SuSE 8.1

> mount: 192.168.0.2:/server/daten
> exports: /srv/data 192.168.0.*

Typo, nehm ich an ?
 

Udo M.
Gast





BeitragVerfasst am: 20. Okt 2002 14:29   Titel: Re: Probleme beim mounten von NFS-Verzeichnissen unter SuSE 8.1

Was sagt denn NFS, wenn Du auf beiden Rechnern die Auflösung (testweise) per `/etc/hosts' bewerkstelligst?
Aber das scheint mir auch nicht mehr sauber, denn seit etwa 1,5 Jahren versucht auch ifconfig einen DNS-Lookup trotz exakter Zuordnung der Interfaces und gegnerischen ppp-Hosts in der `/etc/hosts'
(nsswitch ist auch richtig). Ein `rci4l restart' dauert dann schon mal 4min.

Der NFS-Server war schon immer etwas seltsam, wo z.B. der speziellere Fall greifen soll, etwa
/usr/src coder-host(rw)
/usr *(ro)
spielte bei SuSE-Versionen auch die Reihenfolge eine Rolle. Ohne weitere Änderungen RH/Mandrake-demonen
genommen: o.k.

Habe z.Z. ähnlichen Ärger wie Du,
exports: /var/distris/SuSE 192.168.140.*(ro)
Serverlog etwa: nfs-mount blocked 192.168.140.13 ...
Bei exakter Namensauflösung funzt es, aber wozu gibt es dann `nnn.nnn.nnn.*'?

Auch nfs-root (Diskless-Client) funktioniert nicht mit echtem DHCP, möglicherweise bekommt der Client
seine IP und DHCP updatet dann erst den named in aller Ruhe, leider zu spät für den gleich folgenden
NFS-mount-Versuch, oder es ist wirklich etwas faul an der NFS-Namensauflösung.

Es wir halt alles langsam etwas WinDOS-like ...
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Netzwerk Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy