Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Squid verhindert Anzeige bestimmter CGI-/"aktiver" Seiten

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Netzwerk
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
hansi
Gast





BeitragVerfasst am: 21. Okt 2002 8:23   Titel: Squid verhindert Anzeige bestimmter CGI-/"aktiver" Seiten

Hallo!

Habe derzeit ein kleines (oder großes ) Problem mit Squid und muß herausfinden, ob es wirklich am Squid liegt oder an anderen Fehlern (Betreiber der Internetseiten oder Zugangsanbieter).

Es funktioniert eigentlich wirklich alles, bis auf zwei Dinge: die "Zähler" auf den Artikelseiten von ebay.de werden nicht angezeigt, ebensowenig die Seite http://shop.schlecker.com. Gerade letztere wird aber in dem Netzwerk gelegentlich benötigt, und bevor ich mich da an andere wende, möchte ich erst wissen, ob es nicht an der lokalen Konfiguration liegt. Seltsam ist, daß beide Inhalte angezeigt werden, wenn ich nur über Routing - bei ausgeschaltetem Proxy - zugreife. Über den Squid kommt aber nichts, sonsdern irgendwann ein timeout-Fehler. habe sogar mal die "default"-Konfigdatei vom Squid genommen, falls es an meinen Einstellungen liegen sollte - aber auch damit geht es nicht.
Wie gesagt, sonst funktioniert wirklich alles über den Proxy - es wäre also auch dnkbar, daß es an den Servern liegt, die ohnehin auch etwas langsam sind und z.B. nicht mal per "ping" ansprechbar sind. Aber da es ohne Proxy geht, würde mich doch stark interessieren, warum das so ist...

Vielen dank für jede Antwort!

grüße,

Hansi
 

hansi
Gast





BeitragVerfasst am: 21. Okt 2002 8:25   Titel: Re: Squid verhindert Anzeige bestimmter CGI-/

Wichtiger Nachtrag: die genaue Zieladresse, die nicht tut, heißt "shop.schlecker.de" (und nicht .com!)

Hansi
 

Dino
Gast





BeitragVerfasst am: 21. Okt 2002 12:22   Titel: Re: Squid verhindert Anzeige bestimmter CGI-/

Also, wegen dem Ping würde ich mir keine Gedanken machen. Es könnte an einer Firewall liegen. Wegen DenialOfService-Gefahr wird Ping und Traceroute eigentlich immer gesperrt.
Die Eingangsseite von shop.schlecker.de macht nach 5 Sekunden einen Refresh über ein cgi-Script. Steht im Kopf wenn du dir mal den Sourcecode ansiehst. Da findest du auch den Server vom Shop ( 62.27.78.13/cgi-bin/pg.exe ). Ob das Problem an dem AutoRefresh der Webseite liegt kann ich dir allerdings nicht genau sagen. Könnte aber sein. Evtl kennt sich ja ein anderer etwas besser mit Squid aus .
Gruß
 

hansi
Gast





BeitragVerfasst am: 21. Okt 2002 21:51   Titel: Re: Squid verhindert Anzeige bestimmter CGI-/

Hallo!

Welche Adresse hinter der Schlecker-Seite steckt, das habe ich schon rausbekommen Aber das ist es ja: ich denke, es liegt an den dynamischen Seiten - es tut ja bei den Ebay-Zählern genausowenig. Mir ist vor allem wichtig zu wissen, ob das zwingend am Squid liegt, oder ob ich da anderen Leuten aufs Dach steigen muß - vor langer Zeit hat es nämlich auch mit Squid einwandfrei geklappt. Aber da sowohl der Squid als auch der Kernel gelegentlich aktualisiert wurden, kann ich da nichts mehr mit Garantie sagen. Es könnte auch an der Gestaltung der URLs liegen oder sonstwas - vielleicht ist ja an diesen Servern irgendwas nicht standardkonform.

Komisch ist halt, daß sonst keine (zumindest nicht, wo ich es gemerkt habe) Seite Probleme macht außer diesen zwei.

Wäre echt super, wenn jemand weiterweiß

Was ich noch testen werde: obs vielleicht am Routing liegt und irgendeine "localhost"-Schleife oder sowas gibt, daß vielleicht vom Gateway selbst kein Zugang möglich ist, egal ob mit oder ohne Proxy - denn der Proxy agiert ja aus der Sicht eines Clienten auf dem Gateway.

Viele Grüße,

hansi
 

hansi
Gast





BeitragVerfasst am: 23. Okt 2002 8:32   Titel: Lösung gefunden...

Hallo!

Habe die Lösung nun selber gefunden - die Kernel-Option "Explicit Congestion Notification" war versehentlich aktiviert und hat dafür gesorgt, daß direkt vom Gateway-Rechner aus kein Zugriff auf diese Seiten möglich war, und daher eben auch nicht über den Proxy. Nun funktioniert es - bleibt die Frage, warum es dann über Routing/Masquerading funktioniert hat!?

Viele Grüße,

Hansi
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Netzwerk Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy