Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
2.interne netzwk suse8.0 kein ping

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Netzwerk
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
stephen
Gast





BeitragVerfasst am: 28. Okt 2002 15:57   Titel: 2.interne netzwk suse8.0 kein ping

HI Leute,
hab ein prob mit 2. interner netzwerk. bekomme keine verbindung vom Notebook
auf'n Gateway weder ping noch sonst was. Richtig konfiguriert ist sie ifconfig eth2 ok
und pingen kann ich sie auch.
SuSefirewall2.conf ist auch als netzwk. zum internen netz bekannt.
Ich weiss nicht mehr weiter, kann mir jemand helfen?????????

danke
 

ratte
Gast





BeitragVerfasst am: 28. Okt 2002 18:41   Titel: Re: 2.interne netzwk suse8.0 kein ping

donnerwetter, da hast du beim woerter wuerfeln ja ganz schoen zugeschlagen, sodass ich nicht verstehe, was du ueberhaupt fuer eine netzwerktopographie hast.

fragen ueber fragen:
- 2. nic im schleppi???
- oder 2. nic im gateway???
- wieso ist bei dir die 2. nic eth2???
muesste doch eth1 sein!!!
- pingen geht, aber wohin???

am besten versuchst du's nochmal, nimmst dir zeit, einen sinnvollen, zusammenhaengenden text fuer dein problem zu schreiben, und dann stellste dir mal janz dumm, und pruefst, ob jemand, der deine situation nicht kennt, nachvollziehen kann, was deine situation ist und worin das problem besteht.

ratte
 

stephen
Gast





BeitragVerfasst am: 28. Okt 2002 19:36   Titel: Re: 2.interne netzwk suse8.0 kein ping

also...
1. Rechner suse-linux8.0 (Gateway)
1. Netzwk. eth0 = ppp0 (T-DSL)
2. Netzwk. eth1 = interne zu win2000 2.rechner
3. Netzwk. eth2 = 2.interne zu notebook x-er rechner

eth1 funktioniert schon seit ca. 6 Monaten einwandfrei!!!!!

eth2 habe ich gestern eingebaut, da ich mein notebook oder sonst
einen rechner ans internet anschliesen kann!!

nun... eth2 kann ich auf 1.rechner pingen
aber nicht von ausen (notebook)!!!!!!!!!!

SuSeFirewall "weis" aber dass sowohl eth1 als auch eth2 ins interne Netzwerk "gehen"!!!

P.S. Ich weis dass man normal nur eine Netzwerkkarte zu DMZ hat. Und diese dann an einen Switch hängt,
will ich aber nicht!!!!!!!!!!!

Es würde mich sehr freuen wenn mir jemand einen Tip geben köönte wo der
fehler liegen könnte, danke.

P.S. Ich hoffe diese erläuterung war etwas besser)))
gruss
stephen
 

ratte
Gast





BeitragVerfasst am: 28. Okt 2002 19:59   Titel: Re: 2.interne netzwk suse8.0 kein ping

aha, dann hast du also keinen switch, sondern verbindest die rechner mit crosslink-kabeln wie folgt:
code:

gateway telekomiker windos schleppi
eth0 eth0 eth0
| | |
eth0------- | |
eth1---------------------- |
eth2-------------------------------



ist das richtig?

jetzt waere es gut zu wissen, ob du dir fuer eth1 und eth2 auf dem gateway ips aus dem gleichen subnetz gewaehlt hast, oder aus verschiedenen.

vermutlich hast du eth1 und eth2 im gleichen subnetz, und dann ist das ein problem. die routing-table auf dem gateway besteht dann naemlich aus einer gateway-route, di. die zur telekom und zwei subnetz-routen fuer zwei interfaces im gleichen subnetz. wenn das gateway in das subnetz sendet, wird er das wohl nur ueber ein interface tun. im gegensatz dazu kannst du aber von jedem rechner (windos, schleppi) beide interfaces anpingen, weil die maschine antwortet.

daher musst du eth2 auf ein anderes subnetz konfigurieren und den schleppi mit. nur so kann das gateway zwischen den beiden nics unterscheiden.

sollte ich vorbeigeraten haben, dann habe ich eine frage:

(du hast eth1 in einem subnetz und eth2 in einem anderen, windos und schleppi sind auch dafuer konfiguriert):
wenn du offline gehst, und die firewall runterfaehrst, funktioniert das pingen vom gateway zu den rechnern und umgekehrt zu den rechnern zum gateway und auch von windos ueber das gateway zum schleppi und umgekehrt?

wenn das der fall ist, dann ist die firewall fehlkonfiguriert.

ratte
 

stephen
Gast





BeitragVerfasst am: 28. Okt 2002 20:08   Titel: Re: 2.interne netzwk suse8.0 kein ping

eth1 10.10.10.10
eth2 10.10.11.15

win2000 10.10.10.x
xxxxx 10.10.11.x

deinen zweiten vorschlag hab ich noch nicht probiert...mach ich aber gleich(vielleicht hab grad'n paar downloads laufen)

thx
 

stephen
Gast





BeitragVerfasst am: 28. Okt 2002 20:37   Titel: Re: 2.interne netzwk suse8.0 kein ping

ok funzt bin drin... hab vergessen die ip auf'n schleppi zu ändern, manchmal seh ich den Wald vor lauter Bäumen nicht *g*

...eine frage noch, wie kann ich auf meinen win2000 zugreifen?????????

also auf samba geht...nur der andere ist nicht in der netzwerkumgebung!?!?
pingen kann ich ihn auch nicht.
Muss ich noch am gateway was ändern? iptabels? bin mal wieder total blind!!!
 

ratte
Gast





BeitragVerfasst am: 28. Okt 2002 22:01   Titel: Re: 2.interne netzwk suse8.0 kein ping

ok, dein erstes problem scheint ja geloest zu sein, richtig?

von wo willst du auf den windos rechner zugreifen, vom schleppi?

"also auf samba geht...nur der andere ist nicht in der netzwerkumgebung!?!?" ist wieder so ein wortgewuerfel, wer ist der andere? was willst du mit "auf samba geht" bloss sagen?

auf jeden fall kann ich dir sagen, was du aendern musst:

-adrenalin runterfahren
-tief und langsam einatmen, min. 1 minute
-vorstellen, du fragst deinen deutschlehrer, der den computerkurs betreibt
-laaaaangsam schreiben und
-hinterher nochmal lesen, auf fehler pruefen und sich vorstellen, ob das noch geht, wenn der freundliche leser von deiner situation keine ahnung hat. wenn du willst, mit einer huebschen ascii-grafik angereichert (siehe hilfe, ob code, code), das alleine beruhigt schon ungemein :)

im ernst,
ratte
 

stephen
Gast





BeitragVerfasst am: 28. Okt 2002 23:05   Titel: Re: 2.interne netzwk suse8.0 kein ping

sorry...also ich probiers mal...

code:



internet
|
|
|---<->--samba----<->-----|
|---win2000 auf schleppi-------|
| | linux | |
| | | | | |
| ------<->-- ----<->------ |
| |
|------------------#-------------------------|
funzt net über linux




in der netzwerkumgebung, benachbarte computer ist nur der samba von linux, aber weder der schleppi bei win2000, noch win2000 bei schleppi zu sehen.
 

ratte
Gast





BeitragVerfasst am: 28. Okt 2002 23:35   Titel: Re: 2.interne netzwk suse8.0 kein ping

_ruhig, tief atmen, nur nicht verzweifeln, ist alles nur halb so wild, immer mit der ruhe_

jaaaaaa, huebsches bild.

samba, ja, ok. funzt net, richtig?, aha.

mal sehen, wer wen nicht sehen kann...

*schau* ....
*nachdenk*....
*idee krieg*...
*nachkontrollier*...

achso, das gateway ist vom windos und vom schleppi in der net-zwerg-umgebung sichtbar, richtig? aber windos und schleppi sehen sich nicht richtig, ist das wahr?

jaaa, dann sind wir an einem punkt angelangt, ...ping geht aber, oder?..., an dem leute mit windos2000 mal was dazu sagen koennten, da fehlen mir echt die erfahrungen.

noch n tip:

- auf gegenfragen eine konkrete antwort geben.

ratte
 

stephen
Gast





BeitragVerfasst am: 29. Okt 2002 0:12   Titel: Re: 2.interne netzwk suse8.0 kein ping

danke für die hilfe.

nein ich kann die win2000 und schleppi gegnseitig nicht pingen!!!!!

ich weis auch dass es kein windoof prob ist, meiner meinung nach, leitet linux
die "anfrage" nicht weiter.

So jetzt noch etwas grundlegendes:
Ich benutze linux seit über 2 Jahren und habe seit ca. 7-8 monaten erst mehr als einen Pc sprich die möglichkeit ein netzwerk zu "bauen".
Daher setze ich voraus, wenn ich schreibe,dass ich auf samba zugriff habe jeder in einem solchen forum
weis, dass der samba-server natürlich auf dem linuxrechner läuft.

Ich habe sicherlich fehler bei der beschreibung meines prob. gemacht, aber es ist auch nicht gerade einfach
dass hier ohne eine vernünftige grafik zutun.

wie dem auch sei danke, ich hoffe du hast jetzt keine schlaflose nacht wegen meiner unzulänglichkeit
probs zu schildern.

tschü

stephen
 

Fabian
Gast





BeitragVerfasst am: 29. Okt 2002 23:32   Titel: Re: 2.interne netzwk suse8.0 kein ping

Ist IP-Forwarding zum Schleppi/Win2000-Rechner denn implementiert ?

Es gibt zwar eine Forward und NAT-Chain zum ppp0 (Internet), aber keine zwischen den Rechnern, du musst also vermutlich deine Firewall/Routen nochmal überprüfen ...

Schonmal ein Traceroute probiert ?

Das kann manchmal auch helfen ...

cu

Fabian

PS: Jetzt weiss, ich wozu Switches/Hubs erfunden wurden ...
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Netzwerk Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy