Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Kein Routing nach reconnect

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Netzwerk
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Joyrider
Gast





BeitragVerfasst am: 13. Nov 2002 13:05   Titel: Kein Routing nach reconnect

Hallo,
(ISDN-Router, SuSE 8.0, Kernel 2.4.18)

Folgendes Phänomen:

Bei der ersten Einwahl läuft alles tadellos..dann kommt der 24 Std. disconnect vom ISP und der Router wählt sich brav neu ein, soweit sogut. Allerdings ist nach dem reconnect kein routing mehr möglich..nix zu machen bin zwar online, aber dat maskierte Netz kommt nich ins INet (internes Netz läuft auch tadellos)

Auch Änderungen am den ip-up Scripten und neu einträge von wegen neustart der Firewall brachten keinen Erfolg.
Achso..:wenn ich nach dem reconnect die Firewall restarte, läuft alles wieder prima.

Ich denke, bzw. ich habe den Eindruck das in dem ip-up script der neustart der Firewall schamlos misachtet wird,
hat jemand ne Idee ?

thx.

Joyrider
 

Joyrider
Gast





BeitragVerfasst am: 14. Nov 2002 13:04   Titel: Re: Kein Routing nach reconnect

HI,

So, dat mit dem Routing klappt nu, aber die Firewall wird nach dem reconnect trotzdem nicht richtig gestartet das ip-up script is mittlerweile wieder auf Ursprung zurückgebracht,
wie kann ich die olle Firewall nach einem reconnect neu restarten lassen, also automatisch und so, mit ip-up scheint dat nich zu funzen

so long

Joyrider
 

Heinz
Gast





BeitragVerfasst am: 14. Nov 2002 14:13   Titel: Re: Kein Routing nach reconnect

@Joyrider

Ist gut für dich. Leider habe ich ein ähnliches Problem.
Wenn bei mir ein disconnect stattfindet, kann ich nicht mehr "on demand" einwählen.
Ich habe gemerkt, dass mir nach dem Disconnect die default-route zu ippp0 gelöscht wird.
WEnn ich aber dann von Hand mit isdnctrl dial ippp0 einwähle, generiert das System die default-Route zu ippp0
Oder wenn ich die default-route zu ippp0 von Hand via "route add" setzte kann ich on demand einwählen

Hast du ein Typ wie ich das Prob lösen kann.

Gruss
Heinz
 

Joyrider
Gast





BeitragVerfasst am: 15. Nov 2002 10:02   Titel: Re: Kein Routing nach reconnect

Hi, Heinz,

Das Problem hatte ich auch, Abhilfe schaffte ein simpler Eintrag im Firewall Script. Ich geh nun mal davon aus, dass Du die FW2 benutzt zum Maskieren und Routen. Ich habe die Einträge
FW_KERNEL_SECURITY="yes" und FW_STOP_KEEP_ROUTING_STATE="yes" gesetzt, letzteres sorgt dafür das die Route bestehen bleibt. (Steht auch ne kurze Beschreibung bei dem Punkt).

Mein anderes Problem hat sich auch erledigt, Firewall wird nu brav nach nem reconnect ausgeführt. Es ist schon lästig wenn man Fehler sucht wo keine sind, nur weil man des schreibens nicht mächtig ist....
mein Eintrag in der ip-up.local hieß rsSusefirewall2 restart muss aber heissen rcSuSEfirewall2 restart, Wer kümmert sich schon um 2 doofe Buchstaben die klein anstatt gross geschrieben wurden ??

so long

Joyrider
 

Heinz
Gast





BeitragVerfasst am: 16. Nov 2002 10:11   Titel: Re: Kein Routing nach reconnect

@Joyrider

Ich benutze zur zeit Redhat 8.0
 

Heinz
Gast





BeitragVerfasst am: 17. Nov 2002 11:21   Titel: Re: Kein Routing nach reconnect

OK, hab's hinbekommen

Gruss
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Netzwerk Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy