Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Win XP kann Domäne nicht beitreten

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Netzwerk
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Silver
Gast





BeitragVerfasst am: 16. Dez 2002 21:55   Titel: Win XP kann Domäne nicht beitreten

Hallo

Ich wollte Linux mit Suse 8.0 als Domain-Controller einsetzen, an dem sich Windows Clients anmelden können.
Dazu habe ich Samba 2.2.5 installiert. Ich habe mich bei der Konfiguration an einen Artikel der c't 23/2002 gehalten.

In der smb.conf habe ich folgende Einstellungen vorgenommen:
Workgroup = lserver
security = user
domain logons = yes
domain master= yes
encrypt password = yes

Dann habe ich mittels smbpasswd -a root, einen root für samba angelegt.

Dann folgende Dienste neugestartet:
rcnmb restart
rcsmb restart

Laut c't Artikel muss man bei Win XP Professional unter Verwaltung, bei lokale Sicherheitsrichtlinien die Option:
Domän-Mitglied: Daten des sicheren Kanals digital verschlüsseln oder signieren (immer)
deaktivieren.

Mein Problem:
Wenn ich dann bei Win XP Rechner der Domäne LSERVER beitreten will, fragt er mich nach Benutzername und Passwort.
Dort habe ich dann root und das Sambapasswort von root eingegeben.
Dann kommt die Fehlermeldung:
Windows kann der Domäne LSERVER nicht beitreten. Zugriff verweigert

Hat jemand eine Idee was ich vergessen haben könnte.

Vielen Dank im voraus

MfG
Silver
 

...___...___...
Gast





BeitragVerfasst am: 17. Dez 2002 8:19   Titel: Re: Win XP kann Domäne nicht beitreten

Maschinenkonto erstellt?
smbpasswd -a -m machine$
 

Silver
Gast





BeitragVerfasst am: 17. Dez 2002 16:22   Titel: Re: Win XP kann Domäne nicht beitreten

Hallo

Den Benutzer hatte ich nicht hinzugefügt. Aber ich weiß auch nicht wie.
smbpasswd -a -m maschine$ sagt er kann den Benutzer nicht hinzufügen weil er auf dem System nicht existiert.
Dann hab ich mal so einen Benutzer ohne $ mit Yast hinzugefügt. Aber die -m Option bei smbpasswd bringt immer diesen Fehler.
Hier im Forum konnte ich nichts vergleichbares finden.

Also bitte, was muss ich beachten?

Und ich wüßte gern noch wofür dieses Konto gut ist.

MfG Silver
 

Stormbringer



Anmeldungsdatum: 11.01.2001
Beiträge: 1570
Wohnort: Ruhrgebiet

BeitragVerfasst am: 17. Dez 2002 20:11   Titel: Re: Win XP kann Domäne nicht beitreten

Mache es einfach einmal mit $ Zeichen:
- Erzeuge einen Benutzer bspw. mit dem Namen laptop$ (oder wie auch immer der XP Rechner heißt)
- Führe dann smbpasswd -a -m laptop$ aus (ein Konto sollte dann erzeugt werden)
- Lege Dir noch einen smbadmin account an (root nimmt man dafür nicht!)
- Starte smb neu, und starte nun den XP Rechner
- Führe das Hinzufügen des XP Rechner durch

Gruß
_________________
Continuum Hierarchy Supervisor:
You have already been assimilated.
(Rechtschreibungsreformverweigerer!)
 
Benutzer-Profile anzeigen Private Nachricht senden

Silver
Gast





BeitragVerfasst am: 18. Dez 2002 12:42   Titel: Re: Win XP kann Domäne nicht beitreten

Hallo

Ich hatte schon Schwierigkeiten einen lokalen Benutzer mit $-Zeichen im Namen zu erstellen.
Da hat mir yast gesagt, dass solche Zeichen nicht erlaubt seien. Also hab ich den Benuzter ohne Dollarzeichen erzeugt und anschließend in der /etc/passwd das Dollarzeichen nachgetragen und auch das Homeverzeichnis umbenannt. SuSEconfig ausgeführt, dann nmb und smb neugestartet und dann nochmal versucht den WinXP Rechner der Domäne hinzuzufügen. Leider mit dem selben Resultat.

Und welche Rechte sollte der smbadmin beisitzen? Reicht es, wenn er einfach der Gruppe root auf dem Server angehört?

MfG
Silver
 

EthanHunt2
Gast





BeitragVerfasst am: 27. Dez 2002 15:04   Titel: Re: Win XP kann Domäne nicht beitreten

Hast du das OS/Level auf 65 gesetzt?
 

leo
Gast





BeitragVerfasst am: 29. Dez 2002 18:37   Titel: Re: Win XP kann Domäne nicht beitreten

den benutzer mit dem $ kannst du so erzeugen:

useradd machine$ (zb. useradd laptop$)

dann einfach smbpasswd -a -m laptop$

dann sollte es funktionieren...
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Netzwerk Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy