Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
SuSe8.1 mit rtl8139

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Netzwerk
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
walko
Gast





BeitragVerfasst am: 24. Dez 2002 22:49   Titel: SuSe8.1 mit rtl8139

Hallo
Ich benutze ein Notebook (ALDI MD5400 m. NW-Karte rtl8139). Diese wird unter yast2 erkannt und ist mit 8139too in der modules.conf eingetragen. Im Netz läuft ein Router (Bintec x1000) als DHCP. Ich bekomme beim booten aber beim booten keine IP. Mit ifconfig wird nur die HWaddr von eth0 angezeigt. Kann es mit meinem DHCP zu tun haben??
 

Descartes
Gast





BeitragVerfasst am: 25. Dez 2002 15:01   Titel: Re: SuSe8.1 mit rtl8139

Ist die Netzwerkkarte mittels YaST2 entsprechend für DHCP konfiguriert?

Hast du die SuSE Firewall auf deinem Notebook eingerichtet? Wenn ja, dann mal abschalten und ohne ausprobieren. Eventuell blockt dein Firewall Script den DHCP Broadcast.
 

walko
Gast





BeitragVerfasst am: 26. Dez 2002 21:46   Titel: Re: SuSe8.1 mit rtl8139

Keine Firewall aktiv lt yast. Alle Schnittstellen auf keine.
Wenn ich eine fest IP vergebe kann ich auch keinen Rechner/Router erreichen. Könnte es an der Konfiguration liegen.
 

hans
Gast





BeitragVerfasst am: 27. Dez 2002 19:44   Titel: Re: SuSe8.1 mit rtl8139

der vorredner sagt es ja schon ,die karte mit dhcp konfigurieren .
vergibst du eine feste ip-adresse dann achte darauf dass du das standardgateway auf den router setzt.

bsp:router hat adresse 192.168.0.1 dann gibst du als standardgateway diese adresse ein.

mfg
 

walko
Gast





BeitragVerfasst am: 27. Dez 2002 23:05   Titel: Re: SuSe8.1 mit rtl8139

Auch wenn Gateway gesetzt wird, ist ein pingen im Netz nicht möglich. Gateway ist mit yast gesetzt. Gibst es Konfigurationen die von Hand erledigt werden müssen??

Für jede Hilfe dankbar. Smile
 

Descartes
Gast





BeitragVerfasst am: 28. Dez 2002 0:16   Titel: Re: SuSe8.1 mit rtl8139

Machen wirs mal schrittweise und ganz langsam:

1) Per YaST2 deine Netzwerkkarte so konfigurieren dass die Einstellungen per DHCP zugewiesen werden.

root# yast2


2) Interface eth0 mal deaktivieren und danach neu aktivieren um zu sehen ob die Änderungen greifen

root# if-down eth0
root# if-up eth0


3) Hat die Netzwerkkarte ihre Einstellungen jetzt per DHCP erhalten?

root# ifconfig eth0

Falls Nein, dann Einstellungen deines DHCP Servers kontrollieren:

code:

,-----[ /etc/dhcpd.conf ]-----
! # Parameter: "ad-hoc", "interim" or "none"
! ddns-update-style ad-hoc;
!
! default-lease-time 7200;
! max-lease-time 7200;
!
! subnet 192.168.0.0 netmask 255.255.255.0 {
! range 192.168.0.150 192.168.0.199;
! option domain-name-servers 192.168.0.250;
! option netbios-name-servers 192.168.0.250;
! option domain-name "heimnetz.local";
! option routers 192.168.0.250;
! option subnet-mask 255.255.255.0;
! option broadcast-address 192.168.0.255;
! }
`-----------------------------


,-----[ /etc/route.conf ]-----
! #
! # Destination Dummy/Gateway Netmask Device
! #
! # default 0.0.0.0
! 192.168.0.0 0.0.0.0 255.255.255.255 eth0
`-----------------------------

# es läuft ein lokale DNS der seinerseits bei Bedarf den DNS des Internet Providers befragt

,-----[ /etc/resolv.conf ]-----
| search heimnetz.local
| nameserver 192.168.0.250
`------------------------------




4) Kannst du deinen DHCP Server *) anpingen?

root# ping 192.168.0.250

*) IP Adresse 192.168.0.250 durch die Adresse deines DHCP Servers ersetzen

Falls Nein, läuft vielleicht auf dem DHCP Server eine Firewall die Broadcasts blockt?
Wenn ja dann mal testweise abschalten.
Falls SuSEfirewall2 im Einsatz auf dem DHCP Server dann FW_SERVICE_DHCPD="yes" einstellen.
 

walko
Gast





BeitragVerfasst am: 28. Dez 2002 23:03   Titel: Re: SuSe8.1 mit rtl8139

Hi
Mein DHCP ist der Router (X1000 von Bintec). Der Router ist nicht über LINUX eingerichtet. Die NW-Karte ist auf DHCP konfiguriert. Nach if-down/up wird jedoch kein IP zu gewiesen.

Was es kann das denn bloß sein?
 

arp
Gast





BeitragVerfasst am: 29. Dez 2002 0:12   Titel: Re: SuSe8.1 mit rtl8139

... aber eingerichtet ist er doch hoffentlich, als router unf dhcp-server?

arp
 

walko
Gast





BeitragVerfasst am: 29. Dez 2002 15:36   Titel: Re: SuSe8.1 mit rtl8139

Ja. Der Router sit DHCP eingerichtet. Unter WIN alles ok. Auch ein andres Notebook mit einer PCMCIA-NW-Karte (Noname NE2000 komp
) und SuSe8.0 läuft einwandfrei mit dem Router. Dieser Rechner bekommt auch eine IP vom Router.
Gibt es ein Möglichkeit dies zu Überprüfen wo die Unterschiede sein könnten.

Vielen Dank
Armin
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Netzwerk Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy