Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Samba funktioniert nicht richtig

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Netzwerk
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Eugen+Exner
Gast





BeitragVerfasst am: 12. Jan 2003 4:39   Titel: Samba funktioniert nicht richtig

Hallo alle zusammen.

Ich habe folgendes Problem. Ich habe auf meinem Server Linux 8.1 Samba 2.2.5 eingerichtet. Alles funktioniert zum Teil, d.h. wenn ich auf Netzwerkumgebung mit einem Client Windows XP gehe und auf Server dann kommt ein Fehler "Auf Linx Rechner kann nicht zugegrieffen werden, sie haben keine Berechtigung...". Wenn ich jetzt aber auf "Start" und dann "Ausführen" klicke und "\192.168.0.1(meine Server IP)" eingebe dann kommt nur der Ordner für meinen Client von Homedirectories automatisch zugeordnet wird. Ich habe nun eine zweite Festplatte eingebaut und möchte die komplett im Netz freigeben. Hab diese Platte als Linux Native partitioniert und im Verzeichnisbaum von Linux steht auch der Name der Platte. Wenn ich jetzt das alles in smb.conf eingebe dann sehe ich das Verzeichnis nich auf meinem Client. Und warum kann ich nicht in Netzwerkumgebungen auf den Server bzw. auf die freigegebenen Ordner zugreifen. Was mache ich nur falsch.

Hier meine smb.conf Datei:

[global]
workgroup = LANPDC
os level = 64
server string = Server
time server = yes
unix extensions = yes
encrypt passwords = yes
printing = CUPS
printcap name = CUPS
wins support = yes
character set = ISO8859-15
veto files = /*.eml/*.nws/riched20.dll/*.{*}/

[homes]
comment = Home Directories
valid users = %S
browseable = no
writeable = yes
create mask = 0640
directory mask = 0750

[printers]
comment = All Printers
path = /var/tmp
printable = yes
create mask = 0600
browseable = no

[print$]
comment = Printer Drivers
path = /var/lib/samba/drivers
write list =@ntadmin root
force group = ntadmin
create mask = 0664
directory mask = 0775

[data1] *ist meine zweite Platte
comment = Sicherung
path = /data
browseable = no
writeable = yes
create mask = 0777
guest ok = yes
guest only = yes

Bitte helft mir, der Server wird dringendst benötigt.

Danke im Voraus.

Gruss
Eugen Exner
ejony@web.de
 

Browser
Gast





BeitragVerfasst am: 12. Jan 2003 6:15   Titel: Re: Samba funktioniert nicht richtig

Warum solches?

browseable = no
guest only = yes
 

Eugen Exner
Gast





BeitragVerfasst am: 12. Jan 2003 11:17   Titel: Re: Samba funktioniert nicht richtig

Ich habs auch schon ohne versucht, klappt auch nicht. Ich habs bloß eingetragen, da es bei mir bei Linux 7.1 auch dringestanden ist.

Ich hab sogar schon die User freigegeben mit smbpasswd -a user. Muß ich noch etwas in der Firewall evtl. ändern?

Gruss
Eugen Exner
 

Browser
Gast





BeitragVerfasst am: 12. Jan 2003 17:36   Titel: Re: Samba funktioniert nicht richtig

Alle Firewalls (auch XP-Heimnetzwerk, oder wie das heißt) sind wohl default so eingestellt, daß (Server-)Zugriffe per nfs, smb u.ä. nicht zugelassen sind. Wenn Du also Deinen Server auch zum internen Netz derart abgeschottet hast, sollte es nicht funktionieren, allerdings seltsam, wenn HOMES erreichbar ist.
 

Browser
Gast





BeitragVerfasst am: 12. Jan 2003 18:46   Titel: Re: Samba funktioniert nicht richtig

http://spotlight.de/nzforen/lia/m/lia-1038535000-23521.html
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Netzwerk Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy