Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Netzwerkkarte

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Netzwerk
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
ratloser
Gast





BeitragVerfasst am: 12. Jan 2003 6:16   Titel: Netzwerkkarte

Hi

hab mir eben mal Gentoo 1.4rc2 stage1 gesaugt und wollte es installieren .

Problem ist das Netzwerk bei mir .

Habe einen Router (192.168.0.1) von Netgear .
Das Modul für eth0 wird richtig erkannt und auch geladen .

Laut www.gentoo.org gibt es 2 Möglichkeiten das Netzwerk einzurichten ,mittels DHCP und statisch .

Mit DHCP habe ich es mittels dhcpcd eth0 probiert ,kein Erfolg.
Also statisch mit
/sbin/ifconfig eth0 192.168.0.5 broadcast 192.168.0.255 netmask 255.255.255.0
Dann
/sbin/route add -net default gw 192.168.0.1 netmask 0.0.0.0 metric 1

/etc/resolv.conf mit domain mydomain.org editiert.
/sbin/ifconfig -a gibt das hier heraus

dummy 0 Link encap:Ethernet HWAddr 00:00:00:00:00:00
BROADCAST NOARP MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0
frame:0
collisions:0 txquelen:0
RX bytes:0 (0.0b) TX bytes:0 (0.0b)


eth0 Link encap:Ethernet HWAddr 00:10:DC:9A:9D:B7
inet addr:192.168.0.5 Bcast:192.168.255.255 Mask 255.255.255.0
inet6 addr:fe80:210:dcff:fe9a:9db7/10 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric 1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:4 overruns:0
frame:0
collisions:0 txquelen:100
Interrupt:19 Base adress:0xec00


lo link encap:local loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX wie oben bei dummy 0
TX auch wie bei dummy 0



sit0 link encap:IPv6-in-IPv4
NOARP MTU:1480 Metric:1
RX wie ober bei dummy 0
TX auch wie bei dummy 0
---------------------------------------

Habe versucht mal als Broadcast anstatt 192.168.0.255 mal 192.168.255.255 einzugeben aber klappt auch nicht.

Ping auf anderen rechner im Netzwerk klappt auch nicht genauso wie sich dieser Rechner hier nicht anpingen lässt.
Der Router lässt sich auch nicht anpingen.

Ich weiss nicht mehr weiter ,meinen anderen Linuxrechner (SuSE8.1)(192.168.0.3)habe ich mit DHCP konfiguriert und der funzt einwandfrei.

Ich weiss nicht wo hier der Fehler liegen könnte.

Danke für jede Hilfe im voraus.

MfG

ratloser
 

Raudi
Gast





BeitragVerfasst am: 12. Jan 2003 6:44   Titel: Re: Netzwerkkarte

Das komisch aussieht:

> Dann
> /sbin/route add -net default gw 192.168.0.1 netmask 0.0.0.0 metric 1

Das reicht (netmask ist doch 255.255.255.0):
/sbin/route add -net default gw 192.168.0.1
 

ratloser
Gast





BeitragVerfasst am: 12. Jan 2003 18:49   Titel: Re: Netzwerkkarte

Hi

Habe ich eben versucht aber brachte auch keinen Erfolg.

Network is unreachable.

Wie gesagt ich kann weder andere Hosts anpingen noch kann ich diesen Host nicht anpingen.

Ich verstehe nicht warum das nicht geht , ich gehe genau nach Anleitung vor aber irgendwo muss ja ein fehler sein.

Gruss
PS:Den Artikel TCP/IP unter Linux habe ich mal ausgedruckt hier von ProLinux aber steht meines Erachtens das selbe drin.
 

ratte
Gast





BeitragVerfasst am: 12. Jan 2003 23:55   Titel: Re: Netzwerkkarte

die Netzwerkeinstellungen sind soweit in Ordnung, seltsam finde ich
---schnipp---
Interrupt:19
---schnapp---

entweder ist die Karte puttig, oder du nutzt ACPI oder wie der neue, als DANGEROUS eingestufte Kram heisst.

schreib' mal, was zutrifft.

ratte
 

ratloser
Gast





BeitragVerfasst am: 13. Jan 2003 3:27   Titel: Re: Netzwerkkarte

es trifft zu dass es ACPI ist ! ! !

eine onboard lankarte ,im bios (phoenix-award) gibt es aber keine möglichkeit dies abzuschalten.

google >acpi +linux

derzeit hat nur suse eine acpi unterstuetzung,also auf zum bios-kompendium ....acpi ausschalten ...bei mir geht es nicht !!!! *hmpf

wär ich nicht drauf gekommen mit ACPI

also auf anderem rechner probiert (3 Jahre alt),funzt direkt beim ersten mal.

muss wohl warten bis gentoo ne version rausbringt wo acpi standartmässig eingebunden ist ?????

gruss
 

ratte
Gast





BeitragVerfasst am: 13. Jan 2003 14:08   Titel: Re: Netzwerkkarte

ACPI ist ne Kerneloption, die einkompiliert wird AFAIK.

Back dir doch einen zweiten, in dem acpi ausgeschaltet ist, den du testweise mal benutzt.
Doku zum booten von multiplen kerneln gips zuhauf.

ratte
 

ratloser
Gast





BeitragVerfasst am: 13. Jan 2003 16:23   Titel: Re: Netzwerkkarte

axo , ich dachte bios sache .
oki doki so mach ich es auch .


dank und gruss
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Netzwerk Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy