Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Samba: keinen Zugriff auf homes

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Netzwerk
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
ironeagle



Anmeldungsdatum: 15.01.2003
Beiträge: 7

BeitragVerfasst am: 25. Jan 2003 2:00   Titel: Samba: keinen Zugriff auf homes

Hallo zusammen, ich habe ein echtes Problem:
Ich habe auf SuSE Linux 8.1 einen Samba-Server eingerichtet.
Dieser funktioniert auch soweit bis auf das Homes-Verzeichnis.
Ich bekomme einfach keinen Zugriff auf das Verzeichnis, WIN2K gibt immer folgende Fehlermeldung:

Auf //server/homes kann nicht zugegriffen werden
Der Netzwerkname wurde nicht gefunden

Das Verzeichnis Daten welches für alle User zugänglich ist funzt ohne Probleme
Die User sind in der smbpasswd eingerichtet und stimmen mit den Linux und auch Win Usern überein.

Hier ist meine smb.conf, die mit SWAT erstellt wurde:

# Global parameters
[global]
workgroup = NETZ
netbios name = SERVER
server string = Server der ...
encrypt passwords = Yes
os level = 2
domain master = True
browseable = No
available = No

[Daten]
path = /daten
read only = No
create mask = 0777
directory mask = 0777
browseable = Yes
available = Yes

[homes]
comment = Heimatverzeichnis
valid users = %S
create mask = 0750
browseable = Yes
available = Yes

Habe umgestellt auf SuSE 8.1, vorher hatte ich 7.3 und keine Probleme, da lief der Samba-Server. Gibt es in der neuen Version noch was anderes was man dafür einstellen muß. Habe gemerkt das da doch das ein oder andere verschieden ist.

Ich würde mich freuen, wenn mir jemand helfen kann

Bis bald Stefan


Zuletzt bearbeitet von ironeagle am 25. Jan 2003 2:00, insgesamt 1-mal bearbeitet
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

S. Pfeffer
Gast





BeitragVerfasst am: 31. Jan 2003 13:40   Titel: Re: Samba: keinen Zugriff auf homes

Servus,

versuch doch mal das 'valid users = %S' aus der '[homes]' Section rauszulassen. Das Share [homes] wird ja eh, sozusagen dynamisch für jeden User erzeugt. Wenn die Filesystemrechte entsprechend gesetzt sind kann eh keiner auf ein anders /home zugreifen.

MfG

S. Pfeffer
 

ironeagle



Anmeldungsdatum: 15.01.2003
Beiträge: 7

BeitragVerfasst am: 31. Jan 2003 15:31   Titel: Re: Samba: keinen Zugriff auf homes

Danke nochmal,
aber das hatte ich auch schon versucht. Hat leider auch keinen Erfolg gebracht.
Aber ich konnte das Problem lösen, indem ich das Samba-Paket nochmal deinstalliert und dann neu installiert habe. Seit dem läuft alles wunderbar, obwohl ich die gleichen Einstellungen wieder verwendet habe.
Wenn ich Shares zu anderen Verzeichnissen erstelle, kommt der gleiche Fehler hin und wieder nochmal vor, dann lösche ich das Share einfach wieder und lege es unter einemm anderen Namen an. Plötzlich läuft es dann. Ich kann es dann wieder löschen und unter dem Namen anlegen, den ich eigentlich will, auch das funktioniert dann ohne Probleme. Kann sein das dort ein kleiner Buck in der Version ist. Es gibt ja schon eine neuere, als die im SuSE Linux 8.1 mitgelieferte.
Ist irgendwie komisch, aber es läuft ja alles.

Bis dann und ein pinguinisches Wochenende,
Stefan
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

Nig][tWave
Gast





BeitragVerfasst am: 02. Feb 2003 15:05   Titel: Re: Samba: keinen Zugriff auf homes

versuchst du dich unter windows so "//server/homes" anzumelden???

veruschs mal mit "\server\homes" Wink
 

Nightwave



Anmeldungsdatum: 12.12.2002
Beiträge: 21
Wohnort: Garbsen

BeitragVerfasst am: 03. Feb 2003 7:13   Titel: Re: Samba: keinen Zugriff auf homes

meinte natürlich "\\server\homes"
 
Benutzer-Profile anzeigen Private Nachricht senden

ironeagle



Anmeldungsdatum: 15.01.2003
Beiträge: 7

BeitragVerfasst am: 03. Feb 2003 13:37   Titel: Re: Samba: keinen Zugriff auf homes

Sorry, war nur ein Tipfehler in meinem Post
ich hatte es so versucht, wie Du es vorgeschlagen hast.
War leider kein Erfolg, aber im Moment läuft alles wie geschmiert.
Bis bald
Stefan
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Netzwerk Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy