Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Netzwerk / RedHat8 / Inet-Router

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Netzwerk
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
scotty
Gast





BeitragVerfasst am: 18. Feb 2003 18:27   Titel: Netzwerk / RedHat8 / Inet-Router

Hallo,

bin kurz vorm verzweifeln:

Musste meinen Rechner neu aufsetzen, seit dem spinnt mein Netzwerk.
Folgender Sachverhalt:

Ich habe 2 Netzwerkkarten ( eth0 für lokal und ppp0 ( eth1 ) für DSL ). Aktiviere ich NUR die ppp0 kann ich Daten senden und empfangen, aktiviere ich dann die eth0, bin ich zwar immernoch eingewählt, jedoch sucht er die Daten ausm Net über die eth0.

Die ganze Sache hat vorher wunderbar funktioniert ( einschliesslich Routingscript für die anderen Rechner ).

Habe schon zig Karten und Slots probiert, daran kann das nicht liegen.

Wenn ich weitere Infos posten soll, dann sagt Bescheid.

Ich danke schon mal für die Hilfe......ich bin mit meinem Latein am Ende.


scotty
 

Ralf
Gast





BeitragVerfasst am: 19. Feb 2003 8:05   Titel: Re: Netzwerk / RedHat8 / Inet-Router

Wie sieht denn dann deine Routingtabelle aus wenn du eingewählt bist.


Gruß Ralf
 

arno
Gast





BeitragVerfasst am: 19. Feb 2003 9:02   Titel: Re: Netzwerk / RedHat8 / Inet-Router

hi

hate das prob auch mal da der pppd nicht mehr die default route setzt.
du musst in der /etc/ppp/options glaube ich defaultroute setzten.
allerdings hat das bei mir auch net ganz hingehaut und ich lösche jetzt die defaultroute
mit dem script welches den pppd aufruft.

mach mal bevor du den pppd startest ein
route del default

mfg
arno
 

scottty
Gast





BeitragVerfasst am: 19. Feb 2003 18:20   Titel: Re: Netzwerk / RedHat8 / Inet-Router

also.....

der Vorschlag von arno hat leider nicht geklappt......folgende Fehelrmeldung:

SIOCDELRT: Kein passender Prozess gefunden


Hier die Routingtable, wenn eth0 deaktiviert ist, und ich eingewählt bin :

Kernel IP Routentabelle
Ziel Router Genmask Flags Metric Ref Use Iface
217.5.98.179 * 255.255.255.255 UH 0 0 0 ppp0
127.0.0.0 * 255.0.0.0 U 0 0 0 lo
default 217.5.98.179 0.0.0.0 UG 0 0 0 ppp0


und nun das selbe, mit aktivierter eth0:

Ziel Router Genmask Flags Metric Ref Use Iface
217.5.98.179 * 255.255.255.255 UH 0 0 0 ppp0
192.168.0.0 * 255.255.255.0 U 0 0 0 eth0
127.0.0.0 * 255.0.0.0 U 0 0 0 lo
default 192.168.0.1 0.0.0.0 UG 0 0 0 eth0


wobei diese Anfrage recht lange dauert.

Ich bitte schonmal um Rücksicht, da ich ( noch ) kein Linux-Spezi bin.....seid also mit Fachbegriffen etwas vorsichtig *ggggg*

Danke schon mal


scotty
 

arno
Gast





BeitragVerfasst am: 21. Feb 2003 10:16   Titel: Re: Netzwerk / RedHat8 / Inet-Router

hi

so wie ich das sehe ist es schon ein routing prob.
aktiviere beide karten, wähle dich ein und gieb dann ein
route del default
dannach den befehl
route add default gw 217.5.98.179 (ist der gateway deines providers)

das müsste es dann gewesen sein
mfg
arno
 

scotty
Gast





BeitragVerfasst am: 22. Feb 2003 22:25   Titel: Re: Netzwerk / RedHat8 / Inet-Router

hi,


das prob hat sich gelöst....ich habe beim installieren die 192.168.0.1 als gateway angegeben....was natürlich falsch ist, da er ja dann logischerweise auf sich selbst routet.

Aber trotzdem danke an alle.

scotty
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Netzwerk Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy