Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Geschwindigkeit

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Netzwerk
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Erich
Gast





BeitragVerfasst am: 21. Feb 2003 6:50   Titel: Geschwindigkeit

hallo ......

wollte gerne mal wissen ob es normal ist dass man im internen netz nur knapp 1 MB an daten zu einem anderen linux- oder windowsrechner schicken kann.bei dsl (internet) krieg ich ja schon 768kb. hab eine 10/100 NIC die auch einwandfrei läuft mit dem modul 8139too. nur ich dachte man hat im internen netz eine schnellere geschwindigkeit weil 10/100. vielleicht irre ich mich auch.

ps: hat das was mit hd oder fd zu tun (half- oder fullduplex) und wenn ja , wo stellt man sowas ein?

danke und gruss
 

Erich
Gast





BeitragVerfasst am: 21. Feb 2003 6:55   Titel: nachtrag

achja , ich habe nur eine netzkarte im rechner die über einen switchrouter von netgear verbunden ist mit einem anderen rechner (win und linux) und mit einem dsl-modem. der router übernimmt also das routing für inet und lan.
aber auch wenn ich nicht im inet bin ist das so langsam.

gentoo 1.4rc2
kernel 2.4.20 mit qos kompiliert aber keine einstellungen vorgenommen.
zweiter rechner selbe netzwerkkarte.

das müsste glaub ich alles wissenswertes sein :=)

gruss
 

daniel
Gast





BeitragVerfasst am: 21. Feb 2003 11:53   Titel: Re: Geschwindigkeit

hmm - hab schon oefters erlebt, das, wenn man auf fullduplex umschaltet die uebertragungsrate in die knie geht (was ja eigentlich nicht sein soll).
stell mal auf half-dupex um, falls fd eingestellt ist.
1mb/sec meinst du sicherlich.
das ist so der ungefaehre maximale wert fuer ein 10mbit netz. ein 100mbit netz schafft so gute 7-9mb/sec. abhaengig von den karten und treibern.
deine netzkarte kenne ich leider nicht.
ein switchrouter? verstehe ich das jetzt richtig, es ist ein normaler 10/100 mbit switch, wo du gleichzeitig x rechner anschliessen kannst und zusaetzlich 1x dsl, und dies wird dann geroutet.
nimm mal ein gekreuztes kabel und packe dies ohne etwas dazwischen an die beiden nics. wenns nu schnell geht, musst du am switch rumkonfiguriern. ansonsten sinds wohl ein oder zwei netzkarten.

viele erfolge,
daniel
 

hjb
Pro-Linux


Anmeldungsdatum: 15.08.1999
Beiträge: 3236
Wohnort: Bruchsal

BeitragVerfasst am: 21. Feb 2003 12:01   Titel: Re: Geschwindigkeit

Hi!

So einen Netgear-Switch habe ich auch. Da gibt es nichts zu konfigurieren. Die Karten und der Switch handeln automatisch 100 Mbit/s und Full Duplex aus. Ich weiß im Moment nicht, wo das Problem liegen könnte. Probiere mal mii-diag bzw. mii-tool.

Gruß,
hjb
_________________
Pro-Linux - warum durch Fenster steigen, wenn es eine Tür gibt?
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen MSN Messenger

Erich
Gast





BeitragVerfasst am: 21. Feb 2003 16:18   Titel: Re: Geschwindigkeit

hi,
der switchrouter handelt wie gesagt die geschwindigkeit selber aus, so steht es auch in der beschreibung. habe auch schon ein update eingespielt, der router ist für 10/100 mb.

ich werde wenn ich zuhause bin mal mii* ausprobieren. wäre schön wenn das hilft.

danke fürs erste
schönen gruss
 

Erich
Gast





BeitragVerfasst am: 21. Feb 2003 18:54   Titel: Re: Geschwindigkeit

hi,

code:
root@linux erich # ethtool -s eth0 speed 100 duplex half autoneg off
root@linux erich # ethtool eth0
Settings for eth0:
Supported ports: [ TP MII ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
Supports auto-negotiation: Yes
Advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
Advertised auto-negotiation: No
Speed: 100Mb/s
Duplex: Half
Port: MII
PHYAD: 32
Transceiver: internal
Auto-negotiation: off
Supports Wake-on: pumbg
Wake-on: p
Current message level: 0xffffffff (-1)
Link detected: yes



habe verschiedene parameter probiert, sowohl mit DUPLEX auch mit AUTONEGATION und SPEED

das beste ergebnis erhalte ich mit
code:
root@linux erich # ethtool -s eth0 speed 100 duplex half autoneg off
root@linux erich # ethtool eth0
Settings for eth0:
Supported ports: [ TP MII ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
Supports auto-negotiation: Yes
Advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
Advertised auto-negotiation: No
Speed: 100Mb/s
Duplex: Half
Port: MII
PHYAD: 32
Transceiver: internal
Auto-negotiation: off
Supports Wake-on: pumbg
Wake-on: p
Current message level: 0xffffffff (-1)
Link detected: yes


was aber auch standart bei mir war.
komisch ist nur bei einem download geht max. 1,3MB/sec bei zwei downloads JE 1,0MB/sec in etwa. das wären ja dann mehr als 1.3, den dritten download nimmt der aber nimmer an.

ps:kabel von rechner zu switchrouter sind cat5/patch
kabel von router zum dsl-modem sind cat5/utp (was hierfür ja nicht wichtig ist)
switchrouter ist ein netgear rp 614

gruss und danke
 

Erich
Gast





BeitragVerfasst am: 21. Feb 2003 18:56   Titel: Re: Geschwindigkeit

code:
root@linux marc # ethtool -s eth0 speed 100 duplex full autoneg on
root@linux marc # ethtool eth0
Settings for eth0:
Supported ports: [ TP MII ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
Supports auto-negotiation: Yes
Advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
Advertised auto-negotiation: Yes
Speed: 100Mb/s
Duplex: Full
Port: MII
PHYAD: 32
Transceiver: internal
Auto-negotiation: on
Supports Wake-on: pumbg
Wake-on: p
Current message level: 0xffffffff (-1)
Link detected: yes




sorry der zweite eintrag war falsch kopiert ;)

sollte full heissen und nich half.

sorry
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Netzwerk Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy