Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Redhat 8.0 und DSL-Installation sucks

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Netzwerk
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
jerome
Gast





BeitragVerfasst am: 02. März 2003 17:46   Titel: Redhat 8.0 und DSL-Installation sucks

Hallo...

Nachdem ich ein Dualboot-System mit WindowsXP und Redhat 8.0
erfolgreich installiert hab, häng ich jetzt schon eine ganze
Weile an meinem DSL-Problem bei Linux.

Während die Einwahl unter Windows problemlos läuft, ist unter
RedHat der Connect einfach nicht zum Laufen zu bringen.

Problem: zwei Netzwerkkarten installiert: eth0 mit fester
IP 10.0.0.1, eth1 mit 11.0.0.1... Beide Interfaces up'n running.

Ping über eth0 auf das DSL-Modem 10.0.0.138 funktioniert.

Die DSL-Installation über den Internet-Wizzard installiert mir ein
DSL-"Gerät", das ich an eth0 binde und in dem ich meine (triplechecked)
Usercredentials des Providers eintrage. Das Aktivieren dieser
DSL-Devices schlägt (nach ein paar Minuten Nachdenkens) fehl.

Ich hab dann noch eine Weile mit adsl-setup/connect etc rumgespielt,
alles mit dem gleichen Ergebnis.

Die Fehler, die ich bekomme, lauten "Netzwerk-Gerät ppp0 kann nicht
aktiviert werden", "Timeout waiting for PADO packets" und "Device not
ready. Make sure there is a disk in the drive" (drive???)

Wenn's unter Windows nicht laufen würde, könnte ich's ja noch auf
die Verkabelung oder die Hardware schieben, aber dort läufts ja.

Hat jemand eine Idee, in welche Richtung ich hier weitermachen
könnte? Ich bin für jede Hilfe dankbar...

"Jerome"
 

Andreas B.
Gast





BeitragVerfasst am: 02. März 2003 18:19   Titel: Re: Redhat 8.0 und DSL-Installation sucks

also Du könntest den pppd auch manuell konfigurieren,
ich kenne mich mit den Wizzard´s von RH nicht aus, deshalb nur "generic Answers"

a.
Du brauchst der Netzwerkkarte keine IP zuweisen die mit dem DSLModem verbunden ist, diese muss
nur up sein
ifconfig ethY up

b.
das ppp0 bekommt über den pppd eine default IP, ausserdem wird die default route gesetzt

c.
hinweise gibt es zur manuellen Installation auf
http://hints.linuxfromscratch.org
-> hints index
-> Networking
-> pppoe / dsl setup

den pppoe musst Du glaub ich net noch installieren wie in den hints.
 

mschwendt



Anmeldungsdatum: 14.02.2003
Beiträge: 37

BeitragVerfasst am: 04. März 2003 0:03   Titel: Re: Redhat 8.0 und DSL-Installation sucks

Ein Ethernet Device, hinter welchem direkt das DSL-Modem hängt, bekommt keine IP Adresse. Dein eth0 muß nichtmal "up" sein.

> Timeout waiting for PADO packets

Kannst Du mit pppoe -I eth0 -A den Access Concentrator ermitteln? Falls das auch fehlschlägt, erreichst du offenbar noch nichtmal dein DSL Modem und hast ein Verkabelungs- oder Netzwerkkartenkonfigurationsproblem.

Und wenn Du zuviel rumspielst, wird keiner hier aus deinen Schritten schlau. Wink
 
Benutzer-Profile anzeigen Private Nachricht senden

Andreas B.
Gast





BeitragVerfasst am: 04. März 2003 5:14   Titel: Re: Redhat 8.0 und DSL-Installation sucks

die ip bekommt ppp0 und damit ppp0 vom pppd erzeugt wird muss pppd an ethY gebunden sein,
welches up sein muss oder verstehe ich dich miss ?
 

mschwendt



Anmeldungsdatum: 14.02.2003
Beiträge: 37

BeitragVerfasst am: 04. März 2003 9:59   Titel: Re: Redhat 8.0 und DSL-Installation sucks

> ifconfig ethY up

Das ist ein Schritt, um den sich User absolut nicht zu kümmern hat.

Der User konfiguriert nur das PPP Device unter Angabe der DSL Ethernet Karte. Einzige Ausnahme ist der seltene Fall von einem DSL Modem, welches nur über einen Switch erreichbar ist.

Dokumentation zu LFS oder http://adsl4linux.de halte ich als Rat für einen Red Hat Linux Anwender und Linux Newbie für unpassend. Ich sehe keinen Grund, warum der User nicht redhat-config-network oder notfalls adsl-setup nehmen sollte.

Zu den häufigsten Fehlern gehört Verwendung einer Ethernet Karte, die erst mit Treiberoptionen oder mii-tool auf 10 Mbps half-duplex geschaltet werden muß. Steht in /var/log/messages nur "Timeout waiting for PADO packets" und ist der Access Concentrator nicht zu erreichen, ist sehr wahrscheinlich noch nichtmal das DSL Modem zu erreichen.
 
Benutzer-Profile anzeigen Private Nachricht senden

Andreas B.
Gast





BeitragVerfasst am: 04. März 2003 14:49   Titel: Re: Redhat 8.0 und DSL-Installation sucks

btw jetzt mal die Frage nach den Netzwerkkarten an jerome,
welche sind das ?
10/100mbs oder 10mbs ?
speziell mit welcher ist das Ding an das DSL Modem angeschlossen.
 

Andreas B.
Gast





BeitragVerfasst am: 04. März 2003 14:58   Titel: Re: Redhat 8.0 und DSL-Installation sucks

@jerome

führ mal bitte
"mii-tools"
aus, und poste das Ergebnis

ps.
bislang hat bei mir noch keine 100mbs Karte die 10mbs nicht erkannt,
wo ich sie auf einen Modus hätte zwingen müssen
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Netzwerk Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy