Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
probleme mit linuy las router mit kabelmodem

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Netzwerk
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
francosdad



Anmeldungsdatum: 02.03.2003
Beiträge: 2
Wohnort: Leipzig

BeitragVerfasst am: 02. März 2003 18:14   Titel: probleme mit linuy las router mit kabelmodem

hallo,

ich habe ein problem unter linux einen router einzurichten, mit welchem ich die windows clients (10 stück an der zahl) auf das internet zugreifen lassen kann.
bis jetzt lasse ich das system über squid laufen, kann jedoch outlook über windows nicht verwenden, da squid diese protokolle nicht unterstüzt.

das problem welches sich ergibt, ist, dass ich kein dsl anschluss habe, sondern über ein kabelmodem über kabeldeutschland ins internet gehe. damit habe ich ich das problem, dass ich die linux firewall nicht einstellen kann.

ich möchte also auf den windows client nur das gateway einstellen und direkt über den linuy server ins internet gehen.

die einstellungen der netzwerkkarten sind für die externe - dhcp und in der internen 192.168.0.30 über das subnet 255.255.255.0 .

bitte helft mir dringend weiter, wie ich dieses problem lösen kann.

danke im voraus.

p.s. ich arbeite mit linux 8.1 professional
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

Andreas B.
Gast





BeitragVerfasst am: 02. März 2003 18:23   Titel: Re: probleme mit linuy las router mit kabelmodem

warum kannst Du die Firewall net nutzen ??

der Router hat doch zwei netzwerkkarten
2 Netzwerkdevices
dem router wird ja per dhcp der defaultgw mitgeteilt, und gesetzt
anstatt bei deiner firewall "ppp0" anzugeben gibst du einfach
ethY <-- Kabelmodem gerät an.

ach ja

"Kabel <---> Kabelmodem <---> Netzwerkkarte"
stimmts soweit ?
 

francosdad



Anmeldungsdatum: 02.03.2003
Beiträge: 2
Wohnort: Leipzig

BeitragVerfasst am: 03. März 2003 11:31   Titel: Re: probleme mit linuy las router mit kabelmodem

dank dir für deine antwort, aber

das habe ich getan, es funktioniert nicht. ich gebe mal ein paar genauere angaben :

ich habe das kabelmodem an den netzwerkdevice eth1 angeschlossen, welcher mit dhcp konfiguriert ist und dem dns des providers 192.168.1.17. wenn ich squid einschalte funktioniert das internet über die windows clients mit der einstellung des proxy 192.168.0.30 (ip des servers) und dem port 3128.
schalte ich aber den proxy aus und starte die firewall mit der externen schnittstelle eth1 und der internen eth0 und stelle beim windows client das gateway auf 192.168.0.30 funktioniert nichts. ich habe natürlich dann den proxy unter der verbindungseinstellung des ie ausgeschalten.

ich bin linux neuling, das heisst ich beschäftige mich erst seit einem monat damit. vielleicht kannst du mir oder jemand anders auch einen anderen weg erklären. ich wollte es über zebra probieren, jedoch finde ich keine konfigurationshilfe dafür.

wichtig ist nur, dass die windows clients auch outlook benutzen können, was über squid ja nicht möglich ist.

vielen dank im voraus, der micha
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

Ralf
Gast





BeitragVerfasst am: 03. März 2003 12:55   Titel: Re: probleme mit linuy las router mit kabelmodem

Ich nehme mal an, du mußt noch IP-forwarding und NAT konfigurieren.
Müßte eigentlich über yast gehen

Mfg Ralf
 

bazik
Gast





BeitragVerfasst am: 03. März 2003 14:44   Titel: Re: probleme mit linuy las router mit kabelmodem

>> p.s. ich arbeite mit linux 8.1 professional

Was ist das?

Ich hab nur Linux 2.4.20 Vanilla :/
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Netzwerk Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy