Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Internetverbing mit suse 8.0 über Kabel

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Netzwerk
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
10110
Gast





BeitragVerfasst am: 21. März 2003 19:20   Titel: Internetverbing mit suse 8.0 über Kabel

Hi

ich bin ein blutiger Linux Newbi und kämpfe mit der Internetverbindung.
Provider: cabelcom (Internet über Kabel) PCMCIA CardBus Karte).

Mein Problem, ich kriege keine Verbindung zustande.
Ich erhalte eine Fehlermeldung die in etwa besagt,
das smppp einen Fehler verursacht hat, oder bei der
Ausführung von smppp ein Fehler aufgetreten sei.
Den genauen Fehler könne ich im Protokoll nachschauen,
ich weiss aber nicht welches Protokoll und wo es sich befindet (var/log?)

Besten Dank schon mal im voraus.

mfg
 

petameta
prolinux-forum-admin


Anmeldungsdatum: 14.02.2003
Beiträge: 1294

BeitragVerfasst am: 21. März 2003 21:29   Titel: Re: Internetverbing mit suse 8.0 über Kabel

Hat der Provider eine Internetadresse ?

Bei Kabelmodems reicht es doch oft, einfach ne Netzwerkkarte anzuklemmen und die Adresse per DHCP zu beziehen.
 
Benutzer-Profile anzeigen Private Nachricht senden

10110
Gast





BeitragVerfasst am: 22. März 2003 10:30   Titel: Re: Internetverbing mit suse 8.0 über Kabel

Ja unter WixP, funzt das so. WixP installiert, Kabel eingestöpselt und drin war ich.
Aber unter Linux will er nicht. Vielleicht erkennt er ja die pcmcia LAN Karte nicht.
zwar die Leds sind an, bis halt auf das Active Led - aber das ist ja logisch ohne Ver-
bindung. Ich hab null Ahnung, was ich machen soll.
 

petameta
prolinux-forum-admin


Anmeldungsdatum: 14.02.2003
Beiträge: 1294

BeitragVerfasst am: 22. März 2003 12:44   Titel: Re: Internetverbing mit suse 8.0 über Kabel

Da empfehle ich Dir, erstmal das Ethernet howto zu lesen Smile.

Also: Es müssen 3 Sachen funktionieren:

1. Der Netzwekkartentreiber muß geladen sein. Guck mal was ein "lsmod" Dir ausgibt. Welche Netzwerkkarte genau benutzt Du ? Hast Du sie konfiguriert bei der Installation ? Guck mal, was yast2 zur Netzwerkkonfiguration sagt.
2. Die Netzwerkkarte muß konfiguriert sein Gebe mal den Befehl ifconfig als root ein. Was sagt er Dir da ? Es müßte ein eth0 vorhanden sein.
3. Du mußt eine Netzwerkadresse per dhcp beziehen. Dafür muß ein DHCP-client laufen.
 
Benutzer-Profile anzeigen Private Nachricht senden

10110
Gast





BeitragVerfasst am: 22. März 2003 16:52   Titel: Re: Internetverbing mit suse 8.0 über Kabel

zu 1. ne Linksys Cardbus pcmpc200. Bei der Installation wurde sie nicht automatisch erkannt, darum habe ich sie manuel installiert.
steht immernoch unbekannt, aber is eth01.
________________________________________________________________
lsmod
----------------------------------------------------------------
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:60 errors:0 dropped:0 overruns:0 frame:0
TX packets:60 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:3912 (3.8 Kb) TX bytes:3912 (3.8 Kb)

--------------------------------------------------------------------

zu 2. eth01 ist nicht vorhanden...
____________________________________________________________________
ifconfig
--------------------------------------------------------------------
Module Size Used by Not tainted
snd-pcm-oss 45152 0 (autoclean)
snd-mixer-oss 11136 0 (autoclean)
snd-maestro3 13732 0
snd-pcm 58528 0 [snd-pcm-oss snd-maestro3]
snd-timer 11456 0 [snd-pcm]
ipv6 123424 -1 (autoclean)
snd-ac97-codec 24196 0 [snd-maestro3]
snd 31720 0 [snd-pcm-oss snd-mixer-oss snd-maestro3 snd-pcm snd-timer snd-ac97-codec]
soundcore 3268 3 [snd]
ds 6368 4
yenta_socket 8384 2
pcmcia_core 37984 0 [ds yenta_socket]
isa-pnp 27816 0 (unused)
joydev 5728 0 (unused)
evdev 3904 0 (unused)
input 3072 0 [joydev evdev]
usb-uhci 20996 0 (unused)
usbcore 55136 1 [usb-uhci]
lvm-mod 58016 0 (autoclean)
reiserfs 158816 1

3. Betreff dhcp Dienst: Ich habe einen dhcpd gefunden wenn ich ihn jedoch aktiviere wird die Meldung 'Programm ist nicht konfiguriert' ausgegeben.
Wo kann ich den konfigurieren??
 

petameta
prolinux-forum-admin


Anmeldungsdatum: 14.02.2003
Beiträge: 1294

BeitragVerfasst am: 22. März 2003 21:56   Titel: Re: Internetverbing mit suse 8.0 über Kabel

Bin mir nicht sicher, welches Modul für diese Netzwerkkarte zuständig ist.

Probier erstmal folgendes: "ifconfig eth0 192.168.0.1". Wenn das nicht klappt, ist der Netzwerktreiber nicht geladen.
In dem Fall Probier mal "modprobe tulip" oder "modprobe tulip_cb". Wenn eines von diesen beiden funktioniert, sollte das ifconfig wie oben funktionieren.

Wenn das alles funktioniert, kannst Du dich um den DHCP client kümmern. Der dhcpd ist allerdings ein DHCP server, verteilt also IP-Adressen in einem Netz. Diesen nicht aktivieren.
Du braucht entweder den dhclient oder den dhcpcd (DHCP Client Daemon). Damit kenne ich mich allerdings nicht aus, habe das bisher noch nie gebraucht. Bin aber sicher, google liefert Dir was brauchbares.
 
Benutzer-Profile anzeigen Private Nachricht senden

10110
Gast





BeitragVerfasst am: 23. März 2003 8:58   Titel: Re: Internetverbing mit suse 8.0 über Kabel

Funktionniert alles nicht.
Nur komisch ist, dass ein ping auf localhost bzw. 127.0.0.1 funktioniert. Und das heisst ja eigentlich, zumindest unter W-Platformen, dass die LAN-Karte funzt.

nux:~ # ifconfig 127.0.0.1
127.0.0.1: error fetching interface information: Device not found

linux:~ # ifconfig 192.168.0.1
192.168.0.1: error fetching interface information: Device not found
linux:~ #

linux:~ # ifconfig eth0 192.168.0.1
SIOCSIFADDR: No such device
eth0: unknown interface: No such device

linux:~ # ifconfig eth-pcmcia-0 192.168.0.1 // Karte ist unter Yast als eth-pcmcia-0 eingetragen, aber eben als unbekannt.
SIOCSIFADDR: No such device
eth-pcmcia-0: unknown interface: No such device
linux:~ #


linux:~ # modprobe tulip
/lib/modules/2.4.18-4GB/kernel/drivers/net/tulip/tulip.o: init_module: No such device
Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters
/lib/modules/2.4.18-4GB/kernel/drivers/net/tulip/tulip.o: insmod /lib/modules/2.4.18-4GB/kernel/drivers/net/tulip/tulip.o failed
/lib/modules/2.4.18-4GB/kernel/drivers/net/tulip/tulip.o: insmod tulip failed
linux:~ #


linux:~ # modprobe tulip_cb
/lib/modules/2.4.18-4GB/pcmcia-external/cb_enabler.o: init_module: Operation not permitted
Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters
/lib/modules/2.4.18-4GB/pcmcia-external/cb_enabler.o: insmod /lib/modules/2.4.18-4GB/pcmcia-external/cb_enabler.o failed
/lib/modules/2.4.18-4GB/pcmcia-external/cb_enabler.o: insmod tulip_cb failed
linux:~ #


Von wo weiss ich welches die richtigen IO und IRQ Parameter sind, und wo kann ich diese installieren?
 

petameta
prolinux-forum-admin


Anmeldungsdatum: 14.02.2003
Beiträge: 1294

BeitragVerfasst am: 23. März 2003 9:45   Titel: Re: Internetverbing mit suse 8.0 über Kabel

Nein, ein Ping auf 127.0.0.1 funktioniert, weil das Loopback device läuft. Dieses ist zuständig für 127.0.0.1. Guck mal Deine Ausgabe von ifconfig an, das ist das Loopback device (lo). Wenn dort zusätzlich noch eth0 steht, läuft die Netzwerkkarte.

Versuch mal mit Google was über die Netzwerkkarte zu finden, ich habe da bisher nur was von tulip gelesen, keine Ahnung warum das nicht funktioniert. Ein "modprobe xxx" lädt das entsprechende Treibermodul. Wenn das funktioniert, sollte der Rest auch funktionieren.

Sorry, kann so nicht mehr sagen.
 
Benutzer-Profile anzeigen Private Nachricht senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Netzwerk Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy