Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
RedHat....route add 192.....usw

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Netzwerk
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
pablovschby
Gast





BeitragVerfasst am: 30. März 2003 1:41   Titel: RedHat....route add 192.....usw

hallo

route-.eingabe:

Ziel Router Genmask Flags Metric Ref Use Iface
192.168.3.0 * 255.255.255.0 U 0 0 0 eth1
80.218.64.0 * 255.255.248.0 U 0 0 0 eth0
127.0.0.0 * 255.0.0.0 U 0 0 0 lo
default dclient80-218-6 0.0.0.0 UG 0 0 0 eth0



auf eth1 ist das LAN

eth0 ist das internet....also das cable-modem gibt dem redhat die ip

route add 192.168.3.0 eth0

habe ich gemeint, würde alle pakete des eth1-netzes auf eth0 leiten und umgekehrt...ging aber net...


192.168.3.1 ist der linux-pc als router und 192.168.3.2 ist der win-pc im lan, ...statische interne ip's

beim win-pc ist als gateway: 192.168.3.1 eingetragen....


..wieso gehts net...

gruss
pablo
 

Ralf
Gast





BeitragVerfasst am: 30. März 2003 11:39   Titel: Re: RedHat....route add 192.....usw

Versuchs mal mit
echo 1 > /proc/sys/net/ipv4/ip_forward
das aktiviert das ip-forwarding des Kernels.

Gruß Ralf
 

arno
Gast





BeitragVerfasst am: 30. März 2003 12:31   Titel: Re: RedHat....route add 192.....usw

hi
falls du mit dem winclient surfen willst musst du zu dem obern tip masquerading aktivieren
mit dem befehl:
iptables -A POSTROUTING -t nat -s 192.168.3.0/24 -j MASQUERADE

dann müsste es funken
mfg
arno
 

pablovschby
Gast





BeitragVerfasst am: 30. März 2003 13:26   Titel: Re: RedHat....route add 192.....usw

hallo

ich habe beide eure befehle eingegeben und das routen war immer noch deaktiviert...

...leoder bin ich ein absoluter anfänger im linux...daher:

es wäre noch sehr wichtig, wenn ihr mir die "gegen-"befehle eurer 2 befehle posten könntet, damit ich das ganze wieder deaktivieren kann, was ich vorhin aktiviert habe.....

einfach zum das wieder deaktivieren, was eure 2 befehle aktiviert haben,.....


danke&gruss
pablo


p.s.: hat sonst ev. noch jemand ne idee..?
 

Pierre
Gast





BeitragVerfasst am: 30. März 2003 13:35   Titel: Re: RedHat....route add 192.....usw

lies dir mal die "man route" durch, einfach auf der konsole eingeben!

mfg pierre
 

pablovschby
Gast





BeitragVerfasst am: 30. März 2003 14:02   Titel: Re: RedHat....route add 192.....usw

mach ich ja...aber ich begreif das net so....


ausserdem muss ich eh zuerst die 2 "gegen"-befehle haben, damit ich die 2 befehle voin vorhin wieder rückgängig machen kann...

gruss
 

arno
Gast





BeitragVerfasst am: 30. März 2003 14:14   Titel: Re: RedHat....route add 192.....usw

sage erst mal genau was du willst!
falls du nur mit den clients surfen willst vergiss das routen!
dazu reichen die beiden befehle oben (halt bei jedem linux was ich in letzter zeit probiert hab
falls nicht wären fehlermeldungen interessant.
WAS sagt der winclient wen du WAS machst?
WAS sagt /var/log/messages wenn du WAS machst?

wenn du keine informationen lieferst kann dir auch nicht geholfen werden.
meine glaskugel ist zu zeit in der reinigung!

mfg
arno
 

pablovschby
Gast





BeitragVerfasst am: 30. März 2003 14:40   Titel: Re: RedHat....route add 192.....usw

danke für deine antwort...

---
wenn du keine informationen lieferst kann dir auch nicht geholfen werden.
---

sorry, ich loefere ja, was du willst....


---
meine glaskugel ist zu zeit in der reinigung!

---

helseherglaskugel?


---
WAS sagt der winclient wen du WAS machst?
---
Der Winclient sagt "unkown hostname" wenn ich google.com pinge
der winclient sagt aber auch "network not found" wenn ich im opera ne site eigebe, dies logischerweise gibt...
auch im ie6 sagt de3r winclient natürlich: site not found


---
WAS sagt /var/log/messages wenn du WAS machst?
---

wenn du mir sagst, was ich machen muss....also wo ich die info's holen muss, die ich dann hier posten würde...

.-...dann mach ichs...

da ich momentan nicht viel am linuxserver selbst mache, kann ich dir ja nicht gross sagen, was ich mache, da ich ja nichts mache ()

hier meine messages:

wenn du noch andere info's meines systems willst, ....sags ruig...

da sshd läuft, würde ich dir sogar diesen root-login mal geben, wenn du willst...und natürlich die ip...(wenn du dir das mal der secureshell anschauen willst...)

messages:

http://www.pablovschby.ch/messages


gruss&danke
pablo
 

pablovschby
Gast





BeitragVerfasst am: 30. März 2003 14:41   Titel: Re: RedHat....route add 192.....usw

wieder was vergessen:

was ich will:

eigentlich will ich den linux-pc später mal als router und firewall für die winpc's einsetzen...aber momentan will ich EINFACH nur mal das routen ermöglichen, von mir aus ohne einschränkung...

gruss
 

dussel
Gast





BeitragVerfasst am: 30. März 2003 18:25   Titel: Re: RedHat....route add 192.....usw

Ziel Router Genmask Flags Metric Ref Use Iface
192.168.3.0 * 255.255.255.0 U 0 0 0 eth1
80.218.64.0 * 255.255.248.0 U 0 0 0 eth0

auf eth1 ist das LAN

eth0 ist das internet....also das cable-modem gibt dem redhat die ip

route add 192.168.3.0 eth0

hmmm.... dein router hat die adresse 192.168.3.0 aber 192.168.3.1 ist als gateway ??
also wenn dein router die adresse *3.0 hat dannn mußt du als gateway eben diese auch einstellen!!!!!

ich verstehe das so daß dein linuxrechner auch der router ist.... sehe ich das falsch ???

dir iptablesbefehle noch anwenden und gut ist.. meht braucht man da nicht zu machen.

mfg
 

pablovschby
Gast





BeitragVerfasst am: 31. März 2003 11:21   Titel: Re: RedHat....route add 192.....usw

danke, ich probiers bis spät. morgen aus, momentan keine zeit, sorry...
 

pablovschby
Gast





BeitragVerfasst am: 31. März 2003 11:52   Titel: jawohl...

danke für die antwort
---
hmmm.... dein router hat die adresse 192.168.3.0 aber 192.168.3.1 ist als gateway ??
---

nein,...wenn ich route eingebe, heissts zwar, dass auf eth1 die ip "192.168.3.0" ist, aber das ist die NETZADRESSE...

...dem linux-pc (also dem router) gab ich fest die ip: 192.168.3.1


---
also wenn dein router die adresse *3.0 hat dannn mußt du als gateway eben diese auch einstellen!!!!!
---

daher habe ich eben *.3.1 eingegeben und nicht die netzwerkadresse *3.0, wie sie in "route" angegeben wird,....


---
ich verstehe das so daß dein linuxrechner auch der router ist.... sehe ich das falsch ???
---

nein, richtig


---
dir iptablesbefehle noch anwenden und gut ist.. meht braucht man da nicht zu machen.
---

achja.,....?

was muss denn genau eingegeben werden, deiner meinung nach.,...

....bei mir funktioniert das routing immer noch net...


merci&gruss
pablo
 

andi
Gast





BeitragVerfasst am: 01. Apr 2003 8:35   Titel: Re: RedHat....route add 192.....usw

Hallo!
die routingtable deines ersten postings sieht für mich vollkommen ok aus (nichts dran ändern!)
echo 1 > /proc/sys/net/ipv4/ip_forward und
iptables -A POSTROUTING -t nat -o eth0 -j MASQUERADE
ist ebenfalls korrekt. Und nicht vergessen, dass er das nach jedem Neustart wieder vergisst!
Sonst ist eh keine firewall aktiv oder?
Hast du bei den Winclients auch den korrekten DNS Server angegeben?
Kannst du ip-adressen im www anpingen (von Client und Server)?
Und während der Versuche immer die Log´s im Auge behalten
mit
tail -f /var/log/messages
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Netzwerk Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy