Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
sobald 2. Karte aktiv, kein I-net mehr.....

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Netzwerk
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
pablovschby



Anmeldungsdatum: 14.02.2003
Beiträge: 25

BeitragVerfasst am: 28. Apr 2003 14:00   Titel: sobald 2. Karte aktiv, kein I-net mehr.....

Hallo

eth0 ist WAN--dhcp
eth1 ist LAN-->statische IP...

dann kann man die verschiedenen routings angeben: wenn nur eth0 also i-net aktiv, sagt route das:

Kernel IP Routentabelle
Ziel Router Genmask Flags Metric Ref Use Iface
bla.bla.bla.bla * 255.255.248.0 U 0 0 0 eth0
127.0.0.0 * 255.0.0.0 U 0 0 0 lo
default blablabla UG 0 0 0 eth0

aber sobald die 2. karte aktiv ist, heissts:

Kernel IP Routentabelle
Ziel Router Genmask Flags Metric Ref Use Iface
192.168.3.0 * 255.255.255.0 U 0 0 0 eth1
bla.bla.bla.bla * 255.255.248.0 U 0 0 0 eth0
127.0.0.0 * 255.0.0.0 U 0 0 0 lo

wobei bla natürlich die i-netadresse des modems wäre... ich hab mit "man route" alles rauskriegen versucht, aber find das einfach net raus: daher .mit welchem befehl muss ich dem redhat sagen, dass eth0 meine standard-nic(wan) ist...??
gruss&danke
pablo
 
Benutzer-Profile anzeigen Private Nachricht senden

Bob Gomorrha
Gast





BeitragVerfasst am: 28. Apr 2003 14:14   Titel: Re: sobald 2. Karte aktiv, kein I-net mehr.....

Schau mal in /etc/modules.conf

Dort sollte eigentlich drin stehen, was was ist.

cu

bg
 

pablovschby
Gast





BeitragVerfasst am: 28. Apr 2003 14:41   Titel: Re: sobald 2. Karte aktiv, kein I-net mehr.....

eth0 ist soundso

aber da stehen nur die treiber....
gruss&merci
pablo
 

Bob Gomorrha
Gast





BeitragVerfasst am: 28. Apr 2003 15:07   Titel: Re: sobald 2. Karte aktiv, kein I-net mehr.....

Das mein ich ja.

Die Zeile müsste in etwa (schwaches Erinnerungsvermögen) alias eth0 treiber lauten.
Wenn Du also eth0 und eth1 die entsprechen Treiber gegenüberstellst, sollte es klappen.

So wie ich das sehe, schmeisst er Dir jedesmal deinen "ursprünglichen" eth0 raus.

cu

bg
 

pablovschby



Anmeldungsdatum: 14.02.2003
Beiträge: 25

BeitragVerfasst am: 28. Apr 2003 15:33   Titel: Re: sobald 2. Karte aktiv, kein I-net mehr.....

aber das file ist ok....da steht:

alias eth0 $treiber
alias eth1 $treiber

gruss
 
Benutzer-Profile anzeigen Private Nachricht senden

Schiermeier Andreas
Gast





BeitragVerfasst am: 28. Apr 2003 16:57   Titel: Re: sobald 2. Karte aktiv, kein I-net mehr.....

route add default gw $IP_DES_GATEWAYS dev eth1

MfG
Schiermi
 

pablovschby
Gast





BeitragVerfasst am: 28. Apr 2003 17:16   Titel: Re: sobald 2. Karte aktiv, kein I-net mehr.....

ja,. merci, aber das problem ist ja, dass der gateway ein modem ist und dieses modem kriegt seine ip dynamisch.....
 

pablovschby



Anmeldungsdatum: 14.02.2003
Beiträge: 25

BeitragVerfasst am: 28. Apr 2003 17:36   Titel: LÖSUNG

so ging das nun:

route add default eth0

grusss&merci
pablo
 
Benutzer-Profile anzeigen Private Nachricht senden

pablovschby
Gast





BeitragVerfasst am: 28. Apr 2003 18:09   Titel: Re: sobald 2. Karte aktiv, kein I-net mehr.....

route add default eth0

wie kriege ich das persistent....wo muss was eing. werden...? bei jedem reboot ist wieder eth1 der default-......?
gruss&danke
pablo
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Netzwerk Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy