Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
SuSE8.2 & ssh: "can't open display"

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Netzwerk
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
tom
Gast





BeitragVerfasst am: 23. Mai 2003 8:41   Titel: SuSE8.2 & ssh: "can't open display"

Hi.

Ich hab mir SuSE 8.2 installiert. Nun habe ich mich über ssh an einem anderen Rechner angemeldet und wollte dort Netscape starten. Leider kommt nur die Meldung: "can't open display". Wenn ich versuche konqueror von dort zu starten, kommt die Meldung "cannot connect to X-Server".

Bis gestern hatte ich Mandrake 9 benutzt, und da hat das ohne Probleme funktioniert, soll heißen, das Netscape-Fenster wurde auf dem meinem Bildschirm angezeigt und war benutzbar.

Wo muss ich was bei SuSE änder, damit das wieder funktioniert?

Danke
tom
 

nano



Anmeldungsdatum: 09.08.2002
Beiträge: 200

BeitragVerfasst am: 23. Mai 2003 9:32   Titel: Re: SuSE8.2 & ssh:

Hi tom,

klappt es wenn du folgendes machst:

1. Auf deinem lokalen Rechner in einer Konsole eintippen: xhost + <name des anderen Rechners>
2. mit ssh an dem anderen Rechner anmelden.
3. dort folgendes absetzten: export DISPLAY=<dein rechnername/bzw ip>:0.0
4. als Test zB. xterm auf dem anderen Rechner aufrufen.

Wenn das nicht klappt, dann akzeptiert dein X-Server möglicherweise keine Verbindung von Außerhalb und du mußt ihn mit der entsprechenden Option starten (wie das geht hängt davon ab, welchen Displaymanager du benutzt).

Gruß,
nano
 
Benutzer-Profile anzeigen Private Nachricht senden

tom
Gast





BeitragVerfasst am: 23. Mai 2003 15:34   Titel: Re: SuSE8.2 & ssh:

Leider scheint der andere Rechner "export" nicht zu kennen:

"export: Command not found."

Aber es muss doch etwas an meiner SuSE-Installation sein. Mit Mandrake hat's ja vorher auch funktioniert...
 

nano



Anmeldungsdatum: 09.08.2002
Beiträge: 200

BeitragVerfasst am: 23. Mai 2003 17:17   Titel: Re: SuSE8.2 & ssh:

>Leider scheint der andere Rechner "export" nicht zu kennen:
>"export: Command not found."
Was für eine shell hast du denn auf diesem Rechner? Mit export setzt man Variablen in der bash, wenn auf dem Rechner eine andere shell benutzt wird, mußt du DISPLAY mit dem entsprechendne Kommando setzten.
Du kannst auch mal versuchen einfach eine bash zu starten. (Aufruf mit bash)

>Aber es muss doch etwas an meiner SuSE-Installation sein. Mit Mandrake hat's ja vorher auch funktioniert...
Da hat vermutlich der ssh-client die Sache automatisch erledigt.

Versuch es aber trotzdem nochmal von Hand.
Wenn es von Hand nicht geht, kann auch der ssh-client nix machen.
In diesem Fall liegt es dann vermutlich an deinem X-Server, der nicht auf TCP-Verbindungen wartet.

Gruß,
nano
 
Benutzer-Profile anzeigen Private Nachricht senden

tom
Gast





BeitragVerfasst am: 23. Mai 2003 19:02   Titel: Re: SuSE8.2 & ssh:

die bash hab ich gefunden, aber es geht trotzdem nicht.

Kann ich dem X-Server irgendwie beibringen, auf TCP-Verbindungen zu warten?
 

nano



Anmeldungsdatum: 09.08.2002
Beiträge: 200

BeitragVerfasst am: 23. Mai 2003 21:11   Titel: Re: SuSE8.2 & ssh:

Benutzt du kdm?

Dann ist in der Datei /etc/kde/kdm/Xservers festgelegt, mit welchen Optionen der Xserver gestartet werden soll.
Dort steht vermutlich eine Zeile, die so ähnlich aussieht wie:

:0 local@tty1 /etc/X11/X -dpi 100 -nolisten tcp vt7

Das -nolisten tcp bedeutet dabei, daß der Xserver auf keine Verbindung über tcp wartet. Wenn du diese Option entfernst, sollte es funktionieren.

Falls du xdm benutzt, liegt die Datei unter /etc/X11/xdm. Bei gdm weiß ich leider nicht wie das Starten des Xservers kontrolliert wird. Eventuell wird hier auch einfach die Datei /etc/X11/xdm/Xservers ausgewertet.

Wenn du keinen derartigen Eintrag findest, dann kann die Verbindung natürlich auch in einer eventuell vorhandenen Firewall hängen bleiben.

Viel Erfolg,
nano
 
Benutzer-Profile anzeigen Private Nachricht senden

tom
Gast





BeitragVerfasst am: 23. Mai 2003 22:17   Titel: Re: SuSE8.2 & ssh:

Endlich hab ich die Lösung gefunden. SuSE ist OK, aber ich war zu blöd.
Unter Mandrake habe ich mich immer mit "ssh -l user@rechner" angemeldet.
Bei SuSE muss man "ssh -X user@rechner" verwenden. Das "X11 connection forwarding" standardmäßig deaktiviert.

Ich danke dir trotzdem. Ohne dich hätte ich wohl einfach aufgegeben.

tom
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Netzwerk Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy