Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Hilfe! Nach Firewall aus/wieder ein geht nichts mehr :-((

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Netzwerk
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
neulux



Anmeldungsdatum: 17.03.2003
Beiträge: 29
Wohnort: Schweiz

BeitragVerfasst am: 27. Mai 2003 11:18   Titel: Hilfe! Nach Firewall aus/wieder ein geht nichts mehr :-((

Guten Tag liebe Forumbesucher

Ich hatte auf einem PC ein Linux-Gateway eingerichtet, das wunderbar funktionierte. Um etwas auszuprobieren habe ich die Firewall per Yast ausgeschaltet, Minuten später wieder eingeschaltet - und nichts ging mehr. Tausend Sachen ausprobiert, Foren angefragt... nichts. Suse Support: inexistent. "Gebrauchsanweisungen" auf SuSE-Server funktionieren nicht. Jetzt habe ich SUSE Linux 8.1 komplett neu installiert und immer noch Probleme. Seid ihr meine letzte Rettung? Hier die Details (weil ich trotz allem noch ein ganz klein Bisschen Hoffnung habe...):

- Suse 8.1 Minimalsystem frisch installiert (auch Disks neu formatiert)
- plus smppp, ppp, wget, bind8 und pico installiert (mit Yast)
- Online Update heute gemacht ("Automatisch")
- Beide Netzwerkkarten mit Yast eingerichtet:
eth0 192.168.1.2 geht direkt ans Zyxel P650-ME (DSL, IP 192.168.1.1)
eth1 192.168.2.1 geht an Switch, von da an 1 Windows und 1 Linux-PC mit 192.168.2.2 bzw. ...3
- DSL mit Yast eingerichtet (ppp over Ethernet auf eth0)
- Nameserver bind8 eingerichtet

soweit so gut:
- ping vom Gateway auf beide internen Karten, auf die beiden anderen PCs und aufs "ADSL-Modem" funktionert
- ping von den anderen PCs auf beide Gateway-Netzkarten (...1.2 und ...2.1) funktioniert
- ping vom Gateway aus an IP ins Internet funktioniert
- host "name" funktioniert für intern und internet (am Gateway-PC)
- ping www.suse.de funktioniert (am Gateway-PC) und
- auch w3m-browser "w3m www.suse.de" funktioniert (am Gateway-PC),

aber:
- w3m zu meiner eigenen Website (bei Provider) www.daniel-bauer.com geht nicht ("unknown URI...")
- ping von den anderen PC's aus aufs "Modem" geht nicht (und natürlich auch nicht darüber hinaus ins Netz). Das könnte ich noch begreifen, weil ich ja das Masquerading/SuSEfirewall2 zu diesem Zeitpunkt noch nicht eingeschaltet habe. IP_Forward (in Yast/Netzwerkkarte einrichten/Routing) ist aber "yes".

Jetzt habe ich die Datei SuSEfirewall2 in /etc/sysconfig editiert. Das SuSE Linux 8.1 Administrationshandbuch enthält allerdings "Tags", die es im File nicht gibt (wie es übrigens auch die dort auf Seite 485 beschriebene Datei /etc/sysconfig/network/options und noch vieles andere bei mir nicht gibt).

Anhand der englischen Texte in der Datei selber einigermassen eingerichtet. Dann im Yast/runlevel die Firewall aktiviert, shutdown, neu gestartet.

nun:
- beim Start (u.a. folgende Meldung:
Firewall Initialization (phase 3 of 3) Warning: detected activated named, enabling FW_SERVICE_DNS!
You still have to allow tcp/udp port 53 on internal, dmz and/or external.
- es fällt mir auf, dass nebst lo, eth0 und eth1 noch ein network interface "dsl0" angezeigt wird, rechts aussen steht "manual"...
- vom Gateway-PC aus funktioniert das pingen, dns und w3m immer noch wie zuvor
- aber: von den anderen PCs aus kann ich die eth0-Karte (192.168.1.2) jetzt auch nicht mehr anpingen, das "Modem" schon gar nicht (die 192.168.2.1 aber schon)

Dieses Konfigurationsfile habe ich zur Einsichtnahme hier auf meinen Intenetserver gestellt:
http://www.daniel-bauer.com/muster/SuSEfirewall2.Versuch1.txt

Also habe ich die Firewall wieder abgestellt, mein Konfigurationsfile weggesichert, das unveränderte Original wieder hingesichert und die Firewall in YAST gemäss Gebrauchsanweisung wieder eingerichtet.

Dann:

geht auch vom Gateway-PC nichts mehr ins Netz (auch nicht mehr zum "Modem").

Schalte ich die Firewall wieder aus ists wieder wie vorher...
-------
Ich werde nicht mehr schlau! M.E. habe ich alles genau gleich gemacht, wie damals, als es einfach klappte - aber jetzt will es einfach nicht mehr. Habe ich irgend eine Kleinigkeit übersehen? Ich bitte hoffnungsvoll um Tipps.

Mit freundlichen Grüssen

Daniel

PS: Sorry für langen Text, wollte möglichst genaue Angaben machen.
PS2: Auf dem Gateway-PC brauche ich ausser Routing/Firewall/DNS sonst nichts.
PS3: mit bind9 (statt Cool habe ichs auch schon versucht/keine Aenderung...

PS3: Wer mir soweit hilft, dass das ganze wieder läuft, bekommt von mir - bei Interesse, natürlich - meine "Private Collection CD" (künstlerische Aktfotografie) als Belohnung. Mehr kann ich als Künstler nicht bieten...
 
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen

Marc
Gast





BeitragVerfasst am: 27. Mai 2003 12:10   Titel: Re: Hilfe! Nach Firewall aus/wieder ein geht nichts mehr :-((

Hi
PINGEN geht aber keine Namensauflösung!.

>nun:
- beim Start (u.a. folgende Meldung:
Firewall Initialization (phase 3 of 3) Warning: detected activated named, enabling FW_SERVICE_DNS!
You still have to allow tcp/udp port 53 on internal, dmz and/or external.<

Das hier ist Deine Einstellung.

# If you are running bind/named set to yes. Remember that you have to open
# port 53 (or "domain") as udp/tcp to allow incoming queries.
# Also FW_ALLOW_INCOMING_HIGHPORTS_UDP needs to be "yes"
FW_SERVICE_DNS="no"

Ändere das doch mal in
FW_SERVICE_DNS="yes"

Den Rest habe ich mir nicht durchgelesen, wenn es nicht klappt, melden.

Gruss
Marc
 

neulux



Anmeldungsdatum: 17.03.2003
Beiträge: 29
Wohnort: Schweiz

BeitragVerfasst am: 27. Mai 2003 13:20   Titel: Re: gerettet!

Marc, danke!

Genau das wars. Alles funktioniert wie ich's mir nur wünschen kann.
Ganz, ganz herzlichen Dank.

Wenn du mir für die CD deine Adresse via mein Kontaktformular auf meiner Website schickst http://www.daniel-bauer.com/de/kontakt/index.html dann wird mir deine IP-Adresse mit übermittelt und ich kann sie mit der deines Postings vergleichen (nicht dass mir jetzt 50 Leute schreiben "ich bin der Marc, dein Retter"

Gruss

Daniel
 
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen

Marc
Gast





BeitragVerfasst am: 27. Mai 2003 17:25   Titel: Re: Hilfe! Nach Firewall aus/wieder ein geht nichts mehr :-((

Hi
nett gemeint, aber nicht nötig.
:)

Gruss
Marc
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Netzwerk Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy