Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Sendmail funzt nicht richtig

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Netzwerk
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
fistro



Anmeldungsdatum: 15.08.2002
Beiträge: 4

BeitragVerfasst am: 10. Jun 2003 17:00   Titel: Sendmail funzt nicht richtig

HILFEE !!! Seit einem Linux/Sendmail-Update läuft der Mailer nicht mehr richtig.
Gibt es da draussen irgendeinen Sendmail-Profi, der mir weiterhelfen kann???


- SuSE Linux 8.1
- Sendmail 8.12.6
- Sendmail läuft Standalone (nicht inetd)
- SMTP-after-POP-Daemon gemaess http://arcgraph.de/sr/smaccessd/ dazugebaut (funktioniert)
- ich benutze nicht (!) .mc-Dateien, sondern arbeite direkt mit sendmail.cf (mit den mc-Files klappt irgendwie garnix mehr).

Es funktioniert:

- Empfang von Emails. Abruf per POP3. SMTP-Versand über den Rechner.

das Problem:

- Emails, die lokal erzeugt werden (PHP, Perl oder manueller Aufruf: sendmail) werden nicht versendet.

Eine per PHP-Skript erzeugte Mail liefert in /var/log/mail:

Jun 10 17:48:47 ns1 sendmail[4944]: h5AFmlgc004944: from=www, size=863, class=0, nrcpts=1, msgid=<200306101548.h5AFmlgc004944@ns1.krumedia.de>, relay=www@localhost
Jun 10 17:48:47 ns1 sendmail[4944]: h5AFmlgc004944: to=mk@krumedia.de, ctladdr=www (30/65534), delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=30043, relay=localhost.krumedia.de. [127.0.0.1], dsn=5.6.0, stat=Data format error


Will ich eine Email von Hand losschicken (Aufruf "sendmail mk@krumedia.de </etc/irgendeineDatei" - das ging früher auch problemlos), bekomm ich ne ganze Latte an Meldungen:

Jun 10 17:49:42 ns1 sendmail[5006]: h5AFngGP005006: from=root, size=45, class=0, nrcpts=1, msgid=<200306101549.h5AFngGP005006@ns1.krumedia.de>, relay=root@localhost
Jun 10 17:49:42 ns1 sendmail[5006]: h5AFngGP005006: to=mk@krumedia.de, ctladdr=root (0/0), delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=30019, relay=localhost.krumedia.de. [127.0.0.1], dsn=5.6.0, stat=Data format error
Jun 10 17:49:42 ns1 sendmail[5006]: h5AFngGP005006: h5AFngGQ005006: DSN: Data format error
Jun 10 17:49:42 ns1 sendmail[5007]: h5AFnggl005007: <root@ns1.krumedia.de>... >root<@ns1.krumedia.de.
Jun 10 17:49:42 ns1 sendmail[5006]: h5AFngGQ005006: to=root, delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=31069, relay=localhost.krumedia.de., dsn=5.3.0, stat=User unknown
Jun 10 17:49:42 ns1 sendmail[5007]: h5AFnggl005007: from=<>, size=1069, class=0, nrcpts=0, proto=ESMTP, daemon=MTA, relay=localhost [127.0.0.1]
Jun 10 17:49:42 ns1 sendmail[5006]: h5AFngGQ005006: h5AFngGR005006: return to sender: User unknown
Jun 10 17:49:42 ns1 sendmail[5007]: h5AFnggn005007: <postmaster@ns1.krumedia.de>... >postmaster<@ns1.krumedia.de.
Jun 10 17:49:42 ns1 sendmail[5006]: h5AFngGR005006: to=postmaster, delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=32093, relay=localhost.krumedia.de. [127.0.0.1], dsn=5.3.0, stat=User unknown
Jun 10 17:49:42 ns1 sendmail[5007]: h5AFnggn005007: from=<>, size=2093, class=0, nrcpts=0, proto=ESMTP, daemon=MTA, relay=localhost [127.0.0.1]
Jun 10 17:49:42 ns1 sendmail[5006]: h5AFngGQ005006: Losing ./qfh5AFngGQ005006: savemail panic
Jun 10 17:49:42 ns1 sendmail[5006]: h5AFngGQ005006: SYSERR(root): savemail: cannot save rejected email anywhere


hast jemand ne Idee, wo ich da ansetzen kann?? Bin ratlos ...

Für Tipps an krutwig@gmx.de bin ich dankbar )



Gruesse,
Michael

[weiss nicht so genau, ob's bei "Netzwerk" passt, drum hab ich auch in "Allgemeine Fragen" gepostet]
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Netzwerk Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy