Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
RedHat 9.0 + 56k-Modem = aaarrrgg !!!

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Netzwerk
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
jensus



Anmeldungsdatum: 31.07.2003
Beiträge: 7

BeitragVerfasst am: 31. Jul 2003 12:51   Titel: RedHat 9.0 + 56k-Modem = aaarrrgg !!!

Ich (noch relativ unerfahren in Sachen Linux) habe RedHat Linux 9.0 (Pro) auf zwei Rechnern (komplett) installiert (1x Tower, 1x Notebook). Beide Rechner (das Notebook sowieso) haben sogenannte Winmodems.

Nach einiger Lektüre im Netz und Tests mit einigen Skripten folgte die Installtion des slmdm-2.7.10-Treibers von SmartLink. Alles kein Problem soweit.

Mit 'kppp' konnte ich sofort eine Verbindung aufbauen. Allerdings fehlten Einträge für die Nameserver in '/etc/resolv.conf'. Selbst wenn ich diese in der GUI von 'kppp' eingebe werden sie nicht gespeichert (Wieso ?). Mit dem Gnome/RedHat-Tool 'network-config' (was standardmäßig über die Menüs erreichbar ist) lassen sich die DNS zwar tatsächlich speichern, jedoch kann das Gerät nicht aktiviert werden.

Ich dachte okay, dann nehme ich halt 'kppp', doch leider braucht dieses Programm immer 'root'-Rechte, sicherlich nicht der optimale Weg (zumal den/die Rechner auch meine Freundin benutzt).

Also bei 'kppp' habe ich das 'root'-Problem und bei 'network-config' offensichtlich ein Problem mit unerkannter Hardware/Treiber. Ich weiß nicht, ob es von belang ist, aber 'ifconfig' kennt das Gerät 'ppp0' nicht, obwohl es in 'network-config' korrekt angezeigt aber nicht aktivert werden kann.

'network-config' zeigt mir in der Liste der auswählbaren Geräte/Schnittstellen auch nur die ganzen 'ttyXXX' an während 'kppp' auch '/dev/modem' kennt (dahinter verbirgt sich wohl 'ttyS0').

Was soll ich nun tun, um einen ergonomischen (!) Weg ins Internet zu finden ???
 
Benutzer-Profile anzeigen Private Nachricht senden

jj
Gast





BeitragVerfasst am: 31. Jul 2003 23:19   Titel: Re: RedHat 9.0 + 56k-Modem = aaarrrgg !!!

Um kppp auch als user nutzen zu koennen, muss der Nutzer wahrscheinlich in der entspr. Gruppe mit den entspr. Rechten zum rauswaehlen sein. Kenne die Details bei Red Hat nicht, unter Debian ist es die Gruppe dialout.
 

brum
Gast





BeitragVerfasst am: 01. Aug 2003 7:23   Titel: Re: RedHat 9.0 + 56k-Modem = aaarrrgg !!!

Hallo Glücklicher,

dem es gelang, das modem mit diesem Treiber anzusprechen. Was für ein Modem hast Du genau ?
Ich habe ein MDC slimmodem, das lässt sich zwar ansprechen, aber es wählt nicht wirklich ....

Zu Deinem Rechte-Problem:
Sei mal root und mache ein 'chmod 4755 /usr/ in/kppp'.
Dan klappts auch mit dem user.

Bye brum
 

jensus
Gast





BeitragVerfasst am: 01. Aug 2003 9:28   Titel: Re: RedHat 9.0 + 56k-Modem = aaarrrgg !!!

Hallo brum,

also mit den Modems ist das so eine Sache. Habe einmal unter Windows nachgesehen und dann nochmal mit den Tools 'listModem' (gibt's bei www.linuxant.org) und dann mit 'scanModem' (Link gibt's irgendwo bei linmodems.org). Die Aussagen/Bezeichnungen der drei Quellen passen nicht unbedingt zusammen. Allerdings gibt 'scanModem' in beiden Fällen (Tower & Notebook) an, daß in jedem Fall der Treiber von SmartLink (www.smlink.com) auch in Betracht käme, aber nur die Version 2.7.10, spätere würden keinen vernünftigen Dial-Up hinbekommen. Mit 2.7.14 klappte es tatsächlich nicht. Mit 2.7.10 flutschte es aber auf anhieb. Für mein Notebook (IBM ThinkPad X30) soll es wohl mittlerweile direkt von IBM einen Treiber für Linux geben.

Zu den Modems kann ich mit einiger Wahrscheinlichkeit sagen, welche Chipsätze verwendet werden (darauf kommt es ja an):
Notebook: Acer (Windows sagt "Aegere AC'97")
Tower: Conexant (sagt auch mein Hardware-Dealer: www.schiwi.de -> 56K-PCI für 15 EUR, Windows sagt "SmartPCI 561")

Probiere auf jedenfall mal die beiden oben erwähnten Tools, dann kannst Du gezielt(er) nach Treibern suchen.

Gruß

jensus
 

jensus
Gast





BeitragVerfasst am: 01. Aug 2003 11:23   Titel: Re: RedHat 9.0 + 56k-Modem = aaarrrgg !!!

Die Gruppe 'dialout' kann ich leider unter RedHat nicht finden, weder in der GUI (da werden gar keine Gruppen angezeigt, aber es sollte doch welche geben, oder ?) noch in '/etc/passwd' (wo sie glaube ich drinstehen sollten).
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Netzwerk Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy