Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
win2k-client (SP4) am Samba-PDC

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Netzwerk
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
pierre
Gast





BeitragVerfasst am: 04. Sep 2003 11:38   Titel: win2k-client (SP4) am Samba-PDC

An alle Samba-Profis!

Seit einem knappen Jahr betreibe ich nun schon samba als pdc, aktuell auf SuSE8.2 und Samba 2.2.7 (alle patches eingespielt). Nun kommen wir zum problem:
Gestern habe ich bemerkt, das ich nach aktivierung des rootaccounts in der smbpasswd zu bearbeitung von logon-scripten in der Netlogonshare mit root keinen zugriff mehr habe, es kommt der popup mit beutzer/kennwort-abfrage. Gebe ich root mit dazu gehörigem passwort ein kommt "Falscher Benutzername oder Kennwort". Habe daraufhin das rootpasswort in der smbpasswd neu vergeben, ohne erfolg. Dabei spielte es keine rolle, ob root auf dem client lokal oder an der domäne angemeldet war. Habe dann den client aus der Domäne wieder entfernt um ihn im anschluss wieder dort anzumelden. Das klappt jetzt auch nicht mehr, weil win2k-client sagt "Beim Versuch der Domäne xyz beizutreten, trat folgender Fehler auf: Die angegebenen Anmeldeinformationen stehen mit vorhandenen Anmeldeinformationen in Konflikt"

Hier mal meine smb.conf:


# Samba config file created using SWAT
# from localhost (127.0.0.1)
# Date: 2003/09/04 12:02:17

# Global parameters
[global]
workgroup = yxz
netbios name = Master
server string = Samba %v on %h
interfaces = lo eth0
bind interfaces only = Yes
encrypt passwords = Yes
map to guest = Bad User
pam password change = Yes
passwd program = /usr/bin/passwd %u
passwd chat debug = Yes
password level = 1
username level = 1
log level = 2
syslog = 2
log file = /var/log/samba.log.%m
max log size = 500
name resolve order = lmhosts bcast wins
time server = Yes
keepalive = 30
max disk size = 1000
socket options = IPTOS_LOWDELAY TCP_NODELAY
character set = ISO8859-15
domain admin group = @adm, root, ntadmin
add user script = /usr/sbin/useradd -d -g 100 /dev/null -s /bin/false -M %m$
logon script = login.bat^M
logon path = \%L\profiles\%M\%U
logon drive = L:
logon home = \%L\%U\profiles
domain logons = Yes
os level = 65
preferred master = Yes
domain master = Yes
wins support = Yes
default service = homes
winbind separator = +
path = var/spool/lpd
guest account = guest
admin users = root, @adm, @ntadmin
write list = root,@adm,@ntadmin
printer admin = @adm, @users, @ntadmin
guest ok = Yes
max connections = 3
printing = cups
printer name = lp
browseable = No
share modes = No

[printers]
comment = All Printers
path = /tmp
create mask = 0700
min print space = 2000
printable = Yes
print command = lp -c -d%p %s; rm %s
lpq command = lpstat -o%p
lprm command = cancel %p-%j
lppause command = lp -i %p-%j -H hold
lpresume command = lp -i %p-%j -H resume
queuepause command = disable %p
queueresume command = enable %p
printer name = printer1
use client driver = Yes

[cdrom]
comment = CD-ROM
path = /cdrom
valid users = @users
max connections = 0
browseable = Yes
exec = mount /dev/cdrom
postexec = umount /dev/cdrom

[homes]
comment = Arbeitsverzeichnis
path = /home/%U/Documents
guest account =
valid users = %S
read only = No
create mask = 0700
directory mask = 0700
guest ok = No
locking = No
oplocks = No
level2 oplocks = No

[Netlogon]
comment = Netlogon
path = /var/lib/samba/netlogon/
valid users = root, @ntadmin, @users
guest ok = No
max connections = 0
exec = /var/lib/samba/netlogon/login.bat^

[profiles]
comment = Network Profiles Service
path = /var/lib/samba/profiles
read only = No
create mask = 0600
directory mask = 0700
max connections = 0
share modes = Yes

Achso, auf die public shares sowie Drucker kann er natürlich zugreifen. Ich kann mich auch nicht erinnern hinsichtlich der ursache für dieses problem etwas an der
smb.conf geändert zu haben, zumal es ja noch vor ca. 8 wochen funktioniert hat, weil ich von SuSE 8.0 auf 8.2 upgedatet hatte.

Vielen Dank für jede Hilfe im vorraus!
 

arno
Gast





BeitragVerfasst am: 04. Sep 2003 11:48   Titel: Re: win2k-client (SP4) am Samba-PDC

hi

versuche mal alle netzlaufwerke zu trennen und dich dann an der domäne anmelden.

mfg arno
 

Michael
Gast





BeitragVerfasst am: 04. Sep 2003 12:06   Titel: Re: win2k-client (SP4) am Samba-PDC

Das trennen geht mit net use /DELETE in der Kommandozeile.

Wenn es dann immer noch nicth geht. Von der Domaine in eine
Arbeitsgruppe wechseln, die einen anderen Namen hat-> Neustart
->dann der Domäne wieda beitreten.

smb.conf

admin users = administrator root

Cheers

Michael
 

pierre
Gast





BeitragVerfasst am: 04. Sep 2003 14:24   Titel: Re: win2k-client (SP4) am Samba-PDC

Danke erst mal,

an den evtl. vorhandenen Netzwerkverbindungen könnte es gelegen haben. Im Explorer konnte ich nämlich noch shares sehen auf die root mal in der vergangenheit zugegriffen hat. Die habe ich dann rausgelöscht, ab- und wieder angemeldet und dann ging es plötzlich. Offensichtlich kann sowas passieren wenn root sich am client lokal anmeldet, der account aus sicherheitsgründen in der smbpasswd deaktiviert wurde, und er beim zugriff auf shares einen normalen benutzeraccount verwendet. Anders kann ichs mir nicht erklären, aber trotzdem eine interessante erfahrung.

Danke Euch nochmal

Gruss Pierre
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Netzwerk Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy