Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
probleme mit zwei linux rechnern und d-link di-604

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Netzwerk
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
inservo
Gast





BeitragVerfasst am: 21. Feb 2004 14:43   Titel: probleme mit zwei linux rechnern und d-link di-604

hallo, zusammen...

ich habe zwei rechner mit suse linux 8.2, einen desktop und einen laptop. nun habe ich diese beiden gemäß der beschreibung in der anleitung an einen router d-link di-604 angeschlossen, genau so wie mein dsl-modem (tdsl). ich habe dabei genau die schritte der anleitung befolgt, d.h. alles runtergefahren ausgeschaltet etc.

nun habe ich folgendes problem: mit meinem desktop rechner, der vorher als einziges direkt mit dem dsl-modem und somit dem net verbunden war, kann ohne probleme online gehen. auch die konfiguration des routers über den browser funktionierte einwandfrei. nur mit dem laptop, das vorher noch nicht online war, funktioniert es nicht.

eigentlich würde ich gerne die folgenden beiden dinge tun:

1) mit beiden rechnern (auch gleichzeitig) ins net gehen
2) von beiden rechnern jeweils aufeinander zugreifen (zb am laptop mp3s von der hdd des desktop rechners abspielen etc.)

kann mit wer helfen bei der lösung des problems? zur klärung habe ich auch noch mal die ausgabe beigefügt, die "ifconfig" auf dem laptop ergeben hat (thx@d_o_z_e_r):

eth0 Protokoll:Ethernet Hardware Adresse 00:50:04:40:CF:2E
inet6 Adresse: fe80::250:4ff:fe40:cf2e/64 Gültigkeitsbereich:Verbindung
UP BROADCAST NOTRAILERS MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:42 errors:0 dropped:0 overruns:0 carrier:42
Kollisionen:0 Sendewarteschlangenlänge:100
RX bytes:0 (0.0 b) TX bytes:15970 (15.5 b)
Interrupt:10 Basisadresse:0xcc00

lo Protokoll:Lokale Schleife
inet Adresse:127.0.0.1 Maske:255.0.0.0
inet6 Adresse: ::1/128 Gültigkeitsbereich:Maschine
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:202 errors:0 dropped:0 overruns:0 frame:0
TX packets:202 errors:0 dropped:0 overruns:0 carrier:0
Kollisionen:0 Sendewarteschlangenlänge:0
RX bytes:12748 (12.4 Kb) TX bytes:12748 (12.4 Kb)



DANKE SCHONMAL VORAB FÜR EURE HILFE!!!!

grüße

inservo
 

petameta
prolinux-forum-admin


Anmeldungsdatum: 14.02.2003
Beiträge: 1294

BeitragVerfasst am: 21. Feb 2004 14:55   Titel: Re: probleme mit zwei linux rechnern und d-link di-604

Ist ja auch kein Wunder, Dein Laptop hat nur eine ipv6-Adresse, keine ipv4-Adresse. Mach mal als root ein ifconfig, z. B.:

ifconfig eth0 192.168.0.10 (IP-Adresse natürlich entsprechend anpassen). Dann sollte schon mal ein Ping auf den anderen Rechner klappen. Als nächstes muß das default-gw gesetzt werden:

route add default gw 192.168.0.1 (Beispiel, Adresse wieder ersetzen !)

Außerdem muß der nameserver in der /etc/resolv.conf gesetzt werden. Dieser ist entweder die Adresse des routers, wenn dieser einen bereistellt, oder der Deines Providers (--> google oder direkt nachfragen).

Wenn's so klappt, kannst Du es mit Hilfe von yast auch fest einstellen. So ist die Konfiguration nach Neustart weg.
 
Benutzer-Profile anzeigen Private Nachricht senden

inservo
Gast





BeitragVerfasst am: 22. Feb 2004 13:29   Titel: Re: probleme mit zwei linux rechnern und d-link di-604

hallo, Peta...

hmmm. ich komme trotzdem noch nicht so richtig klar. ich habe also als root ifconfig eth0 192.168.0.30 (die IP-Adresse des Desktop Rechners, die des Routers lautet 192.168.0.1) gemacht. dann habe ich diesen route add befehl gemacht, danach einen ping auf den desktop rechner, das hat dann endlos irgendwelche auflistungen gemacht. das habe ich 5 minuten laufen lassen, bevor ich es abgebrochen habe. ich blick bei diesem ganzen zeuch echt nicht mehr durch. wo zB kann ich das denn im yast einstellen? ich habe mich da schon drei stunden durchgequält und bisher nix erreicht. vielleicht mal für ganz doofe??? danke!!!!
 

petameta
prolinux-forum-admin


Anmeldungsdatum: 14.02.2003
Beiträge: 1294

BeitragVerfasst am: 23. Feb 2004 15:19   Titel: Re: probleme mit zwei linux rechnern und d-link di-604

Ist ja auch Sinn des ping-Befehls Smile.

Ein erfolgreicher Ping sieht ungefähr so aus:

------------------------------------------------------------------------
PING 192.168.0.100 (192.168.0.100) from 192.168.0.37 : 56(84) bytes of data.
64 bytes from 192.168.0.100: icmp_seq=1 ttl=64 time=704 usec
64 bytes from 192.168.0.100: icmp_seq=2 ttl=64 time=532 usec
64 bytes from 192.168.0.100: icmp_seq=3 ttl=64 time=542 usec

--- 192.168.0.100 ping statistics ---
3 packets transmitted, 3 received, 0% loss, time 1998ms
rtt min/avg/max/mdev = 0.532/0.592/0.704/0.083 ms
------------------------------------------------------------------------

Ein nicht erfolgreicher z. B. so:

------------------------------------------------------------------------
PING 192.168.0.101 (192.168.0.101) from 192.168.0.37 : 56(84) bytes of data.
From 192.168.0.37: icmp_seq=1 Destination Host Unreachable
From 192.168.0.37 icmp_seq=1 Destination Host Unreachable
From 192.168.0.37 icmp_seq=2 Destination Host Unreachable
From 192.168.0.37 icmp_seq=3 Destination Host Unreachable
------------------------------------------------------------------------

Mir ist noch eingefallen: Evtl. mußt Du vorher ein "route del default" machen, für den Fall, daß es schon ein Standardgateway (oder Default Route) gibt.
 
Benutzer-Profile anzeigen Private Nachricht senden

inservo
Gast





BeitragVerfasst am: 23. Feb 2004 20:02   Titel: Re: probleme mit zwei linux rechnern und d-link di-604

also... ich habe dieses ifconfig etc. gemacht... dann den ping auf die adresse des desktop rechners, der hat auch funktionert, allerdings habe ich den vor ca. 10 min gestartet und bin momentan bei icmp_seq 580 und weiterzählend. als antwortzeit steht da immer so um die 0,06 sec.... hört sich ja ganz passabel an, oder?

ich weiss hier auch wirklich nicht mehr weiter, zumal der router angeblich automatisch als server agiert und per DHCP die ip's verteilt. wie gesagt, bei dem desktop rechner scheint das ja auch zu funktionieren.

also wenn das so weiter geht, schmeiss ich linux wieder runter, verkauf den blöden router und bleibe bei meinem windoof (weil ichs wohl selber auch bin), war schliesslich teuer genug Smile))

grüße

inservo
 

petameta
prolinux-forum-admin


Anmeldungsdatum: 14.02.2003
Beiträge: 1294

BeitragVerfasst am: 24. Feb 2004 10:26   Titel: Re: probleme mit zwei linux rechnern und d-link di-604

Also nochmal zum ping: Den brauchst Du sicher keine 10 Minuten laufen lassen, Du kannst den Befehl jederzeit mit STRG-C abbrechen. Wenn ein paar pings (5 oder so reichen) funktioniert haben, ist alles OK. Die Antwortzeit spielt keine große Rolle, es sei denn, die fällt extrem aus dem Rahmen (mehrere Sekunden).

Was mich wundert, ist daß Du eine ipv6-Adresse per DHCP bekommen hast. Funktioniert der D-Link router schon mit ipv6 ? Würde mich eher wundern.

Check doch bitte mal folgende Sachen, auch wenn sich das jetzt etwas einfach anhört:

- Besteht überhaupt rein Hardware-mäßig eine Verbindung zum Netzwerk ? Leuchtet die Netzwerk-Lampe am Router/Switch/Netzwerkkarte ?
- Hast Du einen dhcp-client installiert ? Versuch mal folgendes (als root !):

dhclient eth0

Wenn erfolgreich, sollte die Ausgabe ungefährt so aussehen:

--------------------------------------------------------
Internet Software Consortium DHCP Client V3.0rc4
Copyright 1995-2001 Internet Software Consortium.
All rights reserved.
For info, please visit http://www.isc.org/products/DHCP

Listening on LPF/eth0/00:80:c8:76:95:a1
Sending on LPF/eth0/00:80:c8:76:95:a1
Sending on Socket/fallback
DHCPREQUEST on eth0 to 255.255.255.255 port 67
DHCPACK from 192.168.0.100
bound to 192.168.0.254 -- renewal in 1529 seconds.
--------------------------------------------------------

Wenn das nicht klappt tippe ich mal auf Fehler im Netzwerk. Dann überprüfe mal das Kabel. Wenn das OK ist, könnte es sein, daß die Netzwerkkarte und Router die Geschwindigkeit nicht richtig aushandeln können, dies müßte dann zumindest auf einer Seite festgelegt werden. Welche Netzwerkkarte benutzt hat der Rechner ?

Wenn das funktioniert hat, weiß ich auch nicht so recht, kenne mich mit Hardware-Routern nicht so aus, und den D-Link habe ich noch nie gesehen (verständlicherweise).

Mit SuSE 8 habe ich noch nicht gearbeitet. Es müßte doch in yast2 möglich sein, das alles einzustellen. Wenn's per DHCP klappen soll, muß es irgendwie auf automatische Addresszuweisung stehen. Ich benutze yast2 nicht (mehr), weiß es deshalb nicht so genau.


Zuletzt bearbeitet von petameta am 24. Feb 2004 10:26, insgesamt 1-mal bearbeitet
 
Benutzer-Profile anzeigen Private Nachricht senden

inservo
Gast





BeitragVerfasst am: 25. Feb 2004 19:00   Titel: Re: probleme mit zwei linux rechnern und d-link di-604

hallo...

also, die ping antwortzeiten sind ganz okay.. wie gesagt so um die 0,06 sekunden immer...

eine hardwaremäßige verbindung besteht, die lampe leuchtet genau wie bei dem desktoprechner (auch in derselben frequenz, falls das was zu bedeuten hat)

wenn ich den befehl

dhclient eth0

eingebe, erhalte ich eine meldung, das der befehl unbekannt ist (nachtigall, hör ick dir etwas trapsen?? Smile )

der rechner benutzt eine realtek-netzwerkkarte, das laptop eine ca. 3 jahre alte, die in der dockingstation auf einem pci-slot eingebaut ist.

im yast von suse habe ich es auf automatisch stehen, aber das funktioniert eben leider nicht.

tut mir echt leid, das ich hier fragen stelle, die mir in 3 monaten wahrscheinlich wie kinderkram vorkommen *g*, aber so ein fehler hat ja den fehler, das man daraus echt viel lernt. danke nochmal!!!
 

petameta
prolinux-forum-admin


Anmeldungsdatum: 14.02.2003
Beiträge: 1294

BeitragVerfasst am: 25. Feb 2004 21:57   Titel: Re: probleme mit zwei linux rechnern und d-link di-604

So haben hier alle mal angefangen, auch wenn es einige ungerne zugeben ...

Es gibt zwei DHCP clients, einmal den schon erwähnten dhclient, und den dhcpcd (DHCP client daemon). Evtl. wird letzterer bei SuSE 8.2 benutzt, bin mir da nicht sicher. Dieser ist wie der Name sagt ein Daemon, er läuft also im Hintergrund. Man bekommt also nicht viel mit. Der dhclient ist da praktischer, weil man die Fehlermeldungen bzw. Erfolgsmeldungen gleich ausgegeben bekommt.

Daher mein Vorschlag:

Installier das Paket dhclient mit Hilfe von Yast, und probier das ganze nochmal. Evtl. hat sich damit das Problem schon erledigt, und es hat nur der dhclient gefehlt.
 
Benutzer-Profile anzeigen Private Nachricht senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Netzwerk Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy