Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Mausrad Problem

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Hardware
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
julius



Anmeldungsdatum: 10.04.2001
Beiträge: 209
Wohnort: Hannover

BeitragVerfasst am: 13. Mai 2001 15:01   Titel: Mausrad Problem

Hi,

ich habe meine XF86Config (XFree86 4.0.3) so editiert, dass ich unter X das Rad an meiner Maus nutzen kann. Funktioniert ohne Probleme. Nur: Wenn ich jetzt gerade aus X komme und die Maus an der Konsole nutzen möchte, geht sie nicht mehr. Bewege ich sie z. B. nach oben, so geht der Cursor nach rechts oder so. Sprich: Sie ist nicht mehr zu gebrauchen!

Hat jemand eine Idee, wie ich das Problem beheben kann? Das Rad unter X ist mir sehr wichtig, aber genauso wichtig ist mir die funktionierende Maus an der Konsole!

Danke schon mal
Julius
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen

zensox
Gast





BeitragVerfasst am: 15. Mai 2001 6:04   Titel: Re: Mausrad Problem

Wenn ich dich richtig verstehe hast du gpm installiert.
Das ist extra für die Maus in der Konsole gedacht, also eine neue config datei editieren.
/etc/gpm.conf ist es glaub ich, danach gpm neustarten
 

julius



Anmeldungsdatum: 10.04.2001
Beiträge: 209
Wohnort: Hannover

BeitragVerfasst am: 15. Mai 2001 13:13   Titel: Re: Mausrad Problem

okay und was soll ich in der Config Datei editieren? In der XF86Config-4 musste ich das Protokoll auf IMPS/2 setzten (anstatt PS/2), damit das Rad funktioniert. Nur geht dann eben die Maus an der Konsole nciht mehr... Muss ich da nun auch irgendein Protokoll oder so reinschreiben??
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen

Michael
Gast





BeitragVerfasst am: 15. Mai 2001 15:52   Titel: Re: Mausrad Problem

Beendest Du gpm, bevor X startet? Ich habe gehoert, dass X und gpm gleichzeitig zu Problemen fuehren kann.
Aber gpm sollte auch mit imps/2 laufen, versuch es mal damit.
 

julius



Anmeldungsdatum: 10.04.2001
Beiträge: 209
Wohnort: Hannover

BeitragVerfasst am: 15. Mai 2001 17:07   Titel: Re: Mausrad Problem

>Beendest Du gpm, bevor X startet? Ich habe >gehoert, dass X und gpm gleichzeitig zu >Problemen fuehren kann.
>Aber gpm sollte auch mit imps/2 laufen, >versuch es mal damit.

Ja, nur wie muss ich denn imps/2 in die gpm Config Datei eintragen? Hmm, werde gleich mal nach einem gpm HowTo suchen.

Ansonsten: Kann man denn irgendwie ein Skript schreiben, um bei 'startx' gpm zu beenden und nach dem Beenden von X wieder zu starten? Bin leider (noch) nicht so der Skriptcrack.
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen

Michael
Gast





BeitragVerfasst am: 17. Mai 2001 17:01   Titel: Re: Mausrad Problem

Wenn Du fuer Konsole- und X-Sitzungen verschiedene Runlevel faehrst (z.B. 3 und 4), dann gehoeren die Befehle zum Starten und Stoppen von GPM in die entsprechnden Start- u. Stopscripte. Die Details dieser Scripte sind bei den verschiedenen Distros unterschiedlich.

Bei mir sieht das z.B. so aus:

Zum starten
gpm -m /dev/mouse -t imps2

Zum stoppen
killall gpm
 

julius



Anmeldungsdatum: 10.04.2001
Beiträge: 209
Wohnort: Hannover

BeitragVerfasst am: 18. Mai 2001 12:43   Titel: Mausrad Prob. gelöst

Okay, danke Euch allen! Jetzt geht es und es war sogar einfacher als ich dachte. Das Problem war ein Eintrag in der /etc/rc.d/init.d/gpm, den ich ein wenig verändern musste...

bye
Julius
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Hardware Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy