Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
CD-Brenner mountet nach Kernel-Compalierung nicht mehr

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Hardware
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
seba7



Anmeldungsdatum: 23.10.2001
Beiträge: 14

BeitragVerfasst am: 31. Okt 2001 20:52   Titel: CD-Brenner mountet nach Kernel-Compalierung nicht mehr

Hallo,

ich benutze SuSE Linux 7.3

die Vorgeschichte:
SuSE 7.3 erkennt Elsa Microlink 56k USB nicht,
habe mich an Kernel-2.4.13 ran gewagt, mit Erfolg,
Modem erkannt und bin im Internet,

Nachteil und Problem:
der CD-Brenner lässt sich nicht mehr mounten,
mit Yast kein Erfolg,
und Konsole:

mount /dev/hdc /cdrecorder (und die Antwort)
ist kein gültiges blockorientiertes Gerät

hat jemand einen Vorschlag,
wo ich nach dem Fehler suchen könnte,

DANKE FÜR JEDEN TIPP

Gruß,
Sebastian
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

Jochen
Gast





BeitragVerfasst am: 01. Nov 2001 11:00   Titel: Re: CD-Brenner mountet nach Kernel-Compalierung nicht mehr

Bei IDE-CD-Brennern ist typischerweise die IDE-SCSI-Emulation eingeschaltet. Wenn er unter /dev/hdc den Brenner nicht mehr sieht, versuch doch mal /dev/scd0 zu mounten? Ansonsten halt Fehlersuche auf klein-klein-Art: Ist /dev/hdc vielleicht keine blockorientierte Gerätedatei mehr? Hast Du das devfs ohne devfsd aktiviert? Beim Kernelbauen die Unterstützung für IDE-CDROM vergessen?

Jochen
 

seba7



Anmeldungsdatum: 23.10.2001
Beiträge: 14

BeitragVerfasst am: 01. Nov 2001 13:50   Titel: Re: CD-Brenner mountet nach Kernel-Compalierung nicht mehr

Hallo Jochen,

hab zunächst scd0 mountet, dabei kam heraus,
mount: /dev/scd0 is not a valid block device


was ich nicht so recht verstehe, wenn ich...

linux:/ # mount dev/cdrecorder
mount: can't find /dev/sr0 in /etc/fstab or /etc/mtab


was ist der unterschied zwischen scd0 und sr0 ????
Zwei Gerätedateien für einen CD-Brenner???

-----------------------------------------------------------------

Danach kam der Kernel dran,
devfs gefunden aber wo ist devfsd???

y /dev file System support
y Automatically mount at boot
y Debug devfs


Bootversuch misslang, da ich nicht weiß,
wie ich eigentlich das Anpassen der /etc/fstab vornehmen soll.

Im Standart-Kernel von SuSE
ist das devfs nicht aktiviert,
aber ich kann von CD-Brenner aus lesen.
---------------------------------------------------------------

Werde mal den Kapitel,
das Einbinden und Entfernen von Datenträgern lesen,
schein interessantes Thema zu sein.


Danke für die Tipps Jochen,
für weitere Vorschläge wäre ich dankbar,
so lernt man am besten.

Gruß,
Sebastian
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

Jochen
Gast





BeitragVerfasst am: 02. Nov 2001 8:06   Titel: Re: CD-Brenner mountet nach Kernel-Compalierung nicht mehr

Hi!

Schalte das devfs einfach mal aus, daran wird es nämlich liegen. Das devfs übernimmt dann die Verwaltung der Device-Namen, wie Du sie sonst unter /dev liegen hast, aber in anderer Form. Um Kompatibilität zum "normalen" /dev-Verzeichnis herzustellen, benötigst Du den devfsd, ein Daemon, der /dev mit Links auf die passenden Einträge im devfs füllt. Das ist Programm wie andere auch und ist ggf. bei Dir sogar schon installiert, wird aber wohl nicht gestartet.

Und was sr0/scd0 betrifft: Jacke wie Hose. Die Dateinamen sind unter Linux Schall und Rauch. Wenn Du magst, kannst Du auch unter "/dev/egon" auf Deinen CD-Brenner zugreifen... Der Unterschied in der Namensgebung ist lediglich historischer Art.

Jochen
 

Sebastia
Gast





BeitragVerfasst am: 02. Nov 2001 13:36   Titel: Re: CD-Brenner mountet nach Kernel-Compalierung nicht mehr

Hallo Jochen,

habe also devfs auf "N" gestellt,
nebenbei bin ich auf den Artikel von Pro-Linux gestoßen,
"CD-Writer mit EIDE-Schnittstelle unter LINUX installieren"
ist sehr gut Erklärt, na jedenfalls es hat geklappt,
kann endlich meinen CD-Brenner benutzten,
fast aber nur fast,

bei Daten wie die SuSE-CD klappts
oder einer CD mit MP3s geht auch,
aber wenn ich eine Audio-CD einlege,
bekommen ich eine Fehlermeldung,

mount: Falscher Dateisystemtyp, ungültige Option, der
>Superblock< von /dev/scd0 ist beschädigt oder
es sind zu viele Dateisysteme gemountet


hmmm, egal ob Madonna oder Sting, immer die gleiche Meldung,
aber die MP3-CDs lassen sich abspielen.

Jochen, sagt dir die Fehlermeldung was,
bin aber froh soweit gekommen zu sein,
mit zwei Wochen Linux Erfahrung.

Bin kurz vor dem Ziel, brauche noch bisschen Unterstützung,
bin für jeden Ratschlag dankbar

Gruß,
Sebastian
 

Jochen
Gast





BeitragVerfasst am: 02. Nov 2001 14:00   Titel: Re: CD-Brenner mountet nach Kernel-Compalierung nicht mehr

Es sieht so aus, als würde ein automount-Daemon laufen, der frisch eingelegte CDs automatisch mountet. Da Audio-CDs aber nun mal kein Dateisystem haben, geht das schief... Da ich aber zu den CD-händisch-Montierern gehöre, weiss ich nicht, ob man dem beibringen kann, Daten-CDs zu mounten und Audio-CDs in Ruhe zu lassen.

Jochen
 

Sebastian
Gast





BeitragVerfasst am: 03. Nov 2001 13:26   Titel: Re: CD-Brenner mountet nach Kernel-Compalierung nicht mehr

Hallo Jochen,

habe KreateCD ausprobiert, das anscheinend Audio-CDs liest,
es kommt noch besser, habe ein Track auf eine
Wiederbeschreibbare CD gebrannt, das Ergebnis hat mich
überrascht, die CD-RW kann ich von meinem CD-Player aus spielen,
hat bei Windows nie funktioniert.

Ist das Zufall, oder ist es normal bei Linux,
das CD-RWs so gebrannt werden, das man es auch
in einer Anlage abspielen kann ???

Jochen verzeih meine Unwissenheit,
aber was sind CD-händisch-Montierern ???

Gruß,
Sebastian
 

Jochen
Gast





BeitragVerfasst am: 04. Nov 2001 10:36   Titel: Re: CD-Brenner mountet nach Kernel-Compalierung nicht mehr

CD händisch montieren? Damit meine ich nix geheimnisvolleres als "mount /mnt/cdrom" oder "mount -t iso9660 /dev/scd0 /cdrom" oder so... Also den Datenträger mit einem selbst abgesetzten mount-Kommando ins System einhängen. Und somit brauche ich keinen Automounter (der bin ich selber ) und kenne Dein Problem halt nicht genau. Und genau ausdrücken kann ich mich auch nicht immer... Sorry.

Was das Rippen, Brennen auf CD-RW und Abspielen auf dem CD-Spieler betrifft: Keine Ahnung. Nach meiner Erfahrung spielen da so viele Faktoren eine Rolle (Brennprogramm, Rohling-Sorte, Brenner, Spieler, ...), dass ich mich nicht zu einer Aussage hinreissen lasse.

Deine Unwissenheit verzeihen? Na gut, dieses eine Mal noch.

Jochen
 

mamuepa



Anmeldungsdatum: 04.04.2001
Beiträge: 112
Wohnort: Hildesheim

BeitragVerfasst am: 10. Nov 2001 15:47   Titel: Re: CD-Brenner mountet nach Kernel-Compalierung nicht mehr

Hallo Sebastian!
Ich benutze das gleiche Modem wie Du. Es wurde auch von Suse 7.3 prof. erfolgreich als ttyACM0 erkannt, ich kann alle Providerdaten eingeben, nur einwählen kann ich mich mit kinternet nicht. Kppp erkennt kein ACM-Modem. Meine Frage ist nun, was Du bei der Kernelkompilierung verändert hast, daß das Modem funktioniert. Unter Suse 7.1 Pers. funktionierte das ganze einwandfrei.
Vielen Dank für Deine Mühe und für alle Tipps aller anderen, die eine Idee zu diesem Problem haben.
MfG Martin
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

Sebastian
Gast





BeitragVerfasst am: 11. Nov 2001 12:36   Titel: Re: CD-Brenner mountet nach Kernel-Compalierung nicht mehr

Hallo Martin,

also mit dem Standart Kernel von SuSE 7.3
funktionierte das Modem nicht,
erst nach der Kompilierung des Kernel-2.4.13,
wo bei ich USB-support als Module wählte:
m Support for USB

y Preliminary USB device filesystem
y Enforce USB bandwidth allocation (Experimental)
m UHCI (Intel PllX4, VIA,...) support
m USB Modem (CDC ACM) support

mit yast1 hab ich die Modem Erkennung vorgenommen, OK.
Ich benutze nicht kinternet, sondern KPPP
und das Modem funktioniert, beim ersten Einwählen dauerte es
ca. 30 sek. bis das Modem irgendwelche Töne von sich gab,
aber jetzt wählt es auf anhib.

Gelegentlich bekommen ich eine Fehlermeldung,
wenn ich mich ein zweites mal einwähle, dann klappts aber,
ich versuche das kleine Problem noch zu lösen
Der pppd-Dämon wurde unerwartet beendet!

Rückgabewert 16

wünsche dir viel Erfolg

Gruß,
Sebastian
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Hardware Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy