Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Brenner - read only???

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Hardware
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Chicki
Gast





BeitragVerfasst am: 12. Dez 2001 16:58   Titel: Brenner - read only???

Hi @all!
Ich meinen Brenner(Ricoh MP7040A, Suse 7.2 und 2.4.16 Kernel) ganz nach Anleitung(bei Tips-Programme) eingerichtet. Ich kann von CDs lesen aber wenn ich cdrecord 1.10 starte, sagt er
[...]
Read only filesystem. Cannot open "dev/scd0". Cannot open SCSI-driver.
[...]
Was muss ich tun, damit das nicht mehr read-only ist?
Vielen Dank für Eure Hilfe!!
 

Jensemann
Gast





BeitragVerfasst am: 12. Dez 2001 21:35   Titel: Re: Brenner - read only???

Das kommt mir allerdings ein wenig Spanisch vor, mit welchem Parameter hast du cdrecord gestartet, normaler weise greift cdrecord nicht auf /dev/scd* zu sondern auf /dev/sg*, gib mal (als root) cdrecord -scanbus ein, dann listet es die Nummer des scsi anschluss (id,lun oder so was) auf, z.B. 0,0,1 das gibts du dann mit dem -dev Parameter an cdrecord. Kleine Frage nebenbei, warum benutzt du nicht einfach ein Frontend zu cdrecord wie xcdroast, ich schätze mal, das du noch Linuxanfänger bist (wenn nicht, bitte nicht sauer sein), und da wäre es ganz sinnvoll erst mal mit einem Frontend zu testen ob überhaupt alles funzt. Cdrecord greift über /dev/sg* auf den Brenner zu, weil mit dem normalen cd Treiber nicht gebrannt werden kann, /dev/sg* erlaubt es einem Programm eigene Treiber einzubringen, also praktisch einen eigenen Scsi Treiber für das Laufwerk. Hoffe war jetzt alles klar, wenn nicht einfach fragen.

Mfg Jensemann
 

Chicki
Gast





BeitragVerfasst am: 12. Dez 2001 21:59   Titel: Re: Brenner - read only???

Ok, da hattest du recht, hab ich zwar schon mal gehört dass das sg0 heißen soll, hab mich aber beim ausprobieren verschrieben und sd0 geschrieben und als das nicht ging dachte ich das scd0 stimmt. Jetzt kommt aber immer irgendwie device busy oder so...

hier die Ausgabe von X-CD-Roast:

Calling: /usr/lib/xcdroast-0.98/bin/xcdrwrap CDRECORD dev= "0,0,0" fs=4096k -v -useinfo speed=4 -dao -eject -pad -data "/tmp/track-01.img" ...

scsidev: '0,0,0'
scsibus: 0 target: 0 lun: 0
Linux sg driver version: 3.1.20
pregap1: -1
Cdrecord 1.10 (i686-pc-linux-gnu) Copyright (C) 1995-2001 Jörg Schilling
TOC Type: 1 = CD-ROM
Using libscg version 'schily-0.5'
atapi: 1
Device type : Removable CD-ROM
Version : 0
Response Format: 1
Vendor_info : 'RICOH '
Identifikation : 'CD-R/RW MP7040A '
Revision : '1.1j'
Device seems to be: Generic mmc CD-RW.
Using generic SCSI-3/mmc CD-R driver (mmc_cdr).
Driver flags : SWABAUDIO
Drive buf size : 1359872 = 1328 KB
FIFO size : 4194304 = 4096 KB
Track 01: data 43 MB padsize: 30 KB
Total size: 49 MB (04:56.52) = 22239 sectors
Lout start: 50 MB (04:58/39) = 22239 sectors
Current Secsize: 2048
ATIP info from disk:
Indicated writing power: 5
Is not unrestricted
Is not erasable
Disk sub type: Medium Type B, low Beta category (B-) (4)
ATIP start of lead in: 232466 (151:40/116)
ATIP start of lead out: 551141 (121:89/116)
Disk type: unknown
Manuf. index: -1
Manufacturer: unknown (not in table)
Blocks total: 359849 Blocks current: 359849 Blocks remaining: 337610
Starting to write CD/DVD at speed 4 in write mode for single session.
0 seconds. Operation starts.
Waiting for reader process to fill input buffer ...
input buffer ready.
Performing OPC...
cdrecord: Input/output error. send opc: scsi sendcmd: no error
CDB: 54 01 00 00 00 00 00 00 00 00
status: 0x2 (CHECK CONDITION)
Sense Bytes: 70 00 03 00 00 00 00 0C 00 00 00 00 64 C0 00 00
Sense Key: 0x3 Medium Error, Segment 0
Sense Code: 0x64 Qual 0xC0 (illegal mode for this track) [No matching qualifier] Fru 0x0
Sense flags: Blk 0 (not valid)
cmd finished after 3.387s timeout 200s
cdrecord: Resource temporarily unavailable. OPC failed.
 

Jensemann
Gast





BeitragVerfasst am: 12. Dez 2001 22:18   Titel: Re: Brenner - read only???

Hatte ich auch mal, hab darauf ne Mailan an den Autor geschrieben, der meinte, ich solle die Linse des Brenners reinigen (man nehme eine Reinigungscd, die Rohlingmarke wechseln oder den Brenner wegwerfen, bei mir half ersteres.

Mfg Jensemann
 

Linuxglider
Gast





BeitragVerfasst am: 12. Dez 2001 23:51   Titel: Re: Brenner - read only???

hatte bis vor kurzem den gleichen Brenner,
mit exakt der gleichen meldung.

meiner war kaputt also der tip mit der linse
könnte vielleicht was bringen.

hast du die möglichkeit das teil unter windows
zu testen? Wenn er dort auch nicht will
rip.
 

peterw2k
Gast





BeitragVerfasst am: 13. Dez 2001 13:30   Titel: Re: Brenner - read only???

Hi,

vielleicht liegt's einfach nur am Rohling? Was für ne Marke benutzt du denn? Mein Ricoh-Brenner (MP7080A) kommt z.B. nicht mit den Billig-CDRs vom Promarkt ("Platinum") zurecht (da krieg ich auch so ne ähnliche, kryptische Fehlermeldung), dafür klappen die aus'm Aldi prima

Gruß,
Peter
 

Chicki
Gast





BeitragVerfasst am: 13. Dez 2001 14:56   Titel: Re: Brenner - read only???

Ich verwende BASF Rohlinge, bei manchen gehts, bei manchen nicht, also liegts warscheinlich zum Teil daran. Außerdem werd ich mir jetzt mal sone Reinigungscd zulegen. Vielen Dank für eure Tips, ihr habt mir echt geholfen!
Bis zum nächsten Problem,
Chickenman
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Hardware Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy