Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
GeForce2 und TV-Out?

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Hardware
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
ytimk



Anmeldungsdatum: 07.09.2001
Beiträge: 341

BeitragVerfasst am: 01. Jan 2002 16:45   Titel: GeForce2 und TV-Out?

Hi zusammen,
und frohes neues Jahr!
Ich hab' eine GeForce2 MX 200 und wollte die an den Fernseher hängen. Das bereitet leider einige Probleme:
1. Beim Booten wird alles in Schwarz-Weiß und grob gepixelt abgebildet (auch lilo - graphisch)
2. Später, wenn Mandrake läuft, sieht man gar nix mehr - nur noch flimmern.
Ich habe schon die XF86Config gemäß dem Mini-Howto von linuxhardware.org verändert - ob richtig, bin ich mir nicht wirklich sicher, da die Einstellungen in Deutschland sicher anders sind als USA, aber das habe ich imho beachtet...
Wäre nett, wenn mir jemand helfen könnte.
 
Benutzer-Profile anzeigen Private Nachricht senden

jensemann
Gast





BeitragVerfasst am: 01. Jan 2002 21:03   Titel: Re: GeForce2 und TV-Out?

Ich kenn mich da jetzt nicht so hundert prozentig aus, weil ich selbst noch keine Karte mit TV Out habe, aber das hört sich so an, als ob das Signal als NTSC am Fernseher ankommt, hast du in der XF86Config das ganze auch als PAL konfiguriert? Benutzt du die Nvidia Treiber?
 

ytimk



Anmeldungsdatum: 07.09.2001
Beiträge: 341

BeitragVerfasst am: 01. Jan 2002 23:46   Titel: Re: GeForce2 und TV-Out?

in der XF86Config habe ich es schon mit PAL, PAL-B und PAL-G probiert.
Bei den Treibern von Nvidia bin ich mir nicht sicher, da gibts für Mandrake8.1 dre verschiedene Kernel-Treiber: SMP, UP und Enterprise... ich glaube, den smp habe ich installiert. (Vielleicht falsch??)
Kann es vielleicht an dieser ModeLines-Geschichte liegen? Ich hab' überhaupt keinen blassen, was die Zahlen bedeuten, hab's einfach nur abgetippt...
 
Benutzer-Profile anzeigen Private Nachricht senden

jensemann
Gast





BeitragVerfasst am: 02. Jan 2002 3:06   Titel: Re: GeForce2 und TV-Out?

SMP hört sich so an, als ob der Multi Prozessor Rechner ist, hast du so einen? Ich würde dir empfehlen, einfach mal das tar.gz Archiv von nvidia zu saugen und den Treiber selbst zu "kompilieren", vieleicht gehts dann. Da gibts nämlich nur ein Archiv für den Kernel, die anderen beiden Arten des Kernel Treiber teils sagen mir nämlich überhaupt nichts. Hast du die aktuelle Version der Treiber installiert, vielleicht ist in den alten irgendein Bug.
Mfg jensemann
 

panther
Gast





BeitragVerfasst am: 02. Jan 2002 4:32   Titel: Re: GeForce2 und TV-Out?

guten morgen miteinander! :)

zu nvidia-treiber-paketen:
mandrake legt bei ihrer distribution mehrere, vorkompilierte kernel bei. diese unterscheiden sich
nach einkompilierten feautures. der smp-kernel beinhaltet zusaetzlichen mehrprozessor-support, der enterprise-
kernel unter anderem unterstuetzung fuer bis zu 64gbram... (enterprise ->high-end server)
die pakete von nvidia sind fuer ensprechende kernels deiner distribution bereits vorgewrappt.
wenn du den default kernel von deiner distribution verwendest, kannst du die rpms verwenden.
die tarballs brauchst du nur, wenn du die nvidia-treiber selber gegen den kernel wrappen willst,
oder wenn du kein vorgewrapptes packet von nvidia fuer deinen kernel kriegst (u.a. bei selbstkompilierter kernel).

um den treiber zu aktivieren darfst du nicht vergessen, in deiner xfreeconfig den eintrag 'Driver "nv"' in der
driver section auf 'Driver "nvidia" zu setzen. kontrolle: beim starten von x kommt ein nvidia logo ;)


tv-out:
die in europa erhaeltlichen grafikkarten liefern auf den tv-out ein pal signal. damit deine grafikkarte automatisch erkennen kann,
dass du den tv angeschlossen hast, solltest du den monitor kurz trennen und erst ein paar sekunden nach dem systemstart
wieder anschliessen. dass du nur monochrom siehst, liegt an deinem tv eingang. vergewissere dich, dass dein tv das signal akzeptiert
(kleine abschweife: bei unserem alten (>15j) tv war es nicht moeglich. seit wir einen neuen haben, ist das kein problem mehr,
jedoch musste ich schauen, dass ich den "richtigen" eingang erwische, da av1 (komischerweise) bei uns nur fuer monochrom ausgelegt ist,
so dass ich fuer meine zwecke av2 nehmen muss).
der textmodus birgt sonst keine weiteren schwierigkeiten, bedenke aber, dass das bild naturgemaes etwas unscharf ist, da der tv eine
wesentlich geringere schaerfe gegenueber computer-monitoren aufweist (ein ganz leicht gestreiftes, nicht durchgehendes schriftbild ist
normal)

der grafische modus ist etwas komplizierter, da musst du die frequenzen deines tv sowohl horizontal als auch vertikal erwischen.
das ist auch nicht ungefaehrlich, da man bei zu hohen werten den tv ueberlasten kann, eine hand in reichweite des ausschalters
lohnt allemal. die frequenzen aber durch ausprobieren zu finden ist relativ langeweilig, schau deshalb im handbuch deines tv nach.
die uebeliche aufloesung uebrigens ist 800*600 mit 16-bit farben, darueber macht imho nicht mehr jedes geraet mit.

bei mir funktionerts soweit praechtig,
sag wenn du noch ein bisschen mehr hilfe brauchst

ich leg mich jetzt schlafen,
viel spass und gutes gelingen,
panther
 

panther
Gast





BeitragVerfasst am: 02. Jan 2002 4:35   Titel: Re: GeForce2 und TV-Out?

uups, noch was vergessen:
hast du qualitativ gute kabel? nimmst du es ueber einen euro-scart oder s-video in?
ist das kabel nicht allzulang? moeglichst keine "umstecker" verwenden und
eventuelle stoersender koennten auch noch das resultat verschlechtern...

so, jetzt entgueltig im land der traeume,
panther
 

ytimk



Anmeldungsdatum: 07.09.2001
Beiträge: 341

BeitragVerfasst am: 02. Jan 2002 14:15   Titel: Re: GeForce2 und TV-Out?

So, der NVidia-Treiber is nu installiert.
Ich hab mal 'nen Saublöden Fehler gemacht und zwei Tage lang die XF86Config editiert, bis ich herausgefunden habe, dass ich die XF86Config-4 verändern muss...
Das Kabel ist nicht so Qualitativ hochwertig, ich kauf dann ein neues, wenn's funzt.
Computer und TV sind über Cinch miteinander verbunden.
Naja, wie dem auch sei, das Problem ist jetzt ein anderes: Der X-Server scheint nicht mehr gestartet zu werden. Der Rechner versucht dauernd, vom Text-Login umzuspringen und ausser Strg+Alt+Entf hat man keine Chance, einzugreifen.
Ich hab mal die XF86Config-4 herauskopiert und die Kommentare von Harddrake gelöscht, der Übsicht wegen. Vielleicht findet ihr ja 'nen Fehler:
code:


Section "Files"

RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:-1"

EndSection


Section "ServerFlags"

AllowMouseOpenFail

EndSection


Section "InputDevice"

Identifier "Keyboard1"
Driver "Keyboard"
Option "AutoRepeat" "250 30"

Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "de(nodeadkeys)"

EndSection


Section "InputDevice"

Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "Microsoft"
Option "Device" "/dev/mouse"
Option "Emulate3Buttons"
Option "Emulate3Timeout" "50"


EndSection



Section "Module"

Load "dbe"
Load "glx"


SubSection "extmod"
#Option "omit xfree86-dga"
EndSubSection

Load "type1"
Load "freetype"
EndSection


Section "Monitor"
Identifier "monitor0"
VendorName "Universum"
ModelName "Fernseher"
HorizSync 30.0 - 50.0
VertRefresh 50
EndSection


Section "Device"
Identifier "NVIDIA GeForce2 DDR (generic)"
VendorName "NVidia"
BoardName "GeForce 2MX 200"
Driver "nvidia"
Option "ConnectedMonitor" "TV"
Option "TVStandard" "PAL-G"

EndSection


Section "Screen"
Identifier "screen1"
Device "NVIDIA GeForce2 DDR (generic)"
Monitor "monitor0"
DefaultColorDepth 16
Subsection "Display"
Depth 1
Modes "800x600"
ViewPort 0 0
EndSubsection
Subsection "Display"
Depth 4
Modes "800x600"
ViewPort 0 0
EndSubsection
Subsection "Display"
Depth 8
Modes "800x600"
ViewPort 0 0
EndSubsection
Subsection "Display"
Depth 16
Modes "800x600"
ViewPort 0 0
EndSubsection
EndSection


Section "ServerLayout"
Identifier "layout1"
Screen "screen1"

InputDevice "Mouse1" "CorePointer"

InputDevice "Keyboard1" "CoreKeyboard"
EndSection


Anmerkung: Der Rechner soll nur noch über TV laufen.


Zuletzt bearbeitet von ytimk am 02. Jan 2002 14:15, insgesamt 1-mal bearbeitet
 
Benutzer-Profile anzeigen Private Nachricht senden

ytimk



Anmeldungsdatum: 07.09.2001
Beiträge: 341

BeitragVerfasst am: 02. Jan 2002 18:31   Titel: Re: GeForce2 und TV-Out?

Ich bin's nochmal,
wollte nur eben bescheid geben, dass es jetzt funktioniert - auch in Farbe!
Hab die XF86Config-4 so umgeschrieben, dass der Rechner auf TwinView startet und der Fernseher nur ein opt. 2. Monitor ist.
Danke euch beiden!!
 
Benutzer-Profile anzeigen Private Nachricht senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Hardware Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy