Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Netzwerkkarte

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Hardware
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
mootsch
Gast





BeitragVerfasst am: 02. Apr 2002 9:50   Titel: Netzwerkkarte

Hallo.

Ich habe mich entschlossen auf Linux umzusteigen. Ich hatte vorher ausschliesslich mit Windows zu tun (2000,98,XP).
Nun habe ich mir meine alte SUSE linux 6.4 Distribution installiert und es läuft alles.

Ich habe vor mit meinem Rechner (Linux) über einen anderen Rechner (Win2000) per Proxy ins Internet zu gehen.
Jetzt habe ich bloss ein Problem und tausend fragen ( Sad ) :

- In meinem Rechner ist eine D-Link DFE-530TX eingebaut. Da Mein SUse 6.4 noch den Kernel 2.2.16 hat, hab ich mir den neuen Kernel 2.4.18 (glaube ich) aus dem Netzt gezogen. Auf der D-Link Page besorgte ich mir die Treiber für die Netzwerkkarte. Nun zu meinem ersten Problem : Wie installiere ich denn einen Treiber unter Linux? Da ich keinen schimmer davon habe, habe ich folgendes getan...
Ich hab den neuen Kernel in /usr/src/ entpackt (vorher mein altes Linux verzeichnis gelöscht). Dann habe ich unter /usr/src/Linux/drivers/net/ meine D-Link Treiber entpackt (warum? weis ich nicht, ich hatte gehofft irgendwie den Treiber in den Kernel einzubinden oder sowas Smile ).

Wenn ich jetzt unter /usr/src/Linux per make xconfig meinen Kernel Konfigurieren möchte habe ich unter den Optionen Netzwerk->Ethernet 10/100 MBit die möglichkeit einen Treiber für meine D-Link zu installieren (Den Treiber den ich auswählen kann, heisst "VIA Rhino Support").

Nachdem ich das alles getan habe, hab ich mit make dep clean bzImage meinen Kernel kompiliert. Dannach nochmal make modules.

Da ich ja Suse habe, übernimmt es mir laut dem Handbuch mit dem Befehl make bzlilo die Lilo Konfiguration. dannach noch einmal make modules_install (da ich nicht wusste ob ichs brauche, hab ich es einfach getan). noch kurz make clean und den rechner neugestartet... siehe da es geht! Der Kernel läuft sogar ohne Probleme.

Nun wollte ich meine Netzwerkkarte "brauchbar machen". Yast gestartet und bei den Netzwerk Einstellungen konfiguriert. auf eth0 hab ich also den treiber "gelegt" den ich brauche (Via RHINO Support). Dannn noch eine IP-Adresse vergeben, das Netzwerk auch Aktiviert mit F4 und neugestartet (Linux neu-gebootet).

Ab hier hört meine Fantasie auf Sad ... eth0 liefert beim booten nur Fehler zurück... kein Device o.ä.
Was habe ich falsch gemacht?
Ist es überhaupt möglich was ich vorhabe? Ich meine Über meinen Rechner per Proxy (win2000) ins Internet zu gehen?

Wenn mir jemand Helfen mag, wäre das nicht schlecht... mit dem "Gefährlichen-Halb-bis-garnichts-wissen" komme ich glaube ich nicht weit.

Danke im Voraus.
MFG,
Mootsch
 

mootsch
Gast





BeitragVerfasst am: 03. Apr 2002 15:46   Titel: Re: Netzwerkkarte

Nein.
Ich habs geschafft... weis zwar nicht wie... aber es läuft.
 

gewitter



Anmeldungsdatum: 09.04.2001
Beiträge: 1354

BeitragVerfasst am: 03. Apr 2002 23:12   Titel: Re: Netzwerkkarte

Wäre alles halb so schlimm, wenn du mit dem w2k über den linux-rechner ins internet gehen würdest
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Hardware Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy