Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
sam9407
Gehen Sie zu Seite 1, 2  Weiter
 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Hardware
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
mischa
Gast





BeitragVerfasst am: 02. Mai 2002 19:54   Titel: sam9407

Hallo ich hab die beiden sam packete von suse linux 8 installiert , um meine Isis Soundkarte zum laufen zu bringen...wenn ich auf der console sam9407 eingebe , kommt nur die Fehlermeldung incompatible API versions, please recompile, heisst das, dass ich einen neueren sam "Treiber" aus dem Internet ziehen muss....eigentlich muesste derTreiber von der linux 8 CD doch relativ aktuell sein.
gruss mischa
 

arjo1
Gast





BeitragVerfasst am: 04. Mai 2002 12:11   Titel: Re: sam9407

Hast du in der rc.config "start_sam9407 yes" eingegeben? (ich hab allerdings SuSE7.3, da gings
unter yast1 einfach).Ist das eine isa-Karte? Dann müsstest du noch den ganzen isapnp-Kram durch-
gehen.
 

mischa
Gast





BeitragVerfasst am: 04. Mai 2002 17:20   Titel: Re: sam9407

hallo,
isa Karte? Was war denn das noch mal? Also welche Karte hast du gehabt? Meine Isis Karte hat das Problem ,dass sie zwei Chips hat . Einen Maestro und einen Dream. Unter Windows kann man zwischen den beiden Chips hin und her Schalten. Bei Linux geht das leider nicht...Jetzt erkennt Linux nur den Maestro Chip und die Unterstuetzung fuer den Dream jedoch nicht.
Fuer was ist unter Linux eigentlich das km_sam940 ??? Ich hab das installiert , aber irgendwie kann Linux dieses Modul nicht finden...Ich glaube daran liegt das Problem...Also auch unter rc.config "start_km_sam9407 yes" eintragen???
gruss
mischa
 

arjo1
Gast





BeitragVerfasst am: 06. Mai 2002 7:36   Titel: Re: sam9407

Ich hab ne Terratec EWS64XL mit dream-chip und sam9407 ist der Treiber nur für diesen.
Im www mit google müsstest du mit diesen Stichworten einiges finden.
Hier ein kurzer Überblick: modprobe sam9407 samMajor=94 (eventuell auch 14)
du brauchst eine /etc/sam9407.conf (man sam9407.conf) darin muss der Pfad zu firmware
und soundsets angegeben sein. sam9407 -v ergibt dann einige Meldungen.
Wenn du überhaupt nicht mehr weiterkommst, dann poste mal die Ausgaben obiger Befehle.
 

arjo1
Gast





BeitragVerfasst am: 06. Mai 2002 7:40   Titel: Re: sam9407

noch was vergessen, du solltest alle anderen Soundtreiber est mal rausnehmen (kein alsa usw.)
am besten mit yast die Soundkarten löschen, der dream-chip klingt eh am besten;)
 

mischa
Gast





BeitragVerfasst am: 06. Mai 2002 15:15   Titel: Re: sam9407

Hallo,
also du hast geschrieben , dass der sam nur fuer die EWS terratec Karte (oder so aehnlich) ist, kann ichs dann mit meiner MaxiStudio Isis Karte von Guillemot vergessen?
greetz mischa
 

arjo1
Gast





BeitragVerfasst am: 06. Mai 2002 16:31   Titel: Re: sam9407

Sorry, falsch ausgedrückt:) mit "nur" meinte ich den dream-chipsatz.
Deine Karte müsste schon laufen mit dem sam9407-treiber, ich hab allerdings kein SuSE8.0.
 

arjo1
Gast





BeitragVerfasst am: 06. Mai 2002 16:35   Titel: Re: sam9407

geh mal auf www.anime.net/~sam9407, da müsste deine Karte dabei sein.
 

mischa
Gast





BeitragVerfasst am: 06. Mai 2002 21:55   Titel: Re: sam9407

also ich hab jetzt bald alles ausprobiert und es klappt nicht....vielleicht ist es bei der isis ein Problem, dass sich zwei chips auf einer Karte befinden , naemlich der Maestro und der Dream Chip und den Maestro erkennt er , jedoch nicht den Dream , aber er braucht wahrscheinlich beide um Sounds abspielen zu koennen....Grosse Verwirrung...
Ich probier jetzt mal dein letztes Posting....
gruss mischa
 

mischa
Gast





BeitragVerfasst am: 06. Mai 2002 22:37   Titel: Re: sam9407

Hallo ich hab jetzt mal die Befehle ausgefuehrt , hier die Ausgabe:
(uebrigens laeuft bei Start schon ein sam9407d modul)
linux:~ # insmod sam9407
Using /lib/modules/2.4.18-4GB/misc/sam9407.o
linux:~ # sam9407 samMajor-94
sam9407[#0]: incompatible API versions, please recompile(heisst das ich brauch eine neuere version?)
linux:~ # sam9407 -v
sam9407[#0]: incompatible API versions, please recompile
sam9407: 0 cards handled
linux:~ #
linux:~ # rcalsasound stop
Shutting down sound driver done
linux:~ # sam9407 -v
sam9407: 0 cards handled
linux:~ # sam9407 samMajor-94
linux:~ #
--------------------------------
nach eingabe von lspci -v kommt

00:0e.0 Multimedia audio controller: ESS Technology ES1978 Maestro 2E (rev 10)
Subsystem: Guillemot Corporation: Unknown device 0010
Flags: bus master, medium devsel, latency 64, IRQ 10
I/O ports at f400 [size=256]
Capabilities: [c0] Power Management version 2
----------------------------------
Was ist eigentlich das km_sam9407 ... Ich hab das mal installiert , aber das System kann kein modul mit dem Namen finden....
vielen Dank im Voraus
gruss mischa
 

gewitter



Anmeldungsdatum: 09.04.2001
Beiträge: 1354

BeitragVerfasst am: 06. Mai 2002 22:48   Titel: Re: sam9407

probier doch mal "modprobe maestro", wenn der andere kram aus dem speicher raus ist.
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

arjo1
Gast





BeitragVerfasst am: 06. Mai 2002 23:21   Titel: Re: sam9407

Also so wie ich das sehe, geht immer nur einer der beiden Chips.
<linux:~ # insmod sam9407
Using /lib/modules/2.4.18-4GB/misc/sam9407.o>
hier wird der Treiber geladen.
< sam9407 -v > hier versucht der treiber auf die "/etc/sam9407.conf"
zuzugreifen (diese Datei musst du anlegen mit Pfad zu firmware
und soundsets - die firmware gibts auf o.a. Addresse, die Soundsets
kannst du von Windows rüberkopieren, bei mir schaun die so aus:
gssbk320.94b usw.)Hier ist meine /etc/sam9407.conf du musst aber deinen Pfad angeben.

card 0
firmware /home/ews64_os.bin
soundbank /home/soundsets/gmbk9708.94b
Wenn dir das alles nix sagt, dann ist`s vielleicht einfacher
nur den Maestro zu verwenden.
 

arjo1
Gast





BeitragVerfasst am: 06. Mai 2002 23:23   Titel: Re: sam9407

Und nochmal zur Erinnerung:)alsa hat bei sam9407 absolut nichts zu
suchen. Wenn alsa läuft, geht sam9407 nicht!!
 

mischa
Gast





BeitragVerfasst am: 07. Mai 2002 9:33   Titel: Re: sam9407

hallo,
danke mal fuer die Hilfe...
ich hab wie du gesagt hast den alsa deinstalliert und hier ist die Ausgabe der Console:
linux:~ # modprobe maestro
/lib/modules/2.4.18-4GB/kernel/drivers/sound/maestro.o: init_module: No such device
Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters
/lib/modules/2.4.18-4GB/kernel/drivers/sound/maestro.o: insmod /lib/modules/2.4.18-4GB/kernel/drivers/sound/maestro.o failed
/lib/modules/2.4.18-4GB/kernel/drivers/sound/maestro.o: insmod maestro failed
linux:~ # modprobe sam9407
linux:~ # sam9407 -v
sam9407[#0]: incompatible API versions, please recompile
sam9407: 0 cards handled
linux:~ # insmod sam9407
Using /lib/modules/2.4.18-4GB/misc/sam9407.o
insmod: a module named sam9407 already exists
linux:~ # modprobe sam9407
linux:~ # modprobe maestro
/lib/modules/2.4.18-4GB/kernel/drivers/sound/maestro.o: init_module: No such device
Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters
/lib/modules/2.4.18-4GB/kernel/drivers/sound/maestro.o: insmod /lib/modules/2.4.18-4GB/kernel/drivers/sound/maestro.o failed
/lib/modules/2.4.18-4GB/kernel/drivers/sound/maestro.o: insmod maestro failed
---------------------------------
meine sam9407.config sieht wie folgt aus:
card 0
firmware /usr/share/sam9407/isis.bin
soundbank /usr/share/sam9407/bank4m.94b

-----> aber es laeuft halt noch nicht ...Sad
vielleicht weisst du ja noch was..
gruss mischa
 

arjo1
Gast





BeitragVerfasst am: 07. Mai 2002 10:08   Titel: Re: sam9407

Ich geh mal davon aus, daß das sam9407Modul geladenist.
Probier jetzt mal in dieser Reihenfolge:
rmmod sam9407 <enter>
modprobe -v sam9407 (oder "modprobe sam9407 samMajor=94") <enter>
sam9407 -v <enter>
und poste die Bildschirmausgabe.
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Hardware Alle Zeiten sind GMT + 1 Stunde
Gehen Sie zu Seite 1, 2  Weiter
Seite 1 von 2

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy