Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Hilfe::::USB-Camera via Mass-Storage-Driver:::::

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Hardware
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
celindir
Gast





BeitragVerfasst am: 19. Aug 2002 8:15   Titel: Hilfe::::USB-Camera via Mass-Storage-Driver:::::

Hallo zusammen,

Neue Hardware, neue Herausforderungen !!
Ich habe seit ein paar Tagen eine Sony Digitalcamera (DSC-P50), die ich gerne unter Linux ansprechen möchte.
Nach einigem nachlesen bin ich so schlau, dass sie wohl als Mass-Storage-device erkannt werden kann.

Zuerst tat sich beim Einstöpseln aber fast gar nix. Nur bei den Kernelmeldungen stand so etwas ähnliches wie
USB new device connect on bus1/2, assigned device number 2
USB device 2 (vend/prod (weiss ich nicht mehr)) is not claimed by any active driver.

nach dem Laden des usb mass-storage treibers mit modprobe sah es bei den Kernelmedungen leider nicht andes aus. Allerdings konnte ich im KDE-Kontrollzentrum unter USB nun sehen, dass das Device am USB nun korrekt mit Hersteller und Typenbezeichnung erkannt wurde. Ich dachte, jetzt bräuchte ich es nur noch als Laufwerk zu mounten. Aber wie??

Ich habe keine Ahnung, wie ich rausbekomme, welches Device ich nun mounten muss.
cdrecord -scanbus liefert kein neues SCSI-Device

Bei anderen habe ich gesehen, dass die Kernelmeldungen soetwas ausspucken :
Initializing USB Mass Storage driver...
usb.c: registered new driver usb-storage
scsi0 : SCSI emulation for USB Mass Storage devices
Vendor: Sony Model: Sony DSC Rev: 2.10
Type: Direct-Access ANSI SCSI revision: 02
Attached scsi removable disk sda at scsi0, channel 0, id 0, lun 0
SCSI device sda: 126848 512-byte hdwr sectors (65 MB)
sda: test WP failed, assume Write Enabled
sda: sda1
WARNING: USB Mass Storage data integrity not assured

Das war bei mir leider nicht der Fall.

Was mache ich falsch??

Ich arbeite unter SuSE 7.3 mit Kernel 2.4.10
Die erforderliche SCSI-Emulation müsste auch vorhanden sein. Zumindest läuft mein IDE-Brenner unter SCSI-Emulation. (Oder ist das eine andere, die ich für USB brauche ??)
Ich habe auch noch einen echten SCSI-Controller in meinem System, so dass mir cdrecord -scanbus insgesamt 2 Controller auflistet (den echten scsi0 und die IDE-Emulation scsi1)
Kann es sein, dass mit der SCSI-Emulation nicht noch ein Controller für usb emuliert werden kann??
Muss ich vielleicht die IDE-Emulation deaktivieren, bevor ich USB-SCSI-Emulation nutzen kann??

Fragen über Fragen


Wer hat einen Tipp für mich?

Sachdienliche Hinweise posten Sie bitte in diesem Forum oder mailen sie direkt an mail@celindir.de

Vielen Dank

Euer Celindir
_____________________________________
"May the source be with you..."
 

vost



Anmeldungsdatum: 16.08.2002
Beiträge: 48
Wohnort: Reutte in Tirol

BeitragVerfasst am: 19. Aug 2002 11:17   Titel: Re: Hilfe::::USB-Camera via Mass-Storage-Driver:::::

Hallo celindir

... nichts einfacher als das

1. USB einstopseln
2. Auf "beep" oder kernelausgabe warten
3. #> mount -t vfat /dev/sda1 /mountpoint

sollte das Device schon vergeben worden sein, dann ist es halt das nächste -- nein nicht hda2, sondern hdb1. Das Filesystem ist defaultmäßig vfat (kannst auch umformatieren, aber dann speichert deine Kamara keine Fotos mehr in die Flashcard)

mfG vost
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

vost



Anmeldungsdatum: 16.08.2002
Beiträge: 48
Wohnort: Reutte in Tirol

BeitragVerfasst am: 19. Aug 2002 11:32   Titel: Re: Hilfe::::USB-Camera via Mass-Storage-Driver:::::

Hallo celindir

... ups da hab ich etwas voreilig geantwortet.

Als ersters mußt Du dir einen aktuellen SuSE-Kernel runtersaugen. Danach funkts mit Sicherheit.

Sollte es dennoch nicht funken, noch ein paar Infos:

Fürs USB-Dvice gibt es zwei verschieden Treiber
1. usb-uhci
2. usb-ohcp
Du mußt dir den richtigen für Dein Board aussuchen. Es kommt manchmal vor, daß beide Treiber funktionieren, aber halt einer nur perfekt.
Wenn das klar ist, prüfe ob in der Datei /etc/fstab die Zeile "usbdevfs /proc/bus/usb usbdevfs noauto 0 0" steht.

Es giebt ein kleines Helferlein, mit dem Namen usbview, findest du auf der SuSE-CD.

mfG vost
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

Celindir
Gast





BeitragVerfasst am: 19. Aug 2002 12:39   Titel: Re: Hilfe::::USB-Camera via Mass-Storage-Driver:::::

Danke für die Tipps, werde sie heute Abend ausprobieren, wenn ich dazu komme.

Soviel weiss ich aber schonmal:


Zeile "usbdevfs /proc/bus/usb usbdevfs noauto 0 0" ist bei mir in der fstab vorhanden --- Aber was sagt mir das???

"Fürs USB-Dvice gibt es zwei verschieden Treiber
1. usb-uhci
2. usb-ohcp"
Under VMware mit win98 kappt es, also müsste ich doch den richtigen Treiber unter Linux benutzen, sonst könnte doch VMware nicht darauf zugreifen, oder ?

"sollte das Device schon vergeben worden sein, dann ist es halt das nächste "
Genau das ist ja das Problem.
Bei mir sind schon eine Reihe von scsi-devices vergeben (sda1, scd0, scd1 etc) woher bekomme ich raus, welches die Kamera benutzt??
cdrecord -scanbus liefert mir nur meine alten bekannten an scsi0 und scsi1
Gibt es noch einen anderen Weg die aktiven bzw. emulierten scsi-devices zu finden??

Danke fürs Kopfzerbrechen.

Euer Celindir
____________________________________
"May the source be with you..."
 

vost



Anmeldungsdatum: 16.08.2002
Beiträge: 48
Wohnort: Reutte in Tirol

BeitragVerfasst am: 19. Aug 2002 18:53   Titel: Re: Hilfe::::USB-Camera via Mass-Storage-Driver:::::

Hallo celindir

Vergiss mal was VMware sagt, das ist wie ein komlett anderer PC mit anderer Hardware. (zB. Netzwerkkarte)
Oder schau mal was Win98 unter VMware zu Deiner Grafikkarte sagt, mit Sicherheit passt der Driver nicht zur tatsächlichen Hardware.

Was das scsi-Device angeht, so wird eben das nächste freie genommen. Du hast also sda und scd schon benutzt, also wird Dein USB-Storage auf sdb, genauer gesagt auf sdb1 vergeben.
Um die Harddisks eines Rechners herauszufinden bedient man sich allgemeinhin mit fdisk.
Um herauszufinden ob sich das USB-Device richtig angemeldet hat gibt es das Programm "usbview"

Die Zeile in der fstab erklärt sich eigentlich selbst und gehört zum Grundwissen eines jeden Linuxers. Ich geh darauf jetzt nicht näher ein.

Aber zuerst mal, mach einen Kernelupdate, du wirst sehen, daß dann alles zu Deiner Zufriedenheit läuft

mfG vost
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

celindir
Gast





BeitragVerfasst am: 20. Aug 2002 9:22   Titel: Re: Hilfe::::USB-Camera via Mass-Storage-Driver:::::

@vost

"Die Zeile in der fstab erklärt sich eigentlich selbst und gehört zum Grundwissen eines jeden Linuxers. Ich geh darauf jetzt nicht näher ein."

Sorry, dann bin ich eben ein Linuxer ohne Grundwissen, der es trotzdem gewagt hat sich ein besseres Betriebssystem zu installieren als windoof und gehofft hat, von denen Hilfe zu bekommen, die mehr wissen !!

Was das Kernelupdate angeht, so hatte ich das ausprobiert und auf Kernel 2.4.18 upgedatet. Da mir danach aber ständig die Kiste bei der Videodigitalisierung via Capture-Card abgeschmiert ist, bin ich wieder auf den Standardkernel der SuSE zurückgegangen. Tja, noch so´n Minuspunkt für mich: "Ich kann noch keinen Kernel selbst updaten oder anpassen!"

Das mit der VMware war mir nur aufgefallen, da sich VMware beschwert, wenn kein USB-Ttreiber oder der falsche installiert ist. VMware greift nämlich meiner Erfahrung nach nicht direkt auf die Hardware zu sondern nur auf das, was Linux zur Verfügung stellt. Folglich: Wenn Linux kein USB hat, dann hat es VMware auch nicht. Ist aber nicht so wichtig.

@ all
Fakt ist, dass ich gestern mal die KNOPPIX reingeworfen habe und siehe da, es funktioniert alles Bestens mit der Kamera. Also ist es schon mal grundsätzlich möglich

Jetzt muss ich nur noch rausbekommen, worin die Unterschiede zu meiner SuSE in der Konfiguration liegen.

Das mit dem Kernelupdate werde ich allerdings dann wohl doch noch mal angehen. Ich hoffe nur, dass dann meine Capture-Karte nicht wieder spinnt.

Vielen Dank für die vielen Tipps.

Für mich ist diese Anfrage damit abgeschlossen und ich werde vorerst für die Kamera KNOPPIX nutzen.

So long
Celindir
_______________________
"May the source be with you..."
 

vost



Anmeldungsdatum: 16.08.2002
Beiträge: 48
Wohnort: Reutte in Tirol

BeitragVerfasst am: 20. Aug 2002 11:34   Titel: Re: Hilfe::::USB-Camera via Mass-Storage-Driver:::::

Hallo celindir

Ich nehme mal an Du hast bis jetzt, einen original SuSE-kernel am laufen gehabt. Ein SuSE-Kernel ist KEIN original Kernel, sondern ein gepatchter.
Du solltest jetzt natürlich auch einen SuSE-Kernel Update machen. Wenn du die Sourcen hast, dann solltest Du diese mit den selben Optionen kompilieren wie der Vorgängerkernel. Teoretisch kannst Du die Datei .config von den alten Sourcen in die neuen rüberkopieren, ein Aufruf von make menucinfig ist dann nicht mehr nötig.

Was VMware nochmal angeht. Du hast natürlich recht daß, die Driver über eine Britch auf das zugreifen was Linux zur verfügung stellt. Trotzdem ist VMware nicht unbedingt aussagekräftig.
Wenn du Devices suchst, dann schau doch direkt ins /proc-Verzeichnis zB. /proc/bus/usb und lies die Dateien darin mit cat aus. Und wenn Du dir jetzt mal wieder die fstab anschaust, dann siehst Du zB. daß /proc/bus/usb der Mountpoint von usbdevfs ist. Folglich sollte, da USB hotpluggable ist, in diesem Verzeichnis eine Datei erscheinen wenn man irgend ein USB-Device einsteckt.

Übrigens, wenn Du den Kernel updatest dann mußt du auch VMware neu installieren, damit die vmware-Module wieder am richtigen Platz installiert sind.

mfG vost
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

Knut
Gast





BeitragVerfasst am: 21. Aug 2002 8:24   Titel: Re: Hilfe::::USB-Camera via Mass-Storage-Driver:::::

Hallo,

da passt doch mein Problem auch gleich dazu...
Wenn ich die Kamera anstecke bekomme ich folgende Ausgaben:

hub.c: USB new device connect on bus 3/2, assigned device number 2
Manufacturer: HHH
Product: DIGITAL CAMERA
Serial Number: 4810817
scsi1: SCSI emulation for USB Mass Storage devices
usb_control/bulk_msg: timeout

Was hat das timeout zu bedeuten?

Ansonsten das gleiche Problem wie bei celindir (was mounten?).

Dank & Gruß
Knut
 

Celindir
Gast





BeitragVerfasst am: 16. Sep 2002 13:02   Titel: Re: Hilfe::::USB-Camera via Mass-Storage-Driver:::::

Hallo zusammen,

inzwischen habe ich mein Problem auf "einfache" Weise gelöst.

Ich habe auf SuSE 8.0 gewechselt.
Nun funktioniert alle bestens.

Nach dem einstöpseln der Cam an USb erscheint auf konsole 10 (Str+Alt+F10)
alles Wichtige an Infos. Bei mir unter anderem auch, dass es sich um /dev/sdb handalt.

mit mount -t vfat /dev/sdb1 /mnt/camera

konnte ich dann prima darauf zugreifen

Mittels Eintrag in die fstab und Icon auf dem KDE-Desktop ist das ganze dann nur noch ein Kinderspiel

Wenn ich jetzt noch pixie-plus aufrufe, dann steht der Dia-Show nichts im Wege.

Also Linux Rules again und Windows ist nicht mehr auf meiner Platte!!!

Celindir
 

KRXY
Gast





BeitragVerfasst am: 04. Feb 2003 12:47   Titel: Re: Hilfe::::USB-Camera via Mass-Storage-Driver:::::

Hallo

ALos bei meiner USB-Kamera zeigt er auf dem Syslog folgendes an :

>>usb.c: USB device 3 (vend/prod 0*d96/0*4102) is not claimed ba any active driver<<

Ich habe es unter SuSE 7.3 als auch unter 8.0 probiert. Beides mal dasselbe Ergebnis!
Die richtigen USB-Treiber habe ich meiner Meinung auch installiert.
Woran könnte das liegen? Könnte ihr mir bitte helfen??
 

Patrick
Gast





BeitragVerfasst am: 06. Feb 2003 12:47   Titel: Re: Hilfe::::USB-Camera via Mass-Storage-Driver:::::

Hallo,

schau einfach mal in YAST2 unter Suse 8,0 bei Partitionen nach, ob die Kamera im angeschlosssenen Zustand erkannt wird. Nicht vergessen die Kamera auf USB-Mass-Storage umzustellen. In YAST2 müsstest Du dann etwas sehen wie /dev/sda.. USB ... "Größe des Speichers", eben analog zu den anderen Partitionen.
Anschließend einfach einen Mountpoint erzeugen, z.B. /media/camera dann die /etc/fstab wie folgt ergänzen:

/dev/sda /media/camera auto noauto,user,sync 0 0

schon ging alles! Viel erfolg!

MfG

Patrick
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Hardware Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy