Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
VIA KT333

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Hardware
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
RoKo
Gast





BeitragVerfasst am: 20. Aug 2002 23:57   Titel: VIA KT333

Moin,

prinzipiell werden via chipsätze ja vom kernel unterstütz (CONFIG_BLK_DEV_VIA82CXXX). aber in wie weit läuft denn der kernel auf einem via kt333 board? werden chipspezifische funktionen unterstützt? läst sich UDMA einschalten oder hat jemand probleme damit gehabt, etc. ...?

ich möcht eigentlich nur sichergehen, das ich, wenn ich demnächst ein board mit diesem chipsatz bei mir einbaue, keine probleme mit gnu/linux bekomme, denn es wäre ein graus, wenn ich, wegen fehlender unterstützung seitens gnu/linux, wieder nur noch windows einsetzten könnte (im moment muß ich dies leider *uueäcks* und dummerweise brauchen die entsprechenden progs scheiß viel rechenleistung. desswegen muß auch ein neuer rechner her, der dann hoffentlich problemlos mit gnu/linux läuft)...

schreibt mir eure erfahrunge...

Gruß
RoKo
 

Knut
Gast





BeitragVerfasst am: 21. Aug 2002 18:48   Titel: Re: VIA KT333

Also ich hab nen A7V333 und kämpfe momentan mit dem USB.
Was UDMA betrifft kann ich nichts sagen, denn ich hab momentan nur alte Platten dranhangen die das nich können...

Der Sound klappt aber wenigstens...


Gruß
Nico
 

sputnik1969



Anmeldungsdatum: 26.07.2002
Beiträge: 92
Wohnort: Berlin

BeitragVerfasst am: 21. Aug 2002 18:57   Titel: Re: VIA KT333

Da der KT333 weitestgehend mit dem KT266/KT266A kompatibel sind welche wieder mit dem KT133/133A weitestgehend kompatibel sind solltest Du keine Probleme bekommen...
UDMA sollte zumindest kein Problem darstellen...USB schon eher, aber USB-Probleme gibt es irgendwie immer wieder auf verschiedenen Boards (bei meinem SIS-CHipsatz hat SuSE auch rumgesponnen...)
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

RoKo
Gast





BeitragVerfasst am: 22. Aug 2002 11:17   Titel: Re: VIA KT333

Moin,

Danke für die Antworten. Ich habs jetzt kurzerhand getestet, was bei rauskommt. Es läuft alles bestens.
Ich bin ja immer wieder überrascht wie problemlos GNU/Linux läuft. Nachdem ich den Rechner umgebaut hatte (übrigens ein Sprung von P1/233MHz auf AthlonXP1600+ ), konnte ich ohne irgenwelche Probleme GNU/Linux starten, im Gegensatz zu Windows (das mußte ich komplett neu installieren). Allerdings liefen die Festplatten nur in ... keine Ahnung was für ein Modus, auf jeden Fall nur mit Durchsätzen von ca. 3,5MB/s und mit hdparm ließen sie sich auch nicht zum DMA-Modus überreden. Erst der Wechsel auf Kernel 2.4.19 führte zum Erfolg. Jetzt läuft hda (da is Windows drauf) mit 22,07 MB/s und hdb mit 45,39 MB/s (die schnellere natürlich für GNU/Linux ). Und USB läuft auch (eigentlich hatte ich damit nur immer unter SuSE Probleme, sonst nie???)

Gruß
RoKo
 

Knut
Gast





BeitragVerfasst am: 23. Aug 2002 6:02   Titel: Re: VIA KT333

Was hast Du den für USB Geräte dranhängen?
Zufällig eins bei was als Mass Storage Device angesprochen wird?
 

Silver
Gast





BeitragVerfasst am: 22. Okt 2002 19:54   Titel: Re: VIA KT333

Hi

Ich hab nun auch ein Board mit VIA KT333 Chipsatz, aber ich kriege den 100er DMA-Modus auch mit dem Kernel 2.4.19 nicht ans laufen. Welche Optionen sind dafür bei der Kernel-Konfiguration genau nötig.
Wäre echt dankbar für eine Hilfe, weil die Festplatten im Moment verdammt langsam sind

MfG
Silver
 

Rene
Gast





BeitragVerfasst am: 28. Okt 2002 7:44   Titel: Re: VIA KT333

und wie sieht das mit dem KT400 aus? auch schon jemand da erfahrungen ?
 

RoKo
Gast





BeitragVerfasst am: 29. Okt 2002 20:35   Titel: Re: VIA KT333

nanu, wo kommt denn der Eintrag her...

@Knut
Mass Storage Geräte hatte ich noch nich dran ... keine Ahnung was mit dem Kernel-Modul nicht hinhauen sollte, was für ein Gerät wolltest du denn anschließen. Evtl. hilft Kernel-Doku weiter... war für mich schon sehr oft hilfreich

@Silver
Unterstützung für VIA-Chipsätze und 'DMA by Default' hat bei mir gereicht...glaube ich. Wie die Optionen jetzt ganz genau heißen und unter welchem Punkt die stehen, kann ich gerade nich nachsehen ... IBM-Platten sind scheiße, genauso wie Maxtor ... kaum läuft der Rechner ein halbes Jahr durch und schon gibt die Platte auf

@Rene
Kernel-Doku bzw. die Hilfe (z.B. in xconfig) zu 'Unterstützung für VIA-Chipsätze' ... da steht welche bis jetzt unterstützt werden. Der KT333 steht genau so wenig drin wie der KT400. Der letzte ist, wenn ich mich jetzt nicht irre, der KT266 ... ist auch so ziemlich egal, zur not kannst den Rechner ja solange bis er unterstützt wird im "Kompatibilitätsmodus" laufen lassen, sprich Standard-Chipsatz...
 

Arpock
Gast





BeitragVerfasst am: 29. Okt 2002 23:59   Titel: Re: VIA KT333

Ich habe leider genau dasselbe Problem, mit derselben Fehlermeldung bei hdparm -d1 /dev/hda. (Suse 8.0 mit Kernel 2.4.18, VIA KT333, IBM 80GB IC35)
Da ich absoluter Linux Newbee bin habe ich auch noch keine Lösung gefunden, die Supportdatenbank bei Suse.de gibt auch nichts nützliches dazu her.

Da ich noch keinen Plan habe, wie ich den aktuellen Kernel in meine 8.0 integriere muss ich wohl oder übel mal 8.1 ausprobieren, ansonsten läuft soweit alles, auch USB.

Hat jemand mit Suse 8.1 ähnliche Probleme, oder gehts da?

@RoKO: IBM Festplatten sind nicht schei..., die Spezifikation liegt bei IBM IDE-Drives bei etwa 330 Stunden im Monat, wenn Du einen Server laufen lässt nimm halt SCSI Platten, die sind für Dauerbetrieb konzipiert!!!
 

RoKo
Gast





BeitragVerfasst am: 30. Okt 2002 1:31   Titel: Re: VIA KT333

IBM ist natürlich nicht scheiße ... war nur ein wenig Sarkasmus ... Wenn die Platte abkackt muß das sein, damit man nich ausflippt Hatte mir extra keine Maxtor geholt, weil meinem Bruder zwei verreckt sind und dann passiert mir die gleiche Scheiße mit IBM ... naja ... Shit happens

ähhmmm und noch was ... die Platte läuft, besser lief, an einem normalen Desktop-Rechner, insoweit man es als Normal bezeichnen kann, wenn dieser auch Tag und Nacht läuft (330 Stunden/Monat sind dann doch etwas wenig) ... am Tag als Office-/Netzarbeitsplatz und die restliche Zeit als Multimedia-Plattform und alles was man sonst noch so anstellen kann mit Linux... eigenartigerweise laufen uralte Platten von Quantum(1.4G), Segate(3.2G), WesternDigital(13.2GB) seit Jahren ohne Probleme (in Server- und Desktop-Systemen), obwohl ich ziwschendurch mit diesen teilen soger "Fußball" gespielt habe (beim aus-/umbauen runtergefallen und so 'ne Scherze ... ab und zu braucht mein Server auch mal einen Tritt, damit die Platte wieder aus dem Ruhemodus hochfährt, obwohl sich da schon wieder die Frage stellt, wozu ein Server, wenn die Platte Zeit hat in den Ruhemodus zu schalten...). Wozu diese Scheiße mit massig GB und 7200U/min wenn diese Dinger nich halten ... ist doch dann voll für Arsch, oder???

KT333, hdparm und kernel 2.4.18 funktioniert nicht!!! Bei mir war 2.4.19 nötig... und bevor ich mit dieser Spielerei mit hdparm in Scripten anfange, backe ich den DMA-Modus lieber direkt in den Kernel ein...funktioniert und reicht für meine Bedürfnisse...

Bis gleich oder später
aber bestimmt rechtzeitig

RoKo
 

rene
Gast





BeitragVerfasst am: 30. Okt 2002 7:35   Titel: Re: VIA KT333

mhhhhh @roko
das liegt leider weniger am hersteller,.....ich habe auch seit ca 1. jahr 2 60gb maxtor 7200 rpm bei mir als raid 0 laufen.
die laufen auch tag und nacht...auch nix passiert. man kann halt mal ne üble serie erwischen , aber halt auch bei ibm Smile
 

Arpock
Gast





BeitragVerfasst am: 30. Okt 2002 10:59   Titel: Re: VIA KT333

@ RoKo: klar ist das ärgerlich wenn einem die Platte abraucht, meine Bemerkung war ja auch nicht böse gemeint. Wink Jedenfalls hat man mit SCSI Platten nicht so schnell Probleme, dafür kosten sie aber auch das X-Fache!
Das die neueren (schnellen) Platten nicht mehr so robust sind hat schon seinen Hintergrund denke ich. Verkaufen, Verkaufen, Verkaufen! Man sieht hin und wieder noch einen alten /8 von Mercedes rumfahren. Ich kann mir aber nicht vorstellen, dass man in 25 Jahren noch ne aktuelle E-Klasse rumfahren sieht. Ich denke das ist in jedem Bereich so.

Wie "backe" Smile ich denn den DMA-Modus in den Kernel ein bzw. wie füge ich einen neuen Kernel in mein bestehendes Linux??
In der "Linuxfibel" fehlt dieser Teil leider völlig Sad Hat es als Anfänger überhaupt einen Sinn sich da ran zu trauen, oder sollte ich besser die Finger davon lassen?
Habe mal gelesen, dass die einzelnen Distributoren soviel an den Kernels ändern, dass sie kaum noch etwas mit den Originalen gemein haben.
Wäre schon toll, wenn ich DMA nutzen könnte, hab nen Durchsatz von 6,63 MB/ sec!! bin fast vom Hocker gefallen! Auf meinem Notebook mit Toshiba Platte (4200 U/min) habe ich 28 MB/ min!

Bin für Hilfe sehr dankbar.

Grüße Arpock
 

RoKo
Gast





BeitragVerfasst am: 03. Nov 2002 23:19   Titel: Re: VIA KT333

Moin,

@Arpock
wie gesagt, da mir z.Z. eine Platte fehlt, und zwar die wo Linux drauf war, kann ich gerad nicht nachsehen, wie genau die Kernel-Optionen heißen für den DMA-Modus. Sinngemäß hatte ich schon geschrieben ('VIA-Chipsatz-Unterstützung' und 'DMA by Default' fest im Kernel, nicht als Modul)...

Die Kernel der Distributoren sind natürlich massig gepacht, aber die gepachten Quellpakete sollten eigentlich dabei sein. Diese einfach installieren und im Quellverzeichniss (sollte eigentlich '/usr/src/linx ' sein) 'make menuconfig' für Textkonsolenconfiguration bzw. 'make xconfig' für X, ausführen und sich durchwurschteln und ab und zu die Hilfe lesen. Ist zwar Englisch, aber doch gut verständlich. Und meistens steht auch eine Empfehlung dabei (z.B.: Wenn du nicht weißt, was damit gemeint ist, dann wirst du es wahrscheinlich auch nicht brauchen). Vorher würde ich noch die Konfiguration des Distributors für den derzeitigen Kernel laden. Diese liegt meist im Verzeichniss 'boot' ('.config-xxxxxx'). Damit hast du erst mal eine lauffähige Konfiguration und kannst dann die Sachen ein- oder ausschalten die du haben möchtest oder nicht brauchst (z.B. ISDN aus, bei Modem oder DSL). Wenn du damit dann fertig bist: 'make dep && make clean && make bzImage && make modules && make modules_install". "make install" gibts auch noch (glaube ich) um den Kernel zu installieren, allerdings wird der Kernel dann nach '/' kopiert und nicht nach '/boot'. Ich kopier den darum immer von Hand vom Verzeichniss ... gute Frage, weiß ich jetzt nicht genau ... ..../kernel/i386/ ... 'cp bzImage /boot/vmlinuz'
Danach noch den Bootloader anpassen und das wars dann...

Einfacher gehts mit Debian... und verdammt ich weiß gerad den Befehl nich .... auf jeden Fall was mit "m<TAB><TAB>"

hört sich, glaube ich, komplizierter an, als es ist...

einfach probieren, wird schon schief gehn...

Gruß
RoKo
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Hardware Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy