Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
modprobe

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Hardware
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
tom@plforum
Gast





BeitragVerfasst am: 29. Aug 2002 7:49   Titel: modprobe

Hallo,

vielleicht ist's nur 'ne Kleinigkeit..?
das Modul aha152x soll automatisch geladen werden, dazu habe ich folgende Dateien modifiziert:

/etc/modules.conf
alias adaptec aha152x
options aha152x io=0x340 irq=11

/etc/rc.d/rc.local
modprobe adaptec

Nach einem reboot wird "modprobe adaptec" auch ausgeführt, allerdings mit folgender Fehlermeldung aus /var/log/messages

> Aug 29 07:08:14 AP240 kernel: SCSI subsystem driver Revision: 1.00
Aug 29 07:08:15 AP240 kernel: aha152x: BIOS test: passed, detected 1 controller(s)
Aug 29 07:08:15 AP240 kernel: aha152x: resetting bus...
Aug 29 07:08:15 AP240 kernel: aha152x0: vital data: rev=1, io=0x340 (0x340/0x340), irq=11, scsiid=7, reconnect=enabled, parity=enabled, synchronous=enabled, delay=1000, extended translation=disabled
Aug 29 07:08:15 AP240 kernel: aha152x0: trying software interrupt, lost.
Aug 29 07:08:15 AP240 kernel: aha152x0: IRQ 11 possibly wrong. Please verify. <

Wenn ich den selben Befehl "modprobe adaptec" nach der KDE-Anmeldung in einer Shell aufrufe funktioniert das ganze dann, das Modul wird geladen und der Controller funktioniert.

Gruß
Tom
 

Bob Gomorrha
Gast





BeitragVerfasst am: 29. Aug 2002 9:29   Titel: Re: modprobe

Naja - dann lass mal in der modules.conf die options weg. Sieht so aus, als gefalle ihm der Interrupt 11 nicht.
 

tom@plforum
Gast





BeitragVerfasst am: 29. Aug 2002 9:48   Titel: Re: modprobe

schon probiert, bringt keine Änderung,

>...Wenn ich den selben Befehl "modprobe adaptec" nach der KDE-Anmeldung in einer Shell aufrufe funktioniert das ganze dann, das Modul wird geladen und der Controller funktioniert...<

wo ist der Unterschied ob der Befehl in der rc.local aufgerufen wird oder 1 minute später unter kde3 in einer shell...?
 

arjo1
Gast





BeitragVerfasst am: 29. Aug 2002 16:00   Titel: Re: modprobe

Trag mal "alias scsi_hostadapter adaptec" in der modules.conf ein.
Und dann in der rc.local "/sbin/modprobe adaptec".
 

tom@plforum
Gast





BeitragVerfasst am: 29. Aug 2002 21:44   Titel: Re: modprobe

das habe ich schon gemacht...

syntax -> alias "aliasname" "modulname"
-> alias adaptec aha152x
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Hardware Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy