Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Hama Kartenleser unter SuSE 8.2

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Hardware
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
dominik
Gast





BeitragVerfasst am: 29. Dez 2003 16:03   Titel: Hama Kartenleser unter SuSE 8.2

Hallo!

Habe einen Hama SmartMedia Kartenleser, den ich gernen unter Linux zum laufen bringen möchte!
Ich weiß nicht, wie ich ihn mounten soll! (unter welchem Anschluss er läuft???)

Kann mir dabei bitte jemand helfen

Gruß
dominik
 

Gunnar
Gast





BeitragVerfasst am: 30. Dez 2003 0:01   Titel: Re: Hama Kartenleser unter SuSE 8.2

Hi,
immer als SCSI-Device, also z.B. /dev/sda1 o.ä.
Als was er angesprochen werden kann steht gewöhnlich in den Logs oder auch in der Ausgabe von "dmesg". Evtl. hilft auch ein "rescan-scsi-bus.sh" aus den sg3_utils (bei SuSE dabei?).
Gunnar
 

dominik
Gast





BeitragVerfasst am: 30. Dez 2003 0:14   Titel: Re: Hama Kartenleser unter SuSE 8.2

Danke erstmal!

Hab ich alles schon probiert, aber er zeigt nicht mal was in /var/log/messages an, wenn ich ihn anschließe!!

Er wird gar nicht erkannt, als Hardware!

Ich bin Ratlos!!

Gruß
dominik
 

Gunnar
Gast





BeitragVerfasst am: 30. Dez 2003 2:05   Titel: Re: Hama Kartenleser unter SuSE 8.2

hört sich an als wenn keine usb-Treiber geladen sind ...
 

dominik
Gast





BeitragVerfasst am: 30. Dez 2003 18:29   Titel: Re: Hama Kartenleser unter SuSE 8.2

Sorry, wenn ich so etwas fragen muss, aber ich bin ziemlich neu, was Linux betrifft!

Wo kann ich das sehen, ob die Treiber geladen sind?

Gruß
dominik
 

Gunnar
Gast





BeitragVerfasst am: 30. Dez 2003 23:22   Titel: Re: Hama Kartenleser unter SuSE 8.2

Wenn Du als root mal lsmod eingibst, bekommst du eine Liste der geladenen Module. Darin steht u.a. so was:

usb-uhci 21612 0 (unused)
ehci-hcd 14152 0 (unused)
usbcore 56768 1 [snd hid usb-uhci ehci-hcd]

Wenn Du ein Gerät ansteckst, das nicht erkannt wird siehst du im Log (/var/log/messages) zumindest das:

Dec 30 23:13:45 m6 kernel: hub.c: USB new device connect on bus4/1/1, assigned device number 4
Dec 30 23:13:45 m6 kernel: usb-uhci.c: interrupt, status 2, frame# 1482
Dec 30 23:13:45 m6 kernel: usb.c: USB device not accepting new address=4 (error=-110)
Dec 30 23:13:45 m6 kernel: hub.c: USB new device connect on bus4/1/1, assigned device number 5
Dec 30 23:13:45 m6 kernel: usb.c: USB device 5 (vend/prod 0x864/0x4102) is not claimed by any active driver.


Wenn das Gerät erkannt wird siehts so aus:

Dec 30 23:16:38 m6 kernel: usb.c: registered new driver usb-storage
Dec 30 23:16:38 m6 kernel: scsi0 : SCSI emulation for USB Mass Storage devices
Dec 30 23:16:38 m6 kernel: Vendor: Model: USB Storage-SMC Rev: 0209
Dec 30 23:16:38 m6 kernel: Type: Direct-Access ANSI SCSI revision: 02
Dec 30 23:16:38 m6 kernel: Vendor: Model: USB Storage-CFC Rev: 0209
Dec 30 23:16:38 m6 kernel: Type: Direct-Access ANSI SCSI revision: 02
Dec 30 23:16:38 m6 kernel: Vendor: Model: USB Storage-MMC Rev: 0209
Dec 30 23:16:38 m6 kernel: Type: Direct-Access ANSI SCSI revision: 02
Dec 30 23:16:38 m6 kernel: sd_init()
Dec 30 23:16:38 m6 kernel: sd: allocated major 8
Dec 30 23:16:38 m6 kernel: sd_attach()
Dec 30 23:16:38 m6 kernel: sd: find_free_slot ...<7>sd: ... found 08:00
Dec 30 23:16:38 m6 kernel: Attached scsi removable disk sda at scsi0, channel 0, id 0, lun 0
Dec 30 23:16:38 m6 kernel: sd_attach()
Dec 30 23:16:38 m6 kernel: sd: find_free_slot ...<7>sd: ... found 08:10
Dec 30 23:16:38 m6 kernel: Attached scsi removable disk sdb at scsi0, channel 0, id 0, lun 1
Dec 30 23:16:38 m6 kernel: sd_attach()
Dec 30 23:16:38 m6 kernel: sd: find_free_slot ...<7>sd: ... found 08:20
Dec 30 23:16:38 m6 kernel: Attached scsi removable disk sdc at scsi0, channel 0, id 0, lun 2
Dec 30 23:16:38 m6 kernel: sd_finish()
Dec 30 23:16:38 m6 kernel: sd_init_onedisk (0,0), sda 08:00
Dec 30 23:16:38 m6 kernel: sda : READ CAPACITY failed.
Dec 30 23:16:38 m6 kernel: sda : status = 1, message = 00, host = 0, driver = 08
... und so weiter ...
Das war übigens auch ein Hama-Reader unter SuSE8.1

Hast Du schon mal testweise ein anderes USB-Gerät angesteckt?

Gunnar
 

dominik
Gast





BeitragVerfasst am: 31. Dez 2003 17:18   Titel: Re: Hama Kartenleser unter SuSE 8.2

HI!

Danke erstmal!

Ich hab es mal ausprobiert!

Wenn ich lsmod eingebe, gibt er mir folgendes aus:

Module Size Used by Tainted: PF
snd-pcm-oss 50144 0 (autoclean)
snd-mixer-oss 15704 1 (autoclean) [snd-pcm-oss]
videodev 6176 0 (autoclean)
isa-pnp 31560 0 (unused)
pppoe 7520 1 (autoclean)
pppox 1144 1 (autoclean) [pppoe]
usbserial 19580 0 (autoclean) (unused)
lp 6400 0 (autoclean)
ipv6 145108 -1 (autoclean)
snd-via8233 14916 1
snd-pcm 71168 0 [snd-pcm-oss snd-via8233]
snd-timer 13376 0 [snd-pcm]
snd-ac97-codec 35696 0 [snd-via8233]
snd-mpu401-uart 3840 0 [snd-via8233]
snd-rawmidi 15584 0 [snd-mpu401-uart]
snd-seq-device 4512 0 [snd-rawmidi]
snd 40900 0 [snd-pcm-oss snd-mixer-oss snd-via8233 snd-pcm snd-timer snd-ac97-codec snd-mpu401-uart snd-rawmidi snd-seq-device]
soundcore 3748 0 [snd]
vmnet 20016 2
parport_pc 28200 1
parport 25352 1 [lp parport_pc]
vmmon 25052 0 (unused)
printer 7104 0
ipt_TCPMSS 2392 1 (autoclean)
ipt_TOS 1048 18 (autoclean)
ipt_MASQUERADE 1368 1 (autoclean)
ipt_LOG 3384 129 (autoclean)
ipt_state 568 105 (autoclean)
st 29716 0 (autoclean) (unused)
sr_mod 13720 0 (autoclean)
sg 27804 0 (autoclean)
mousedev 4372 0 (unused)
joydev 5792 0 (unused)
evdev 4192 0 (unused)
input 3264 0 [mousedev joydev evdev]
usb-uhci 23664 0 (unused)
usbcore 63116 1 [usbserial printer usb-uhci]
raw1394 15828 0 (unused)
af_packet 13224 1 (autoclean)
ppp_generic 17276 3 (autoclean) [pppoe pppox]
slhc 5104 0 (autoclean) [ppp_generic]
ohci1394 17716 0 (unused)
ieee1394 36496 0 [raw1394 ohci1394]
8139too 15752 2
mii 2528 0 [8139too]
ipt_REJECT 3160 3 (autoclean)
iptable_mangle 2200 1 (autoclean)
iptable_filter 1708 1 (autoclean)
ip_nat_ftp 2960 0 (unused)
iptable_nat 16366 2 [ipt_MASQUERADE ip_nat_ftp]
ip_conntrack_ftp 3888 1
ip_conntrack 16964 3 [ipt_MASQUERADE ipt_state ip_nat_ftp iptable_nat ip_conntrack_ftp]
ip_tables 11200 11 [ipt_TCPMSS ipt_TOS ipt_MASQUERADE ipt_LOG ipt_state ipt_REJECT iptable_mangle iptable_filter iptable_nat]
ide-scsi 10384 0
ide-cd 31964 0
cdrom 30304 0 [sr_mod ide-cd]
ext3 85928 1 (autoclean)
jbd 50896 1 (autoclean) [ext3]
lvm-mod 67812 0 (autoclean)
reiserfs 217364 3

Wenn ich den Reader anschließe steht in /var/log/messages folgendes drin:

Dec 31 17:15:00 charly kernel: hub.c: new USB device 00:11.3-2, assigned address 3
Dec 31 17:15:00 charly kernel: usb.c: USB device 3 (vend/prod 0x7c4/0xa103) is not claimed by any active driver.

Ich weiß jetzt nicht weiter, was das bedeutet!!

Gruß
Dominik

P.S Sorry, wenn ich alles mit reikopiert habe, aber ich weiß nicht so genau, was wichtig und nicht so wichtig ist.
 

Gunnar
Gast





BeitragVerfasst am: 04. Jan 2004 0:19   Titel: Re: Hama Kartenleser unter SuSE 8.2

Hi,
unter /etc/hotplug oder so müsste es eine oder mehrere Tabellen usb.???map geben. In diesen Tabelle sieht hotplug nach wie das Gerät zu behandeln ist, es sucht also im eigenen Code und in den Tabellen nach "vend/prod 0x7c4/0xa103".
Wenn das Gerät nicht zuzuordnen ist gibts als Info ein "...is not claimed by any active driver".
Ich würde mal versuchen den Vendor/Product-Code in der Tabelle nachzutragen. Am einfachsten gehts wenn man sich ein ähnliches Gerät kopiert und den Eintrag abändert.
Normalerweise sollte hotplug die Module "scsi_mod" (oder war "sr_mod"?) und "usb-storage" laden. Vor der hotplug-Änderung könnte man mal versuchen diese Module per Hand zu laden (als root "modprobe usb-storage") und mal im Log zu gucken was passiert.
Gunnar
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Hardware Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy