Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
SCSI-Controller verhindert Systemstart

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Hardware
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Mark
Gast





BeitragVerfasst am: 06. März 2004 21:14   Titel: SCSI-Controller verhindert Systemstart

Ich habe eine SCSI-Karte (für Scanner Umax Astra 1220S) eingebaut. Beim Starten von Linux (SuSE 8.2) kam eine Meldung "neue Hardware gefunden", danach wurde sie als neuer Festplatten-Controller eingetragen. Ich hab dummerweise einfach die vorgeschlagenen Änderungen angenommen. Der Scanner funktionierte dann auch. Wenn ich aber seitdem ein auf der selben Platte (IDE) installiertes Windows starten will gibt Grub eine Meldung aus, dass ich den Namen des Befehlszeileninterpreters angeben soll. Ich kann jetzt mein Windoof nicht mehr starten! Was kann ich tun?
Ich weiß nicht so genau, was ein Festplatten-Controller ist und auch nicht ob da vorher einer eingetragen war und wie das sein muss. Der jetzige heißt "DTC Domex 536" und will das Modul "dmx3191d" laden.

Erstmal hab ich in YaST geändert, dass der Controller nicht mehr in die initrd geladen wird, hat nichts genutzt, hatte aber den nervigen Nebeneffekt, dass der Scanner seitdem nicht mehr angesprochen wird. Auch dann nicht, wenn ich den Controller wieder laden lasse.
Wer kann helfen?
 

Mark
Gast





BeitragVerfasst am: 08. März 2004 19:41   Titel: Re: SCSI-Controller verhindert Systemstart

Ich habs gefunden. YaST hat offensichtlich beim Installieren des "Festplatten"-Controllers (war ja eigentlich die SCSI-Karte für den Scanner) die Konfigurationsdatei von Grub (menu.lst) neu geschrieben. Ich habe eine von Hand erstellte in Betrieb, die pro Menüpunkt viele Zeilen enthält, mit denen ich Partitionen verstecke bzw. hervorhole. Leider kürzt YaST aus einem mir völlig unverständlichen Grund immer wenn es die menu.lst schreibt die Einträge auf ein paar Zeilen pro Menüpunkt. Die Windows-Systempartitionen waren also schlicht versteckt.
Ich musste einfach meine Menü-Datei wieder ins Grub-Verzeichnis kopieren (gut die noch irgendwo zu haben!). Total easy, bin aber nicht draufgekommen.
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Hardware Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy