Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Wiso mutiren meine ATAPI ROM´s zu SCSI ROM´s ?!?

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Hardware
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
olaf
Gast





BeitragVerfasst am: 10. März 2004 15:00   Titel: Wiso mutiren meine ATAPI ROM´s zu SCSI ROM´s ?!?

hallo zusammen:

HW:
Ein alter HP PII/400 mit 128 MB und Grafk on board
Pri IDE 2 x HDD via cableselect
Sec IDE 1 X DVD ROM und 1 x CD ROM (Master/Slave)
AHA2940 mit HP DAT 12-24 C1537A KEINE HDD´s od. ROM´s
(AIC7xxx)

Installation: Fedora Core (1.A) KOMPLETT


Waehrend und direkt nach der Installtion sind beide ROMs via /dev/cdrom bzw /dev/cdrom1 mountbar.

Nach dem 3. Bootvorgang bekam ich diese tolle Meldung:

mount: Falscher Dateisystemtyp, ungültige Optionen, der
»Superblock« von /dev/cdrom1 ist beschädigt oder es sind
zu viele Dateisysteme eingehängt
(could this be the IDE device where you in fact use
ide-scsi so that sr0 or sda or so is needed?)

Nach einigem Suchen stellte sich herraus, das die ROM´s nun als
/dev/scd0 bzw /dev/scd1 ansprechbar sind.

Nun meine einfache Frage: WISO werden die Lauferke als SCSI erkannt?

Olaf
 

Jochen
Gast





BeitragVerfasst am: 10. März 2004 16:05   Titel: Re: Wiso mutiren meine ATAPI ROM´s zu SCSI ROM´s ?!?

Das kann eigentlich nur als Ursache haben, dass das ide-scsi Modul geladen wird. Normalerweise geschieht das nur, um einen Brenner ansprechen zu können (Kernel 2.4, der 2.6er braucht das nicht mehr). Hast Du zwischen den Bootvorgängen irgendwas am Kernel oder am Boot-Manager gedreht oder so?

Schau mal in die /boot/grub/menu.lst (oder grub.conf, ist der RH-Name dafür, Link namens menu.lst existiert aber auch). Dort müsstest Du dann in der kernel-Zeile zu Deinem Boot-Eintrag ein "hdc=ide-scsi hdd=ide-scsi" finden. Lösch das da mal raus und reboote, dann sollte es schon besser aussehen.

Jochen
 

Olaf
Gast





BeitragVerfasst am: 11. März 2004 18:46   Titel: Re:Re: Wiso mutiren meine ATAPI ROM´s zu SCSI ROM´s ?!?

Erst einmal Danke für die Bemühungen,

das ide-scsi modul wird tatsächlich geladen.
aber in der grub.conf ist kein eintrag vorhanden.

Systemlog:
.
.
.
Mar 11 09:46:49 test kernel: VFS: Mounted root (ext2 filesystem).
Mar 11 09:46:49 test kernel: SCSI subsystem driver Revision: 1.00
Mar 11 09:46:49 test kernel: PCI: Found IRQ 5 for device 00:12.0
Mar 11 09:46:49 test kernel: scsi0 : Adaptec AIC7XXX EISA/VLB/PCI SCSI HBA DRIVER, Rev 6.2.36
Mar 11 09:46:49 test kernel: <Adaptec 2940 Ultra SCSI adapter>
Mar 11 09:46:49 test kernel: aic7880: Ultra Single Channel A, SCSI Id=7, 16/253 SCBs
Mar 11 09:46:49 test kernel:
Mar 11 09:46:49 test kernel: blk: queue c758d414, I/O limit 4095Mb (mask 0xffffffff)
Mar 11 09:46:49 test kernel: (scsi0:A:3): 5.000MB/s transfers (5.000MHz, offset 15)
Mar 11 09:46:49 test kernel: Vendor: HP Model: C1537A Rev: L708
Mar 11 09:46:49 test kernel: Type: Sequential-Access ANSI SCSI revision: 02
Mar 11 09:46:49 test kernel: blk: queue c7ef5e14, I/O limit 4095Mb (mask 0xffffffff)
Mar 11 09:46:49 test kernel: Journalled Block Device driver loaded
Mar 11 09:46:49 test kernel: kjournald starting. Commit interval 5 seconds
Mar 11 09:46:49 test kernel: EXT3-fs: mounted filesystem with ordered data mode.
Mar 11 09:46:49 test kernel: Freeing unused kernel memory: 136k freed
.
.
.
Mar 11 09:47:22 test kernel: hdc: attached ide-scsi driver.
Mar 11 09:47:22 test kernel: hdd: attached ide-scsi driver.
Mar 11 09:47:22 test kernel: scsi2 : SCSI host adapter emulation for IDE ATAPI devices
Mar 11 09:47:22 test kernel: Vendor: PIONEER Model: DVD-ROM DVD-116 Rev: 1.09
Mar 11 09:47:22 test kernel: Type: CD-ROM ANSI SCSI revision: 02
Mar 11 09:47:22 test kernel: Vendor: HITACHI Model: CDR-8435 Rev: 0010
Mar 11 09:47:22 test kernel: Type: CD-ROM ANSI SCSI revision: 02
.
.


Mit dieser Tatsache könnte ich noch leben, wenn nich anaconda bei jedem boot die /etc/fstab falsch berichtigt.
Hier steht nach jedem boot wieder /dev/cdrom drin.

Zu deiner Frage ob ich zwichen dem 1. und 3. boot etwas installiert habe oder der gleichen: nein.


Mfg Olaf
 

Jochen
Gast





BeitragVerfasst am: 11. März 2004 19:29   Titel: Re: Wiso mutiren meine ATAPI ROM´s zu SCSI ROM´s ?!?

Das Verschlimmbessern der /etc/fstab kannst DU schon mal abschalten, indem Du in der /etc/fstab in den betreffenden Zeilen in der 4. Spalte das Schüsselwort "kudzu" löschst. Dann packt kudzu (nicht anaconda) die jeweilige Zeile nicht mehr an.

Es könnte sein, dass das Laden der ide-scsi-EMualtion aus der initrd heraus passiert. Poste mal den Inhalt Deiner /etc/modules.conf, die wird u.a. zum Erstellen der initrd verwendet, wenn man einen "mkinitrd"-Aufruf von Hand macht.

Jochen
 

Olaf
Gast





BeitragVerfasst am: 12. März 2004 10:36   Titel: Hier die modules.conf

Hallo Jochen,

das entfernen von kudzu wirkte wunder. Danke

Hier nun meine modules.conf

alias eth0 3c59x
alias scsi_hostadapter aic7xxx
alias sound-slot-0 cs46xx
post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1 || :
pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 || :
alias usb-controller usb-uhci

In der Zwichenzeit habe ich noch einen USB CFCard Reader angeschlossen.


Olaf
 

Jochen
Gast





BeitragVerfasst am: 12. März 2004 13:35   Titel: Re: Wiso mutiren meine ATAPI ROM´s zu SCSI ROM´s ?!?

Tja, die sieht soweit eigentlich ganz korrekt aus... Keinerlei Verweise auf ide-scsi. Versuch mal folgendes: Kopiere die /boot/initrd-<kernelversion>.img in ein Arbeitsverzeichnis, entpacke sie (gzip -dc <initrd-*.img >image) und mounte sie (mount -o loop image /mnt). Unter /mnt findest Du dann den Inhalt der initrd. Das Skript "linuxrc" wird ausgeführt; vielleicht findest Du hier irgendwelche Hinweise auf Module, die geladen werden sollen? Du müsstest beispielsweise den Treiber für den AHA2940 unter /mnt finden. Wenn hier auch irgendwas von ide-scsi steht, ist der Fall klar.

Ansonsten hätte ich nur noch zwei Vorschläge: Zu Fedora sind mittlerweile schon ein paar Kernelupdates rausgekommen. Vielleicht mal das aktuelle davon installieren? Oder aber Nägel mit Köpfen machen und einen eigenen Kernel bauen, der von vorneherein gar kein ide-scsi unterstützt.

Jochen
 

olaf
Gast





BeitragVerfasst am: 14. März 2004 21:41   Titel: Re: Wiso mutiren meine ATAPI ROM´s zu SCSI ROM´s ?!?

Hallo Jochen,

asche auf mein Haupt,

es war die TapeWare von Yosemite Technologies.

Ich habe einen 2. Rechner aufgesetzt und nach der Installation von TapeWare hatte ich auch hier dieses Problem.
Trotzdem besten Dank. Ich habe doch einiges gelernt. Linux ist doch etwas anderes als HP-UX auf einer HP E55
DANKE

Olaf
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Hardware Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy