Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Problem mit USB Stick seid Umstellung auf Kernel 2.6

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Hardware
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
timux



Anmeldungsdatum: 05.04.2004
Beiträge: 1
Wohnort: noch Philippsthal / bald Berlin ;-)

BeitragVerfasst am: 05. Apr 2004 13:27   Titel: Problem mit USB Stick seid Umstellung auf Kernel 2.6

Hiho,
ich probier jetzt schon seit längerem meinen 128 Mbyte USB Stick unter Linux
2.6 zu benutzen,
aber ich bekomm immer die Fehlermeldung
usb 1-1: control timeout on ep0in
Irgendwie muss es daran liegen, dass hotplug dem stick kein Treibermodul
(usb-storage) zuweisen kann.
Daten zu dem Stick:
"Leading Driver, UD-11 - 128 MByte"
lsusb schreibt:
Bus 002 Device 002: ID 045e:001e Microsoft Corp. IntelliMouse Explorer
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 001: ID 0000:0000

Mehr Infos liefert /var/log/messages, hier steht zumindest die Produkt ID:
Apr 1 19:52:07 timuxkiste kernel: usb 1-1: new full speed USB device using
address 2
Apr 1 19:52:07 timuxkiste kernel: usb 1-1: Product: USB Embedded Hub
Apr 1 19:52:07 timuxkiste kernel: usb 1-1: Manufacturer: Leading Driver
Co.,LTD.
Apr 1 19:52:07 timuxkiste kernel: hub 1-1:1.0: USB hub found
Apr 1 19:52:07 timuxkiste kernel: hub 1-1:1.0: 2 ports detected
Apr 1 19:52:08 timuxkiste usb.agent[17691]: ... no modules for USB product
67b/2315/1
Apr 1 19:52:13 timuxkiste kernel: usb 1-1: control timeout on ep0in
Apr 1 19:52:36 timuxkiste kernel: usb 1-1: control timeout on ep0out
Apr 1 19:52:41 timuxkiste kernel: usb 1-1: control timeout on ep0in
Apr 1 19:52:50 timuxkiste kernel: usb 1-1: control timeout on ep0in
Apr 1 19:52:50 timuxkiste kernel: usb 1-1: USB disconnect, address 2

Der Stick funktioniert 100% (unter Windows getestet) und lief v
orher auch
schon an meinem Rechner
jedoch unter 2.4.18 - 22! Hoffe jemand kann mir helfen die Zuordnung wieder
herzustellen. Axo: USB sonst funzt,
meine USB Maus geht schließlich auch. Und usb-storage ist fest in den kenel
kompiliert:

Initializing USB Mass Storage driver...
drivers/usb/core/usb.c: registered new driver usb-storage
USB Mass Storage support registered.

Hoffe mir kann jemand helfen, da ich schon seit Monaten am rumbasteln bin, und
langsam keine Ideen mehr hab.
Patch jetzt erstmal auf 2.6.4
Grüße und vielen Dank im Vorraus
Timux

PS: Hier noch die Ausgabe von dmesg:
drivers/usb/host/uhci-hcd.c: d000: wakeup_hc
hub 1-0:1.0: port 1, status 101, change 1, 12 Mb/s
hub 1-0:1.0: debounce: port 1: delay 100ms stable 4 status 0x101
usb 1-1: new full speed USB device using address 2
usb 1-1: new device strings: Mfr=1, Product=3, SerialNumber=0
drivers/usb/core/message.c: USB device number 2 default language ID 0x409
usb 1-1: Product: USB Embedded Hub
usb 1-1: Manufacturer: Leading Driver Co.,LTD.
drivers/usb/core/usb.c: usb_hotplug
usb 1-1: registering 1-1:1.0 (config #1, interface 0)
drivers/usb/core/usb.c: usb_hotplug
hub 1-1:1.0: usb_probe_interface
hub 1-1:1.0: usb_probe_interface - got id
hub 1-1:1.0: USB hub found
hub 1-1:1.0: 2 ports detected
hub 1-1:1.0: compound device; port removable status: FF
hub 1-1:1.0: individual port power switching
hub 1-1:1.0: individual port over-current protection
hub 1-1:1.0: Port indicators are not supported
hub 1-1:1.0: power on to power good time: 100ms
hub 1-1:1.0: hub controller current requirement: 100mA
hub 1-1:1.0: local power source is lost (inactive)
hub 1-1:1.0: no over-current condition exists
hub 1-1:1.0: enabling power on all ports
hub 1-1:1.0: port 1, status 101, change 1, 12 Mb/s
hub 1-1:1.0: transfer --> -75
usb 1-1: control timeout on ep0in
drivers/usb/host/uhci-hcd.c: d000: suspend_hc
hub 1-1:1.0: hub_port_status failed (err = -110)
hub 1-1:1.0: connect-debounce failed, port 1 disabled
usb 1-1: control timeout on ep0out
hub 1-1:1.0: cannot disable port 1 (err = -110)
usb 1-1: control timeout on ep0in
hub 1-1:1.0: hub_port_status failed (err = -110)
usb 1-1: control timeout on ep0in
hub 1-1:1.0: hub_hub_status failed (err = -110)
hub 1-1:1.0: get_hub_status failed
hub 1-0:1.0: port 1, status 100, change 3, 12 Mb/s
usb 1-1: USB disconnect, address 2
usb 1-1: usb_disable_device nuking all URBs
uhci_hcd 0000:00:04.2: shutdown urb c6e96900 pipe 40408280 ep1in-intr
usb 1-1: unregistering interface 1-1:1.0
usb 1-1: hcd_unlink_urb c6e96900 fail -16
drivers/usb/core/usb.c: usb_hotplug
usb 1-1: unregistering device
drivers/usb/core/usb.c: usb_hotplug
hub 1-0:1.0: port 1 enable change, status 100
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen

kobi
Gast





BeitragVerfasst am: 15. Apr 2004 2:45   Titel: scsi

hast du auch scsi support in deinem kernel?
usb-mass storage wird als scsi gerät angesprochen
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Hardware Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy