Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Probleme mit den RAMs ...

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Sonstiges
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Benjamin Klöpfer
Gast





BeitragVerfasst am: 12. Okt 2000 17:44   Titel: Probleme mit den RAMs ...

Hallo alle zusammen,

ich habe in meinen PC letztens ein neues Mainboart eingebaut und die RAM-Riegel von alten übernommen. Mein Bustakt ist 100MHz, wie auch im altem.
Jetzt das Problem: Das BIOS zeigt mir 128 MB RAM an, Windoof zeit auch 128 MB Ram an, nur Linux Zeit 64 MB an (top), und stürzt laufend mit Speicherzugriffsfeheler ab. An Kernel liegt es nicht, denn ich habe schon 3 ausprobiert (2.2.15; 16; 17) ....
Das neue Boart ist ein DFI mit VIA Chipsätzen, wenn das irgendwie helfen sollte ...

Danke für die Hilfe schonmal in vorraus ...

Benjamin Kl.
 

fungs
Gast





BeitragVerfasst am: 13. Okt 2000 5:02   Titel: Re: Probleme mit den RAMs ...

Der Artikel+Kommentare!! unter Kurztips auf dieser Seite sagt es sehr treffend und duerfte fuer dich interessant sein.

Kurz gesagt:
http://www.pro-linux.de/kurztips/11.html

Ich hoffe das war es, was du gesagt hast und da bin ich auch schon wieder froh, jemandem geholfen zu haben...
 

Michael Flaig
Gast





BeitragVerfasst am: 13. Okt 2000 6:29   Titel: Re: Probleme mit den RAMs ...

Ich denke, dass das Problem mit den Speicherzugrifsfehlern hier wichtiger ist.
Was Benjamin meinte: Wenn Programme ausgeführt wird, dann stürzen diese oft mit deinem segmentation fault (speicherzugriffsfehler) ab. Das passiert auch beim booten des Systems, wenn die initscript laufen. Aber auch bei ls und mount und so dingen ... Also ich komm da nichtmehr weiter ... Ram defekt denk ich eigentlich nicht, da das Windows auch beim Zocken nicht abstürzt, wenn viel last auf dem Hauptspeicher ist.
Gruß, Michael
 

hendrik
Gast





BeitragVerfasst am: 13. Okt 2000 7:47   Titel: Re: Probleme mit den RAMs ...

hai
versucht es mal mit einem eintragen in der lilo.conf.
fuegt eine zeile < append mem=128M > ein.
ob append richtig geschrieben ist weiss ich jetzt nicht
bei mir hats auf jedenfall geklappt
160Mchen
es wurden vor her auch nur 64M erkannt.
probierts mal aus.
ciao hendrik
 

hendrik
Gast





BeitragVerfasst am: 13. Okt 2000 7:55   Titel: Re: Probleme mit den RAMs ...

speicher zugriffsfehler?
da wird irgendwo ein array ziemlich ueberlastet, nicht gelöscht mehrfach angesprochen überlagert oder so
meist hängt dies mit einem programm zusammen welches einen bug intus hat, oder irgendwo ist etwas bei der installation
schief gegangen und es kommt zu überlagerungen im speicher.
im notfall alles sichern und von vorn, und das währe hart.
versucht es dann erstmal mit einer mini installation und baut dann langsam auf.
 

Jochen
Gast





BeitragVerfasst am: 13. Okt 2000 9:28   Titel: Re: Probleme mit den RAMs ...

Lad Dir http://reality.sgi.com/cbrady_denver/memtest86/memtest86-2.4.tar.gz runter (ist auch auf tomsrtbt) und boote von der damit erstellten Diskette. Ist m.E. einer der gründlichsten Speichertester. Wenn der meckert, ist es schlechtes RAM, egal, was Win sagt... Vielleicht hast Du ja auch die Reihenfolge der Riegel im Board geändert, und der schlechte Riegel wird jetzt mehr gestresst?
 

hjb
Pro-Linux


Anmeldungsdatum: 15.08.1999
Beiträge: 3236
Wohnort: Bruchsal

BeitragVerfasst am: 13. Okt 2000 10:07   Titel: Re: Probleme mit den RAMs ...

Hi,

Windows ist kein ernstzunehmender Testfall. Wenn Programme unter Linux abstürzen an ständig wechselnden Adressen, ist entweder das RAM defekt oder der Rechner wird zu warm. Ein paar zusätzliche Lüftungslöcher im Gehäuse können helfen. Oder die Versorgungsspannung der CPU um 0.1V erhöhen.

Gruß,
hjb
_________________
Pro-Linux - warum durch Fenster steigen, wenn es eine Tür gibt?
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen MSN Messenger

Benjamin Klöpfer
Gast





BeitragVerfasst am: 14. Okt 2000 17:57   Titel: Re: Probleme mit den RAMs ...

Erstmal danke für eure Hilfe, ich werde das alles soweit mal ausprobieren.

Und HJB, mein Gehäuse ist IMMER offen, zu warm kann alsi nicht sein, und mit der Volt erhöhung, ... ich werds probieren ....

Der Tip mit dem Mentestprogramm, ich kann nicht kompilieren, immmer Seg.-faults...

und Danke nochmal an alle die mir geolfen haben ...

Benjamin Kl.
 

hendrik
Gast





BeitragVerfasst am: 15. Okt 2000 19:13   Titel: Re: Probleme mit den RAMs ...

es geht weiter
das mit dem RAM lässt sich loesen, davon gehe ich aus.
Diese Speicherzugriffsfehler treten bei mir nun auch auf.
Unten ist die Ausgabe des Versuches den Gimp zu compilieren. Dies tritt immer beim make auf.
Bei der Kernel compilierung ebenfalls nur das dann noch ein Speicherzugriffsfehler gemeldet wird. Der gcc bricht aber mit identischer Fehlermeldung < fatal signall 11 > ab.
Was ich beim durchlaufen beobachtet habe ist das wie wild zwischen array's hin und her gesprungen wird. Nun waren die Partionen ehemals mit reisersfs formatiert, ich hatte diese dann wieder auf ext2fs umformartiert.
Könnte das damit zu tun haben?
Vieleicht sind ja irgendwo Reste vorhanden mit denen der Compieler nichts anfangen kann?
Oder aber könnte etwas im Speicher hängen geblieben sein?
Oder hat sich im gcc ein Fehler eingeschlichen, wovon ich aber nicht ausgehe.
< gcc version 2.95.2 19991024 (release) >

Hier nun die Ausgabe (wüüürg)
Next token is 123 ('{')
gcc: Internal compiler error: program cc1 got fatal signal 11
make: *** [print-pcl.o] Error 1
make: Leaving directory `/usr/share/gimp/gimp-1.1.27/plug-ins/print'
make: *** [all-recursive] Error 1
make: Leaving directory `/usr/share/gimp/gimp-1.1.27/plug-ins'
make: *** [all-recursive] Error 1
make: Leaving directory `/usr/share/gimp/gimp-1.1.27'
make: *** [all-recursive-am] Error 2

Wie gesagt ähnliche Meldungen bekomme ich auch an anderer Stelle!

hendrik
 

Jochen
Gast





BeitragVerfasst am: 16. Okt 2000 9:43   Titel: Re: Probleme mit den RAMs ...

Der Signal-11-"Bug" ist bekannt und schon ein FAQ: Schlechter Speicher. Der gcc scheint ein hervorragender Stresstest für speicherriegel zu sein... Wenn Du memtest86 nicht kompilieren kannst, zieh Dir die vorkompilierte Version für Win runter. Das Zipfile einfach auspacken und die Datei memtest.bin auf Floppy packen:
cat memtest.bin >/dev/fd0

Booten und dem Rechner beim Testen zugucken...
 

Jochen
Gast





BeitragVerfasst am: 16. Okt 2000 9:45   Titel: Re: Probleme mit den RAMs ...

Nachtrag: Das Sig11-FAQ findest Du unter http://www.bitwizard.nl/sig11/

Hoffentlich hilft's!
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Sonstiges Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy