Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Zerhauene Swap Partition ?!?

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Sonstiges
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Sven
Gast





BeitragVerfasst am: 12. Dez 2000 19:56   Titel: Zerhauene Swap Partition ?!?

Hi,
ich hab vor kurzem "versucht" Windoof 2000 auf meiner primären Platte zu installieren. Als ich den Rechner nach der installation neu startete, schmierte Windows 2000 beim start ab (typisch Micro$oft *g*) und Linux startete auch nicht mehr *hilfe*.

Ich hab die Platten mehrmals formatiert und ein Ghost-Image meiner Linux Platte (ein 1:1 Abbild der KOMPLETTEN HD) draufgespielt. Aber nix funzt. Beim boot per Bootmanager kommt die Meldung "Error 1x0". Und beim boot per Boot-Disk kommt die Meldung "Checking Swap in /etc/fstab FAILED" (<- oder so ähnlich). Danach bleibt alles hängen.

Linux ist auf der zweiten Platte (3,1 GB) und Windows auf der ersten (4,1 GB). Z.z. hab ich nen älteres WinME image drauf, aber ich würd natürlich liebend gern wieder mein Linux haben (und Windows in VMware einsperren, wie bisher *g*)

Wäre nett, wenn mir hier jemand helfen kann, da ich keien Lust hab meine gesamten Daten zu verlieren.....

Thanx,
Sven
 

Klaus2
Gast





BeitragVerfasst am: 13. Dez 2000 3:18   Titel: Re: Zerhauene Swap Partition ?!?

Hallo,

> .. (typisch Micro$oft *g*) ..

.. typisch Linuxuser.

Mal sehen ob ich das richtig verstanden habe.
Linux ist und war auf der zweiten Platte?
Wurde aber mit Ghost nochmal auf der selben Platte eingespielt?
Auf der Ersten wurde Win2k inst. und dann durch WinMe ersetzt?
Bootmanager ist lilo?

Mögliche Probleme:
Lilo war event. im MBR der ersten Platte und wurde durch die
Win-Inst. gelöscht. Die akt. Part. ist falsch.
Durch Ghost ist die Pos. des Kernels bzw. der initrd anders
oder die Partitionen haben jetzt andere Nummern.

(.. ich kenne Ghost nicht so genau.. ist mit 1:1 gemeint, daß Ghost Sekt.
für Sekt. der zweiten Platte in ein Image kopiert hat und dieses wieder
Sekt. für Sekt. auf die gleiche Platte zurückkopiert hat? Oder kann Ghost
wie z.B. DI die Part. auf eine andere Platte kopieren und auch die
Sekt.-Verweise anpassen?)

Event. Lösung:
Mit einem Linux Rettungssystem starten. Dann für z.B. zwei IDE-Platten
mit "fdisk /dev/hda" und "fdisk /dev/hdb" die tatsächlichen Part.-Nummern
nachsehen. Stimmen die aktiven Part. auch?
Dann die Linux-Root-Part. z.B. bei /mnt in das Dateisystem einhängen.
Mit "cat /mnt/etc/fstab" nachsehen ob die Angaben in der fstab noch richtig
sind. Notfalls mit vi anpassen.
Nun noch schauen ob die Einstellungen in /mnt/etc/lilo.conf richtig sind und
auch korrigieren.
Wenn dann alles IO ist mit der Disk starten (root="die Root-Part. der Platte")
Jetzt sollte es funkt.. Um dann über die Platte zu starten muß lilo wieder mit
"lilo" reinst. werden. (Ist was in der lilo.conf falsch könnte es was "zerlegen"!)
Nach dem nächsten Start sollte alles wieder funkt.
(.. ist die Swap-Signatur noch IO? Event. mit mkswap neu erstellen.)

MfG
Klaus2
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Sonstiges Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy