Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
soundkarte ??!

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Sonstiges
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
cerberusger



Anmeldungsdatum: 28.12.2000
Beiträge: 348
Wohnort: Muenchen

BeitragVerfasst am: 22. Jan 2001 11:47   Titel: soundkarte ??!

hallo jungs und maedels.

heut hat's mich gepackt, und ich wollt ne soundkarte (sb64pci mit dem es1370 chipsatz) in meinen rechner einbauen.

dann hab ich verschiedene anleitungen dazu gelesen (unter anderem auch die auf pro-linux unter tips), und mir einen neuen kernel gebaut.

ich hab folgendes eingebaut:

<M> Sound Card Support
.
<M> Ensoniq AudioPCI (ES1370)
.
<M> OSS sound modules
.
<M> 100% Sound Blaster compatibles (SB16/32/64, ESS, Jazz16) support
<M> Generic OPL2/OPL3 FM synthesizer support
.
<M> FM synthesizer (YM3812/OPL-3) support



compilieren tut er alles ohne fehler (das sind die einzigen module, der rest is alles fest einkompiliert, hat auch nie probs gemacht, nur der $^&$(&#%*$ sound-support treibt mich zum wahnsinn)

nach dem kompilieren hab ich dann die alten modules geloescht und die neuen via make modules_install installiert.

soweit so gut.

nun noch schnell den neuen kernel kopieren, system.map austauschen und lilo konfiguriert...

und dann kommts:

beim reboot erhalte ich dann tausend 'unresolved symbols':

[root@redhat ~]# depmod -a
/lib/modules/2.2.12-32smp/misc/uart401.o: unresolved symbol(s)
/lib/modules/2.2.12-32smp/misc/sound.o: unresolved symbol(s)
/lib/modules/2.2.12-32smp/misc/sb.o: unresolved symbol(s)
/lib/modules/2.2.12-32smp/misc/es1370.o: unresolved symbol(s)


natuerlich kann er so auch die soundkarte net ansprechen. sndconfig verreckt beim abspielen des test-sounds wegen der module, die net geladen werden koennen...
jetzt stellt sich die frage: wie kriege ich dem mist los ?? vor diesem sound-abenteuer hat immer alles praechtig funktioniert, aber seit dem ... &^$*&(#(%*(*&%&$#(*&

waere fuer jeden tipp dankbar ...

g.feiner
_________________
Linux is a wigwam - no windows, no gates, apache inside <img src="http://www.pl-forum.de/UltraBoard/Images/Happy.gif" border="0" align="middle">
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

Peter
Gast





BeitragVerfasst am: 22. Jan 2001 12:34   Titel: Re: soundkarte ??!

Also,
ich mache das mit dem Sound immer so:
Im Kernel nur den es1370 als module, sonst nichts. Dann schaust du, ob du noch irgent so ein init script am laufen hast, das beim hochfahren den Sound aktivieren will (ALSA oder so), das löscht du.
Dann trägst du in /etc/modules.conf ein:
char-major-14 es1379
ein.
Fals irgendwo char-major-14 off steht, diese Zeile löschen.

Happy sounding !
 

cerberusger



Anmeldungsdatum: 28.12.2000
Beiträge: 348
Wohnort: Muenchen

BeitragVerfasst am: 22. Jan 2001 17:13   Titel: Re: soundkarte ??!

das werd ich gleich mal testen. danke erstmal
_________________
Linux is a wigwam - no windows, no gates, apache inside <img src="http://www.pl-forum.de/UltraBoard/Images/Happy.gif" border="0" align="middle">
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

cerberusger



Anmeldungsdatum: 28.12.2000
Beiträge: 348
Wohnort: Muenchen

BeitragVerfasst am: 22. Jan 2001 18:31   Titel: Re: soundkarte ??!

mmh, hat leider net funktioniert. hab nur das es1370er modul und soundcore.o compiliert. er sagt mit immer noch die gleichen fehler, nur hab ich jetzt bei der manuellen soundkarten-config (nachdem die automatische fehlgeschlagen ist) nur noch eine (naemlich die 1370) zur auswahl :(


/lib/modules/2.2.12-32smp/misc/es1370.o: unresolved symbol synchronize_irq

/lib/modules/2.2.12-32smp/misc/es1370.o: unresolved symbol waitqueue_lock


ach ja, btw, ich hab redhat 6.1
_________________
Linux is a wigwam - no windows, no gates, apache inside <img src="http://www.pl-forum.de/UltraBoard/Images/Happy.gif" border="0" align="middle">


Zuletzt bearbeitet von cerberusger am 22. Jan 2001 18:31, insgesamt 1-mal bearbeitet
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Sonstiges Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy