Debian 2.2r2 und PHP3

Antworten
Nachricht
Autor
Matus

Debian 2.2r2 und PHP3

#1 Beitrag von Matus » 24. Mär 2001 20:12

Hallo

Ich bekomme PHP3 unter Debian 2.2 r2 nicht zum Lauufen. Der Server nimmt einfach keine PHP3-Dateien an, so als wäre das PHP3-Modul nicht geladen. Bei Deb-Bug-Report kann ich nichts besonders zu dem Thema finden. Hat jemand ähnliche Erfahrungen bei Deb und PHP3 gemacht? Vielleicht hat jemand sonst noch einen Tip für mich.
Apache lüpt ansonsten problemlos, nur php3 nicht.
Gruss
Matus

Andi

Re: Debian 2.2r2 und PHP3

#2 Beitrag von Andi » 24. Mär 2001 23:08

Hi,

hast du in der /etc/apache/srm.conf die Zeilen

AddType application/x-httpd-php .php .php3
AddType application/x-httpd-php-source .phps

auskommentiert?
Apache neustarten und es sollte gehen.

Bei Debian 2.2 kannst du übrigens auch gleich PHP4 installieren (apt-get install php4).


Andi

Andi

Re: Debian 2.2r2 und PHP3

#3 Beitrag von Andi » 24. Mär 2001 23:08

Hi,

hast du in der /etc/apache/srm.conf die Zeilen

AddType application/x-httpd-php .php .php3
AddType application/x-httpd-php-source .phps

auskommentiert?
Apache neustarten und es sollte gehen.

Bei Debian 2.2 kannst du übrigens auch gleich PHP4 installieren (apt-get install php4).


Andi

Matus

Re: Debian 2.2r2 und PHP3

#4 Beitrag von Matus » 25. Mär 2001 12:00

hallo

ersteinmal danke, aber ich in der datei die entsprechenden einträge auskommentiert (srm.conf ist allerdings leer, bei mir ist es die httpd.conf).
und auch die LoadMudole ... libphp3.so ist auskommentiert. ich habe auch mit der --purge option alles entfernt und neu installiert, trotzdem lädt apache keine php3-dateien. sonst noch mal einen tip?

wenn ich mit insmod /usr/lib/apache/1.3/libphp3.so lade erhalte ich einen ELF-Fehler, ELF ist aber fest in den kernel integriert!

mfg matus

Sebastian Ude

Re: Debian 2.2r2 und PHP3

#5 Beitrag von Sebastian Ude » 25. Mär 2001 12:05

>wenn ich mit insmod /usr/lib/apache/1.3/libphp3.so lade

Naja, das konnte auch unmöglich gutgehen. Oder ist libphp3.so ein Kernel-Modul ?


Folgende Frage:

Hast du die php3-Scripts im cgi-bin-Ordner ?
Falls ja, pack sie mal bitte *nicht* in den cgi-bin Ordner (sondern irgendwo unter htdocs) und probier es dann erneut.

Matus

Re: Debian 2.2r2 und PHP3

#6 Beitrag von Matus » 26. Mär 2001 8:12

Hallo

nach --purge und neuinstallieren lüpt es wieder

Danke
Matus

Antworten