Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
X-Server geht nicht als normaler User

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Sonstiges
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Lotussteve
Gast





BeitragVerfasst am: 24. Apr 2001 13:03   Titel: X-Server geht nicht als normaler User

Hallo!

Hab ein von 6.2 auf 7.0 upgedatetes SuSE zur Betreuung bekommen und hab folgendes Problem:

Als root wird X und GNOME ganz normal gestartet, keine Fehlermeldungen.

Als normaler User kommt er bis zum grauen Bildschirm und der x-MAus, dann bricht er mit drei ICEauth-Meldungen , z.B. cannot create listener ab. Ein File .ICEauthority oder .Xatuhority ist nicht vorhanden, wird aber weder beim Neuanlegen des USers oder startx (wie bei meinen SuSE und Progeny daheim) angelegt.
Ein Kopieren des .ICEauthority von root nach /home/username hat (natürlich) auch nicht geholfen!

Die sdb.suse.de schweigt sich aus, weiß jemand von euch bitte Rat, ohne daß ich es neuaufsetze(unbekannte/alte HW,DAU als Besitzer)??

Besten Dank im voraus,

Ciao,

Steve
 

Anonymous
Gast





BeitragVerfasst am: 24. Apr 2001 13:29   Titel: Re: X-Server geht nicht als normaler User

Trag die User doch in die Gruppe xok ein.
(yast --> Admin.. --> Gruppenverwaltung)
 

Simon
Gast





BeitragVerfasst am: 27. Apr 2001 11:09   Titel: Re: X-Server geht nicht als normaler User

Hallo, du hast progeny??
Ich wollte da einen user hinzufügen, habe aber kein grafisches tool gefunden und deshalb adduser (auf der console) genommen! jetzt kann ich mich nur noch als root anmelden! (grafische Anmeldung) sonst muss ich auf die console wechseln(strg+alt+F1) und kann mich als norm. user anmelden, habe aber kein x server zur verfügung, weil der noch läuft und ich den nur mit halt und reboot beenden kann!
Kann mir jemand helfen??
*verzweifel* Simon
 

lotussteve



Anmeldungsdatum: 20.04.2001
Beiträge: 2
Wohnort: Sbg.

BeitragVerfasst am: 27. Apr 2001 22:21   Titel: Re: X-Server geht nicht als normaler User

Hallo!

Ok, hab das Problem mit Hilfe von Telsa und einigen anderen GNomern gelöst: Der alte Pc hatte die Rechte ziemlich obskur vergeben, ich glaub bei dem alten System war Gnome 1.0.52 oder so aktuell. Musste nur Schreibrechte gewähren in /tmp/ICE-unix/ und voila, es geht, Aber das mal finden.... !


@Simon:

Hast du es schon mit linuxconf probiert? Adduser ruf am besten mit -m -d /home/$USERNAME auf.
Mehr kann ich da leider nicht sagen.


Ciao,

Steve
 
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen

Simon
Gast





BeitragVerfasst am: 28. Apr 2001 16:07   Titel: Re: X-Server geht nicht als normaler User

Hallo, danke für den tipp, aber habe mit deluser den user gelöscht! und danach mit adduser (ohne option) neu angelegt, genau so wie vorher!! neu angemeldet und jetzt klappts! aals ich mienen account löschen wollte erhielt ich einen fehlercode 8 (mein account habe ich nei der Progeny istallation angelegt!)!!
Evtl war ich noch auf einer console eingeloggt, war mir icht sicher muss aber eigentlich daran liegen,...
kann mir jemand sagen wie ich das Grafische Booten ausstellen kann?
Oder wie ich einen Treiber für mein DVD LW finde (Suse un Redhat sowei mandrake (und debian!!) haben es erkannt!)
und einbinde (kammt der einfach ins verzeichnis /dev/ und wird als modul geladen?
gibt es dazu dokus?
Achso, linuxconf kennt mein system nich! Installieren kann ich auch nichts, weil er immer einen fehler mit der initialisierung von apt cache hat! kann ich anders pakete einspielen?
Danke fürs lesen, Simon
 

Lotussteve
Gast





BeitragVerfasst am: 29. Apr 2001 23:07   Titel: Re: X-Server geht nicht als normaler User

Hallo!

Ende des graf. Booten: Einfach in der /etc/inittab den defaultrunlevel von 3 auf 2, oder /etc/init.d/rc3.d/ von SXXgdm auf KXXgdm (XX=Prioritätszahl)

Treiber für DVD-LW brauchst nicht, wenn es ein ATAPI ist einfach das entsprechende /dev/hdX in die /etc/fstab, bei SCSI /dev/sdX. Probier mal "mount -tiso9660 /dev/hdX /dvd" oder in welches Verzeichnis du halt willst.So etwas wie TReiber gibt es in dem Zusammenhang nicht, die GErätedatie sollte vorhanden sein (war bei meinem Pioneer A05SZ so, war Secondary Slave --> /dev/hdd und wird als /dvd gemountet!)

Beim Aufruf von apt-setup oder apt-get update musst du natürlich eine funktionierende Internetverbindung haben, da die Hälfte der Einträge in der /etc/apt/sources.list ja Server von Progeny oder Debian sind. Linuxconf ist bei Newton nicht dabei, sondern in Debian Stable!

Hoffe etwas geholfen zu haben,

Ciao,

Steve
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Sonstiges Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy