Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
X läuft nicht mehr als User

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Sonstiges
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Andi
Gast





BeitragVerfasst am: 11. Jun 2001 17:53   Titel: X läuft nicht mehr als User

Hi,

seit ich mein X auf 4.0.3 upgedated habe kann ich es nur noch als root starten.

Wenn ich xinit oder startx als normaler User eingebe erhalte ich folgende Fehlermeldung:

X: user not authorized to run the X server, aborting.
xinit: unexpected signal 2

Mit XFree 4.0.2 lief es noch.

Andi
 

Sebastian Ude
Gast





BeitragVerfasst am: 11. Jun 2001 18:11   Titel: Re: X läuft nicht mehr als User

Mach mal ein

ls -l /usr/X11R6/bin/XFree86

ist das setuid-Bit gesetzt ?

Falls nicht, dürfte ein

chmod u+s /usr/X11R6/bin/XFree86

das beheben.
 

Andi
Gast





BeitragVerfasst am: 11. Jun 2001 18:59   Titel: Re: X läuft nicht mehr als User

Hi,

XFree86 war nicht setuid.
Ich hab das Bit gesetzt und den Rechner
neugestartet.

Geht leider trotzdem nicht Sad
Selbe Fehlermeldung.
Gibt es noch weitere Programme die das
setuid Bit benoetigen?

Gruss,

Andi
 

Sebastian Ude
Gast





BeitragVerfasst am: 11. Jun 2001 21:27   Titel: Re: X läuft nicht mehr als User

Wie sieht denn deine aktuelle /etc/X11/xserver/SecurityPolicy aus ?
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Sonstiges Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy