Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Inst.-Problem glib

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Sonstiges
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
hendrik
Gast





BeitragVerfasst am: 26. Sep 2001 13:20   Titel: Inst.-Problem glib

versuche gerade ein paar Programme zu installieren, funktioniert aber nicht.
Darunter XFCE-3.8.8 (3.8.7 läuft wunderbar).
configure wird abgebrochen mit folgenden Worten:

---- Schnipp -----

checking for scandir... yes
checking for glib-config... /usr/bin/glib-config
checking for GLIB - version >= 1.2.6... no
*** Could not run GLIB test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GLIB was incorrectly installed
*** or that you have moved GLIB since it was installed. In the latter case, you
*** may want to edit the glib-config script: /usr/bin/glib-config
configure: error: Cannot find GLIB: Is glib-config in path?

---- Schnapp ----

Die glib-version ist 1.2.8
glib-conf liegt dort, wo sie sein soll.

was tun?

Ach ja SuSE7.1 kern 2.4.7

gruss hendrik
 

Sebastian Ude
Gast





BeitragVerfasst am: 26. Sep 2001 13:35   Titel: Re: Inst.-Problem glib

Poste mal bitte die letzten 5 bis 10 Zeilen aus der config.log.
 

hendrik
Gast





BeitragVerfasst am: 26. Sep 2001 20:54   Titel: Re: Inst.-Problem glib

Wie gewünscht

---- Zapp -----


printf("
*** An old version of GLIB (%d.%d.%d) was found.
",
glib_major_version, glib_minor_version, glib_micro_version);
printf("*** You need a version of GLIB newer than %d.%d.%d. The latest v
major, minor, micro);
printf("*** GLIB is always available from ftp://ftp.gtk.org.
");
printf("***
");
printf("*** If you have already installed a sufficiently new version, th
printf("*** probably means that the wrong copy of the glib-config shell
printf("*** being found. The easiest way to fix this is to remove the ol
printf("*** of GLIB, but you can also set the GLIB_CONFIG environment to
printf("*** correct copy of glib-config. (In this case, you will have to
printf("*** modify your LD_LIBRARY_PATH enviroment variable, or edit /et
printf("*** so that the correct libraries are found at run-time))
");
}
}
return 1;
}

configure:9349: gcc -o conftest -g -O2 -I/usr/lib/glib/include -I/usr/X11R6/inc
In file included from /usr/include/bits/posix1_lim.h:126,
from /usr/include/limits.h:144,
from /usr/lib/gcc-lib/i486-suse-linux/2.95.2/include/limits.h:1
from /usr/lib/gcc-lib/i486-suse-linux/2.95.2/include/syslimits.
from /usr/lib/gcc-lib/i486-suse-linux/2.95.2/include/limits.h:1
from /usr/lib/glib/include/glibconfig.h:13,
from /usr/include/glib.h:66,
from configure:9341:
/usr/include/bits/local_lim.h:36: linux/limits.h: No such file or directory
configure: failed program was:
#line 9339 "configure"
#include "confdefs.h"

#include <glib.h>
#include <stdio.h>

int main() {
return ((glib_major_version) || (glib_minor_version) || (glib_micro_version));
; return 0; }

---- Zerapp ----

gruss hendrik
 

Eremit
Gast





BeitragVerfasst am: 26. Sep 2001 21:01   Titel: Re: Inst.-Problem glib

kannst du nicht die kommandozeile ändern?

./configure --with-glib-prefix=/usr/lib

oder so ähnlich.
vielleicht mal etwas testen.

Eremit
 

hendrik
Gast





BeitragVerfasst am: 26. Sep 2001 21:12   Titel: Re: Inst.-Problem glib

Hatte ich schon ausprobiert.
Ich habe den dumpfen Verdacht, dass nach einem Grafikkarten wechsel (NVidia TNT2) und das kompilieren der nötigen Software der Fehler erst auftritt.
Also seit letzter Woche, bin mir aber nicht so sicher.
Via Yast lässt sich leider nicht ein update auf GLIB 1.2.10 durchführen, da werde ich mit Fehlermeldungen nur so überhäuft.
Was ich machen könnte wäre die tars (gtk & glib) zu nutzen, nur wo muss ich diese instalieren und was muss ich dabei beachten.
In erster Linie wäre mir mit einer Fehlerbehebung wesentlich mehr gedient.

gruss
hendrik
 

Eremit
Gast





BeitragVerfasst am: 26. Sep 2001 21:33   Titel: Re: Inst.-Problem glib

ich denke nicht, dass es an der grafikkarte liegt.
installiere doch die glib neu. dann aber mit einem ./configure --with-prefix=...
danach ein "make" und ein "make install"
dann weißt du genau wo die dateien sind. dann kannst du auch, wie oben beschrieben das configure von XFCE mit dem ./configure --with-glib=....... angeben.

auf yast würde ich ganz verzichten. lieber das tar-archiv entpacken mit tar xzvf glib-1.2....


Eremit
 

Sebastian Ude
Gast





BeitragVerfasst am: 27. Sep 2001 13:20   Titel: Re: Inst.-Problem glib

Leute - der Fehler liegt da und nirgends wo anders (deswegen will ich bei soetwas ja auch immer config.log-Auschnitte sehen):

> /usr/include/bits/local_lim.h:36: linux/limits.h: No such file or directory

Dir fehlen einfach die Kernel-Headers !

Das ist fatal, weil die GTK-Headers die glib-Headers, die glib-Headers die libc-Headers, und die libc-Headers wiederum die Kernel-Headers includen, und wenn letztere fehlen => boing.


Hast du bei SuSE deinen Kernel selber compiliert ?

Wenn ja, denk daran, dass /usr/include/linux ein Symlink auf /wo/immer/der/Kernel/liegt/linux/include/linux und /usr/include/asm analog ein Symlink auf /wo/immer/der/Kernel/liegt/linux/include/asm sein muss.

Wenn du den Standard-SuSE-Kernel benutzt, ist höchstwahrscheinlich einfach das Paket, welches die Kernel-Headers beinhaltet nicht installiert.
 

Christian Roessner
Gast





BeitragVerfasst am: 28. Sep 2001 13:54   Titel: Re: Inst.-Problem glib

Hast Du glib-devel und gtk-devel installiert? Probiers dann nochmal.
 

Sebastian Ude
Gast





BeitragVerfasst am: 28. Sep 2001 14:03   Titel: Re: Inst.-Problem glib

> Hast Du glib-devel und gtk-devel installiert? Probiers dann nochmal.

Dann würde der Compiler ja wohl kaum sagen, dass Header-Files von glib.h (was zu glib-devel gehört) included werden.

Würden die GTK-Headers fehlen, käme auch eine andere Meldung.

Ich bin mir zu 99.9 % sicher, dass das Problem an den fehlenden Kernel-Headers liegt.
 

Sebastian Ude
Gast





BeitragVerfasst am: 28. Sep 2001 14:04   Titel: Re: Inst.-Problem glib

Dann = Falls nicht
 

hendrik
Gast





BeitragVerfasst am: 28. Sep 2001 15:33   Titel: Re: Inst.-Problem glib

na, na
erstmal ist es ein SuSE Kernel.
Ich bin gerade am durchchecken.
Die Probs traten wirklich erst nach einspielen der neuen nvidia Software auf. Xfce 3.8.7 hat sich ja noch anstandslos instalieren lassen.
Wo kann ich die fehlenden header Dateien finden?
Muss ich den Kernel neu instalieren oder kann ich die auch durch einen Patch irgendwie wieder hinzufügen?
Wenn ja, welcher patch oder wie heisst die Datei?
 

Sebastian Ude
Gast





BeitragVerfasst am: 28. Sep 2001 16:00   Titel: Re: Inst.-Problem glib



/usr/include/bits/local_lim.h:36: linux/limits.h: No such file or directory


Diese Meldung ist nun mal eindeutig.


> Die Probs traten wirklich erst nach einspielen der neuen nvidia Software auf.

Unwahrscheinlich ... hast du sonst noch irgendetwas mit dem Kernel angestellt ?

Mal ein paar Fragen:

  • Existieren /usr/include/linux und /usr/include/asm ?
  • Falls ja, sind es Symlinks ?
  • Sofern letzteres zutrifft, auf welche Verzeichnisse (oder sind es evtl. ungültige Links ?) bzw. was beinhalten diese ?
  •  

    hendrik
    Gast





    BeitragVerfasst am: 28. Sep 2001 17:07   Titel: Re: Inst.-Problem glib

    prob. gelöst,
    nach längerem Nachdenken fiehls mir wie Schuppen voan den Augen.
    Ich hatte nur den i386_kernel geladen und konfiguriert.
    Habe mir dann den deflt_kernel gesogen kompiliert und es funzte.
    Die quellen haben gefehlt, kann dann ja nicht laufen. schon peinlich.
    trotzdem an alle vielen Dank für Mühe und Aufregung, Gedult und Kopfschütteln.
    gruss
    hendrik
     

    Beiträge vom vorherigen Thema anzeigen:   
         Pro-Linux Foren-Übersicht -> Sonstiges Alle Zeiten sind GMT + 1 Stunde
    Seite 1 von 1

     
    Gehen Sie zu:  

    Powered by phpBB © phpBB Group
    pro_linux Theme © 2004 by Mandaxy