Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
meine natürlich aviplay

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Sonstiges
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
krustyhill
Gast





BeitragVerfasst am: 28. Sep 2001 7:58   Titel: meine natürlich aviplay

 

Sebastian Ude
Gast





BeitragVerfasst am: 28. Sep 2001 13:29   Titel: Re: meine natürlich aviplay

Macht nichts.

Meine Antwort bzgl. des Problems findest du im ursprünglichen Thread:

http://www.pl-forum.de/cgi-bin/UltraBoard/UltraBoard.pl?Action=ShowPost&Board=010&Post=2690
 

MG
Gast





BeitragVerfasst am: 28. Sep 2001 16:39   Titel: Re: meine natürlich aviplay

Hallo Sebastian,

ich verwende Mandrake 8.1 beta3.
Wenn ich versuche, bei aviplay ./configure auszuführen (autogen.sh habe ich erledigt), kommt die Meldung, SDL >= version 1.1.3 sei nicht installiert, ich habe jedoch libSDL v. 1.2.3 und SDL-Mixer 1.2.3 installiert, auch mit ./configure --prefix /usr/lib, unter dem bei Mandrake die Libraries liegen, war ich nicht erfolgreich.
Weisst Du Rat?
Danke für Deine Bemühungen

Gruß

Matthias
 

Sebastian Ude
Gast





BeitragVerfasst am: 28. Sep 2001 21:05   Titel: Re: meine natürlich aviplay

Du hast SDL installiert (SDL_mixer tut, was avifile angeht, nichts zur Sache), aber auch das *-devel Paket (wenn wir jetzt von RPMs reden) ?

Falls nein, hast du das Problem gefunden.

Falls ja, wären die letzten ~ 10 Zeilen aus der config.log interessant.
 

MG
Gast





BeitragVerfasst am: 30. Sep 2001 9:09   Titel: Re: meine natürlich aviplay

Hallo Sebastian,
ich habe gestern nochmals alles, was mir zu SDL unter die Finger gekommen ist, nachinstalliert und nochmals ./configure-ausgeführt, selbes Ergebnis.
Hier die letzten Zeilen aus config.log:

int main() {
DPMSQueryExtension()
; return 0; }
configure:9122: checking for XGetExtensionVersion in -lXi
configure:9144: c++ -o conftest -g -O2 -march=i586 -pipe -I/usr/lib/qt2/include -I/usr/X11R6/include -g -O2 -march=i586 -pipe -I/usr/lib/qt2/include -I/usr/X11R6/include -L/usr/X11R6/lib -L/usr/lib/qt2/lib conftest.C -lXi -L/usr/X11R6/lib -lX11 -lXext -lpthread -lnsl -ldl -lm 1>&5
configure:9183: checking for X11/Xft/Xft.h
configure:9200: c++ -c -g -O2 -march=i586 -pipe -I/usr/lib/qt2/include -I/usr/X11R6/include -g -O2 -march=i586 -pipe -I/usr/lib/qt2/include -I/usr/X11R6/include conftest.C 1>&5
configure:9212: checking for XftDrawString32 in -lXft
configure:9234: c++ -o conftest -g -O2 -march=i586 -pipe -I/usr/lib/qt2/include -I/usr/X11R6/include -g -O2 -march=i586 -pipe -I/usr/lib/qt2/include -I/usr/X11R6/include -L/usr/X11R6/lib -L/usr/lib/qt2/lib conftest.C -lXft -L/usr/X11R6/lib -lX11 -lXext -lXft -lpthread -lnsl -ldl -lm 1>&5
configure:9262: checking for X11/extensions/Xv.h
configure:9280: c++ -c -g -O2 -march=i586 -pipe -I/usr/lib/qt2/include -I/usr/X11R6/include -g -O2 -march=i586 -pipe -I/usr/lib/qt2/include -I/usr/X11R6/include conftest.C 1>&5
configure:9322: checking for X11/extensions/dpms.h
configure:9337: c++ -c -g -O2 -march=i586 -pipe -I/usr/lib/qt2/include -I/usr/X11R6/include -g -O2 -march=i586 -pipe -I/usr/lib/qt2/include -I/usr/X11R6/include conftest.C 1>&5
configure:9354: checking whether system declares DPMS functions in X11/extensions/dpms.h
configure:9369: c++ -c -g -O2 -march=i586 -pipe -I/usr/lib/qt2/include -I/usr/X11R6/include -g -O2 -march=i586 -pipe -I/usr/lib/qt2/include -I/usr/X11R6/include conftest.C 1>&5
configure:9424: checking for sdl-config
configure:9424: checking for sdl11-config
configure:9500: checking for sdl-config
configure:9535: checking for SDL - version >= 1.1.3

Danke für Deine Hilfe

Matthias
 

Sebastian Ude
Gast





BeitragVerfasst am: 30. Sep 2001 10:40   Titel: Re: meine natürlich aviplay

Hmm.

Wenn die sdl-config nicht gefunden wird, ist SDL auch nicht installiert, oder die sdl-config befindet sich nicht in einem Verzeichniss, das in $PATH gelistet ist.

Und damit kommen wir zu einem sehr populären Problem:

Du hast SDL oder eine andere Library selber compiliert, und wegen den Defaults wird sie nach /usr/local geschmissen.

Soweit alles in Ordnung.

Leider gibt es Leute die immer im "su"-Modus compilieren, obwohl das nicht nötig ist (nur für das "make install" braucht man root-Rechte, für alles davor in der Regel nicht).

Im su-Modus ist der $PATH aber beschnitten und enthält unter anderem nicht /usr/local/bin, folglich wird das von der Library zuvor nach /usr/local/bin installierte *-config Script nicht gefunden.

Boing.

Ich weiss nicht ob das dein Problem ist, zu 95% ist es das .

Du kannst jetzt folgendes machen:


1.)

export PATH=$PATH:/usr/local/bin
rm -f config.cache

absetzen, und danach noch einmal ./configure laufen lassen (schlecht).


2.)

Aus dem su-Modus herausgehen, als unpriviligierter User die avifile-0.6 Quellen noch mal neu entpacken, autogen.sh laufen lassen, ./configure ausführen und nur für den letzten Schritt, das "make install" mit

su -

root-Rechte besorgen (besser).
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Sonstiges Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy